ahci und windows 7

Dieses Thema ahci und windows 7 im Forum "Windows 7 Forum" wurde erstellt von caspar, 5. Nov. 2011.

Thema: ahci und windows 7 Ich habe ein das Mainboard Gigabyte X58A-UD3R mit einem Intelprozessor Core i7 930. Es sind 2 Seagate...

  1. Ich habe ein das Mainboard Gigabyte X58A-UD3R mit einem Intelprozessor Core i7 930. Es sind 2 Seagate Sata-Festplatten mit je 1 Tbyte fest eingebaut . Das Betriebssystem ist windows 7 Ultimate. Im Bios sind alle Satacontroller vor der installation von windows 7 auf AHCI gestellt worden. Ich arbeite seit der Installation ein Dreiviertel Jahr ungestört mit dem PC.
    Gestern habe ich mit Paragon Festplattenmanager 2011 Suite eine Partition vergrößert. Neben der Systemfestplatte war 150 GB unformatiert und um diesen Betrag habe ich die Partition rechts davon
    (nicht die Systemfestplatte) vergrößert.
    Seitdem fuhr nicht nur Windows 7 nicht mehr hoch, sondern ich kam auch nicht mehr ins Bios.
    Wenn ich das Bios durch entfernen der Stützbatterie zurücksetze, kann ich das Bios anwählen. Aber sowie ich wieder Ahci einstelle, erscheinen nur ein paar Zeilen mit einer 23 rechts oben und dann steht alles still.
    Wenn ich die Bioseinstellungen auf default lasse, kann ich Windows 7 wiederbeleben mit der Windows 7 DVD. Ich hätte aber gerne wieder die AHCI-Einstellungen.
    MfG caspar
     
  2. Einfach mittels der Win-DVD eine Reparatur durchführen, sollte doch reichen.
    AHCI hast du ja richtigerweise wieder eingestellt. Eigentlich also richtig.

    Oder das Wiederbeleben ohne AHCI, in der Windows-Registry den Wert ändern,
    dann im BIOS auf AHCI stellen.

    Die 23 ist möglicherweise ein Ablaufcode aus dem BIOS und zeigt an, in welchem
    Schritt das BIOS gerade ist.
    Ändern sich die Zahlen normalerweise beim Booten (2-stelliger Hex-Code)?
    23 würde bei deinem Award-BIOS bedeuten: Initialisiere Slot3.
     
  3. Hallo, heisepaul,
    vielen Dank für Deine Antwort.
    Beim normalen Hochfahren sehe ich keine Zahlen. Ich bin verfahren wie Du vorgeschlagen hast, aber sowie ich im Bios auf AHCI umstelle, zeigt sich wieder beim Hochfahren erst eine 10 und dann die 23 und dann rührt sich nichts mehr. In der Registry steht der Schlüssel Start in HKLM\System\CurrentControlset\services\msahci auf Null, wie es sein soll. Ich kann, nachdem ich im Bios auf AHCI umgestellt habe, nicht einmal von DVD starten. Wenn ich alles auf IDE lasse, habe ich keine Probleme.
    MfG caspar
     
  4. Sind die Laufwerke in der richtigen Reihenfolge angeschlossen?
    Also am ersten SATA-Port die Bootplatte, dann eventuelle Datenplatten und schließlich
    die optischen Laufwerke.

    Eventuell ist noch eine Einstellung vonnöten. Welche, kann ich leider nicht sagen.
    Aber eine gute Seite für Gigabyte-Boards ist:

    http://www.jzelectronic.de/jz2/index.php

    Dort nach Anleitung suchen, auf Gigabyte™ BIOS Anleitungen klicken und dein
    Board auswählen. Nun hast du zu den meisten Einstellungen eine mehr oder weniger
    gute Erklärung.

    Ein Direktlink ist leider nicht möglich.
    Mit Opera12 funktioniert die Seite besch.....eiden. Also nicht wundern, falls du den
    verwendest.

    Eine Überprüfung der Bootplatte mit einem Tool vom Hersteller sowie
    chkdsk /f /r (als Admin) + Neustart kann auch nicht schaden.

    P.S.
    Das mit den Zahlen müsste ich sehen. So kann ich mir nichts drunter vorstellen.
    Kannst ja mal googeln, was die bedeuten oder ins Handbuch gucken.
    Vielleicht sind es ja Ablaufcodes, wie bei meinem ASRock-Board.
    Dann könnte man den Fehler weiter eingrenzen.
     
  5. Hallo, heisePaul,
    vielen Dank für deine viele Mühe.
    Ich habe die von Dir angegebene Seite besucht , dort werden optimale Einstellungen für mein Board angegeben und es wird die IDE-Einstellung empfohlen. Da ich im Moment auch eigentlich keine Zeit habe, mich um das AHCI-Problem zu kümmern, belasse ich es erst einmal bei IDE. Merkwürdig ist es schon, dass es über ein Jahr bei gleichen Hardwareverhältnissen und mit AHCI problemlos lief.
    MfG caspar
     
  6. Ich würde noch einmal prüfen, ob sich eventuell eine Registry- Einstellung verändert hat.
    Im IDE- Modus booten und in der Registry zum Pfad

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci

    gehen. Der Wert für Start auf der rechten Seite muß zwingend auf 0 (Null) stehen.

    Jürgen
     
Die Seite wird geladen...

ahci und windows 7 - Ähnliche Themen

Forum Datum
Windows 7 startet im AHCI-Modus nicht mehr Windows 7 Forum 13. Feb. 2014
Windows XP in AHCI vs. IDE Windows XP Forum 4. Jan. 2012
Windows XP und AHCI Windows XP Forum 27. Nov. 2010
AHCI-Modus Treiber Problem für Samsung SDD Festplatte ? Windows 7 Forum 8. Juni 2014
Problem für SDD Platte AHCI-Modus einzurichten Windows 7 Forum 7. Juni 2014