Alternativtext im IMG-Tag

Dieses Thema Alternativtext im IMG-Tag im Forum "Webentwicklung, Hosting & Programmierung" wurde erstellt von Michael_B, 29. Okt. 2002.

Thema: Alternativtext im IMG-Tag Hallöchen, hab da mal ne kleine Frage: ist es möglich den Alternativtext im IMG-Tag bei HTML mehrzeilig zu...

  1. Hallöchen,

    hab da mal ne kleine Frage: ist es möglich den Alternativtext im IMG-Tag bei HTML mehrzeilig zu gestalten. Das wäre sehr nützlich um große Texte darzustellen.
    Habs schon mit dem <br> (und auch mal mit \n) ausprobiert, aber das funzt so net. die Sachen werden einfach mit dargestellt. D. h. aus einem <img src=... alt=erstezeile<br>zweitezeile\ndrittezeile> sieht der Alternative Text genauso aus wie im IMG-Tag.

    Vielleicht kennt da ja jemand ne Möglichkeit. Ich bin mir eigentlich ziemlich sicher, dass ich das irgendwo im Netz schon mal gesehen hab.

    Vielen Dank
     
  2. hi, im IE geht das mit 

     
  3. Danke... das ist ja schonmal was.
    Werde das dann noch auf anderen Browsern testen.

    Michael
     
  4. Warum machst DU nicht ein Mousover-Javascript hin oder DHMTL ?
    Das wirkt doch viel professioneller als die doofen alt-Texte. Die sind doch eigentlich nur dazu da, falls das Bild nicht geladen wird, zu sagen, dort sollte das und das Bild sein und für die Suchmaschinen.
     

    Anhänge:

  5. Eigentlich bin ich kein Freund von JavaScript, da ich schon möchte, dass der Inhalt bei allen Usern gleich angezeigt wird. Da das mit den Zeilenumbrüchem im alt-Attribut aber nur vom IE vernünftig dargestellt wird, werd ich wohl auf die JavaScript-Möglichkeit zurückkommen müssen.

    Danke für den Tipp

    Michael
     
  6. Hallo zusammen,

    ich habe hier 2 Laptops mit Win7 stehen. Funknetz vom Nachbarn, er hat uns seinen Schlüssel gegeben. Der eine Laptop hat Verbindung, der andere nicht. Beide haben dieselbe Wireless Karte Atheros RA 9285 und mittlerweile auch denselben Treiber (Version 9.1.0.334). Bei dem 1. Laptop (Sony VPCEJ1J1E gekauft Sept 2011) der Netz hat, steht in den Eigenschaften bei erweitert 802.11 Bluetooth High Speed, Wert: enabled. Das steht bei dem älteren zweiten Modell (Sony VPCEF3E1E gekauft Sommer 2010) nicht. Dort steht 802.11b Preamble Wert: Long and short. Ich vermute das ist der Haken. Ich habe schon mehrere Treiber installiert, auch Bluetooth Treiber, aber keine Änderung. Mit den veralteten Treibern von 2009 hatte ich wenigstens das Netz des Nachbarn gesehen und ich hatte 3 bis 4 Balken in der Anzeige, aber nach Eingabe des Schlüssels keine Verbindung. Mit den neuen Treibern ist nicht mal ein Netz verfügbar. Ich wäre sehr dankbar für Hilfe, ich sitze nun schon seit 3 Tagen an diesem Problem. Es ist sicher nur eine Kleinigkeit, ich komm nur nicht drauf :) Habt ihr Rat?
    Gruss Mookait
     
  7. Norm. reichen die pre-Werte vollkommen aus. Wennst das Netz wieder siehst mal die Verschlüßelung (WEP / WAP ) deaktivieren, evtl. ist eine MAC-Sperre beim Router aktiv?
     
  8. Danke für die Antwort. Auf den Router habe ich keinen Zugriff. Mein Nachbar ist die nächsten Wochen nicht da. Zudem hat er keine Ahnung von seiner Technik und ich will da auch nichts dran rummachen. Ich dachte es wäre ganz klar ein Treiberproblem meinerseits, weil die Laptops beide gleich sind, und der eine Netz hat, der andere aber nicht. Wie kann ich den ohne Netz dazu bringen dass der auch "802.11 Bluetooth High Speed" hat? Oder kann es sein, dass die eine Atheros Karte mehr kann als die andere obwohl sie beide gleich heissen? Die Verschlüsselung ist übrigens WPA2-PSK
     
  9. Bzgl. der Speks musst schon auf die Herstellerseite schauen. Lösche alles was mit dem Netzwerk zu tun hat - inkl. Treiber und installiere den Treiber neu. Erstmal musst den Router zu sehen bekommen. Wenn eine MAC-Sperre aktiv ist kommst ohne Nachbarn sowieso nicht ran - ausser du hast Zugriff!
    Auch ein anderer WLAN-Kanal wirkt oft schon Wunder...