Apache Problem

Dieses Thema Apache Problem im Forum "Webentwicklung, Hosting & Programmierung" wurde erstellt von NExY, 13. Okt. 2004.

Thema: Apache Problem Hi! Dies ist ein etwas spezielles Problem und deswegen wäre ich sehr froh nur Antworten von Leute zu bekommen, die...

  1. Hi!
    Dies ist ein etwas spezielles Problem und deswegen wäre ich sehr froh nur Antworten von Leute zu bekommen, die damit auch wirklich etwas anfangen können. So Sachen wie->Haha hättest du das mal nicht gemacht' kann sich jeder sparen, ich will einfach nur Hilfe, ok? ^^

    Also ich habe folgendes Problem:
    Aufgrund der der vielen Sicherheitslücken in Windows und den ganzen Würmern etc habe ich nach einer guten Lösung gesucht wie ich das alles von meinem Rechner verhalten kann. Eine Personal Firewall kann man jawohl total vergessen...jeder der sich ein wenig mit PCs auskennt dürfte wissen das die es überhaupt nicht bringen. Wer suchet, der nach langer langer Zeit auch findet und schließlich habe ich eine Anleitung im Internet gefunden wie ich ganz einfach die gefährlichen Ports schließen kann. Dies ging flucks mit einem Programm und nachdem einige benötigte Dienste dann reaktiviert waren hatte ich einen sicheren Rechner, alles funktioniert, wunderbar.

    Nun habe ich aber ein Probelm entdeckt, was mir vorher nie aufgefallen ist. Mein Apache Server, den ich früher zur Entwicklung von PHP-Pages benutzt habe funktioniert nichtmehr richtig. Bin ich im Internet und starte ihn, so lässt es sich ganz normal über internetremote also über die Internet-IP abrufen und ich kann somit auf den PHP-Parser etc zugreifen.
    Wenn ich aber über localhost oder 127.0.01 darauf zugreifen will, also nicht über das Internet, so kommt immer die Fehlermeldung:

    Die Firefox meldung gibt ja schon ein wenig Aufschlüsse (change the port etc) aber hier kommt eben mein Problem. Ich weiss nicht wo ich unter Windows XP Professional einzelne Ports einstellen kann und Proxy sagt mir auch nichts!

    Das einzige was ich Netzwerktechnisch seit meiner letzten Homepageerstellung gemacht habe ist das mit dem Programm, wie oben beschrieben und ein Bluetooth Dongle installiert, woran es aber eher nicht liegen kann (oder?!).

    Also kann mir da jemand helfen und mich an zumindest an ein anderes Forum weiterempfehlen? Ich brauch den Webserver dringend wieder. Also schnelle Hilfe wäre ganz gut!

    Achja und an alle die jetzt denken:->dann bleib doch einfach den ganzen Tag on und nutz den Apache übers Inet', dennen ist zu sagen->ich hab nur ISDN und keine Flat!!1' ;)

    Vielen Dank schonmal an jeden der sich dem Prob angenommen hat und mir vielleicht weiterhelfen kann.

    Euer
    NExY

    *edit*-> vergessen:
    1. OS::Windows XP Professional SP1
    2. über Netzwerkip->192.168.0.1 geht es auch nicht

    verschoben von Windows XP
     
  2. hp
    hp
    den port kannst du in xp nicht setzten, wenn dann im apache selber und in der datei services, so daß er statt port 80 den port 8080 benutzt. was du aber mal probieren kannst: im internetexplorer unter extras/internetoptionen/verbindungen/einstellungen/proxyserver die checkbox proxy für lokale adressen umgehn aktivieren und unter proxyserver erweiter in dem feld ausnahmen, die ip adresse 127.0.0.1 und die richtige ip deines rechners eintragen ... die hosts datei muß auch richtig sein, natürlich auch die services, falls du http über den port 8080 ansprichst...

    greetz

    hugo
     
  3. ich hab das jetzt mal mit dem normalen Port 80 ausprobiert, da ging es aber auch nicht.
    Wo kann ich den Port denn ändern beim Apache? Kenn mich da leider nicht so dolle aus.
    Mensch irgendwie muss aber doch auch die Einstellung aber auch wieder Rückgänig gemacht werden können!
    Das ging doch immer so gut :-/
    Hilf vielleicht eine Neuinstallation des Apache?
     
  4. hp
    hp
    normalerweise horcht der apache auf port 80 (default http port). wenn du das in dem browser so eingibst http://127.0.0.1:80 oder http://localhost:80 solltest du auf den webserver kommen. voraussetzung ist, daß du die änderung im proxy so wie ich es dir beschrieben hab, gemacht hast und wenn du angeblich von außen draufkommst, so hortcht er ja auf den standardport ...

    greetz

    hugo
     
  5. wie stell ich denn den Port auf 8080?

    Geb ich im Internetexplorer nun http://127.0.0.1:80 (mit der Einstellung von hp) dann kommt wieder->ungültige Anforderung'
    kann man da nicht irgendwas machen?
    AH!
     
  6. Hi,

    was hast du den in der httpd.conf für NameVirtualHost eingestellt?
     
  7. da steht in etwa

    Code:
    #
    # Use name-based virtual hosting.
    #
    #NameVirtualHost *
    
    #
    # VirtualHost example:
    # Almost any Apache directive may go into a VirtualHost container.
    # The first VirtualHost section is used for requests without a known
    # server name.
    #
    #<VirtualHost *>
    #    ServerAdmin [email]webmaster@dummy-host.example.com[/email]
    #    DocumentRoot /www/docs/dummy-host.example.com
    #    ServerName dummy-host.example.com
    #    ErrorLog logs/dummy-host.example.com-error_log
    #    CustomLog logs/dummy-host.example.com-access_log common
    #</VirtualHost>
     
  8. Hier mein Beispiel für einen virtuellen Host, der auf Port 8080 hört:
    Code:
    Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost *:8080>
        ServerAdmin [email]void@domain.com[/email]
        ServerName [url]www.void-test.de[/url]
        DocumentRoot D:/4/Apache/public
        ErrorLog d:/4/apache/void-error_log
    </VirtualHost>
    
    <Directory D:/4/Apache/public>
        Options Indexes FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    
     
  9. Hi,

    hab grad ma mit nem Windows-Apache (von XAMPP) nen bissl rumgespielt, konnte den Fehler produzieren, da hing es mit dem Modul der SSL verschlüsselung zusammen, allerdings gibts bestimmt noch mehr Ursachen dafür.

    Benutzt du XAMPP und benötigst SSL nicht?

    dann ersetz in der ssl.conf einfach mal <VirtualHost _default_:443> durch <VirtualHost localhost:443> (Dann kann allerdings nur noch über https://localhost die SSL Verchlüsselten Seiten aufgerufen werden)

    Was du noch probieren könntest:
    ServerName [IRGENDWAS] auskommentieren (also ein # davor schreiben), allerdings das ServerName [IRGENDWAS] was nicht zwischen <VirtualHost [IRGENDWAS]>und </VirtualHost> steht.

    Ansonsten kannst du mir auch mal die httpd.conf und ssl.conf (falls es die gibt) schicken und ich probier hier mal nen bisschen aus, weiß allerdings noch nicht wann ich dazu komm.
     
Die Seite wird geladen...

Apache Problem - Ähnliche Themen

Forum Datum
apache unter xampp macht probleme Webentwicklung, Hosting & Programmierung 4. Apr. 2006
FTP-Server (Apache Web-Server)problem Netzwerk 20. Feb. 2006
Re: Ftp, Apache, .htaccess Windows XP Forum 27. Nov. 2011
Ftp, Apache, .htaccess Webentwicklung, Hosting & Programmierung 26. Nov. 2011
Apache lässt sich mit XAMPP nicht starten Windows XP Forum 1. Okt. 2011