Autoexec.bat

Dieses Thema Autoexec.bat im Forum "Windows 95-2000" wurde erstellt von Erich M., 23. Jan. 2005.

Thema: Autoexec.bat Hallo zusammen, seit einiger Zeit habe ich sehr lange Startphasen. Die Autoexec.bat hat sich ggü. der...

  1. Hallo zusammen,

    seit einiger Zeit habe ich sehr lange Startphasen. Die Autoexec.bat hat sich ggü. der ursprünglichen Installation deutlich verändert:

    AUTOEXEC.BAT / 09.09.02

    SET BLASTER=A220 I5 D1 H1 T4
    @echo off
    rem - By Windows Setup - lh C:\WINDOWS\COMMAND\mscdex /D:CD1
    rem - By Windows Setup - LH c:\treiber\mouse\mouse.com
    mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)
    mode con codepage select=850
    keyb gr,,C:\WINDOWS\COMMAND\keyboard.sys

    AUTOEXEC.BAT / 22.01.05

    SET BLASTER=A220 I5 D1 H1 T4
    rem - By Windows 98 Network - C:\WINDOWS\net initialize
    rem - By Windows 98 Network - ban /nc
    rem - By Windows 98 Network - ndisban
    rem - By Windows 98 Network - redirall
    rem - By Windows 98 Network - C:\WINDOWS\net start
    rem - By Windows 98 Network - arswait
    rem - By Windows 98 Network - z:login
    rem - By Windows 98 Network - C:\WINDOWS\net initialize
    rem - By Windows 98 Network - ban /nc
    rem - By Windows 98 Network - ndisban
    rem - By Windows 98 Network - redirall
    rem - By Windows 98 Network - C:\WINDOWS\net start
    rem - By Windows 98 Network - arswait
    rem - By Windows 98 Network - z:login
    @echo off
    rem - By Windows Setup - lh C:\WINDOWS\COMMAND\mscdex /D:CD1
    rem - By Windows Setup - LH c:\treiber\mouse\mouse.com
    mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)
    mode con codepage select=850
    keyb gr,,C:\WINDOWS\COMMAND\keyboard.sys

    PATH=%PATH%;C:\Programme\Mts

    Ein Netzwerk habe ich nicht; kann oder darf ich da einiges löschen?

    Besten Dank für eine Info!
     
  2. hp
    hp
    PATH=%PATH%;C:\Programme\Mts

    was soll der pfad? kennst du das programm? prüfe mal, ob da nicht ein trojaner dahintersteckt. die mit rem gekennzeichneten zeilen sind nur komentare, die werden überlesen, der rest ist, bis auf den pfad eigentlich gleich ... und poste mal auch die dazugehörige config.sys, vielleicht ist da auch was manipuliert worde. scan mal die kiste, onlinescanner gibts hier www.antivirus-online.de

    greetz

    hugo
     
  3. Hallo hugo,

    danke zunächst. Hier die config.sys
    device=C:\WINDOWS\himem.sys /testmem:eek:ff
    device=c:\treiber\cdrom\ecscdide.sys /D:cd1
    dos=high,umb
    device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
    Country=049,850,C:\WINDOWS\COMMAND\country.sys

    Wegen Mts - scheint mit Java(?) zu tun zu haben; kann ich hier irgendwor eine Datei hochladen (Inhalt des Dateimanagers)?
     
  4. Ansonsten ist an diesen Dateien nichts außergewöhnliches. Wenn Du beim Start die Taste F4 gedrückt hältst, werden Autoexec.bat und Config.sys nicht verarbeitet. Damit kannst Du feststellen, ob es an ihnen liegt oder nicht.

    Eine weitere Möglichkeit, beim Start die Taste F8 gedrückt halten und im Menü die Option Einzelbestätigung auswählen. Damit muss das Laden jeder Komponente extra bestätigt werden. Hier kann man unter Umständen feststellen, an welcher Stelle der Rechner so lange braucht.
     
  5. Ja Hallo erstmal,

    1. Frage welches Windows benutzt du?

    2. Brauchst du die Codeseitenumschaltung unter DOS, wenn nein kannst du in der config.sys vor die Zeile
    device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
    rem [Leerzeichen] setzen
    bei der Zeile
    Country=049,850,C:\WINDOWS\COMMAND\country.sys
    löscht du die 850, so dass dort dann 049,,c:\...... usw. steht. In der autoexec.bat setzt du vor die beiden Zeilen, welche mit mode.... beginnen ebenfalls jeweils ein
    rem [Leerzeichen]

    3. Funktioniert im DOS-Modus dein CD-LW? in der config.sys wird mit der Zeile
    device=c:\treiber\cdrom\ecscdide.sys /D:cd1
    zwar der Treiber geladen, in der autoexec.bat ist aber der LW-Zugriff
    rem - By Windows Setup - lh C:\WINDOWS\COMMAND\mscdex /D:CD1
    auskommentiert. Unter Windows ist das kein Problem, da diese Zugriffe selbst verwaltet werden. Wird der Treiber aktiviert, kann es dazu kommen, dass Windows dannn in den Kompatibilitätsmodus geht und dadurch langsamer wird. Musst du halt mal ausprobieren.

    sollte das Ganze dann sicher funktionieren, kannst du später alle Zeilen vor denen ein rem steht komplett löschen.
     
  6. hast Du in letzter Zeit eine Netzwerkkarte eingebaut?Hast Du dieser eine feste IP-Adresse zugewiesen?Sonst probiert Win98SE beim Start nämlich erstmal alle in seiner Datenbank vorhandenen aus..... und das dauert......
     
  7. Hallo zusammen,

    danke für die ergänzenden Infos zunächst. Die Tipps von bythom werde ich mal testen.

    Eine Netzwerkarte habe ich nicht neu eingebaut - aber ich habe mal wegen eines zusätzlichen Profils Änderungen vorgenommen; ich meine auch seither gibt es diese Zeilen mit rem....By ... Netzwerk.
     
  8. wenn Du nicht gerade häufig mit DOS oder alten DOS-Programmen arbeitest,kannst Du auf die autoexec.bat und die Config.sys sogar völlig verzichten.Win98SE braucht beide Dateien zum Betrieb überhaupt nicht.
     
  9. Das ist nun auch wieder wahr.
     
  10. Hallo wakku,

    unter DOS arbeite ich so gut wie gar nicht. Könnte ich hier noch optimieren? Oder ist das zu gefährlich, wenn Windows aus irgendwelchen Gründen mal nicht startet.

    Danke!