Autostart Verzögern??

Dieses Thema Autostart Verzögern?? im Forum "Windows 95-2000" wurde erstellt von Mayrix, 14. Jan. 2004.

Thema: Autostart Verzögern?? Hallo Leute, ich habe ein problem, das ich ein tool habe welches mit Windows Startet! Dieses tool baut eine...

  1. Hallo Leute,

    ich habe ein problem, das ich ein tool habe welches mit Windows Startet!
    Dieses tool baut eine Verbindung zu meinen Router über Netzwerk auf!

    jetzt habe ich aber meine Netzwerkkarte raus und habe eine Wireless Karte eingebaut! Diese braucht nach dem starten aber ein wenig bis sie verbindung zum Router hat!

    in dieser zeit versucht aber mein tool auch die Verbindung mit dem Router, findet diesen nicht und schaltet ab!

    Wie kann ich in der Registrie einen Autostart Eintrag so bearbeiten, das mein tool eventuell erst nach 20 Sekunden Automatisch gestartet wird?
    Gibt es da eine Möglichkeit?

    Ich würde mich freuen wenn mir jemand Helfen könnte!

    Gruß Mayrix
     
  2. Hallo,

    Du könntest das mit einer Batch erledigen, die Du dann anstatt Deines Tools in der Autostart legst.

    Mit Notepad eine .txt-Datei erstellen, Namen geben mit der Endung .bat, aktivieren und die Abfrage ignorieren.

    Rechtsklick auf diese Datei und Bearbeiten auswählen und dann ff. eintragen:

    ________________ab hier
    @echo off
    cls
    choice /c:jn /n /t:j,20>nul
    hier der gleiche Eintrag Deines Tools wie im Autostart
    cls
    -----------------------bis hier

    Danach Datei speichern und schließen.

    Die 20 in der 3. Zeile sind die Sekunden, die kannst Du von 01 - 99 beliebig verändern.

    Diese Batch in einem Verzeichnis ablegen, die Registry öffnen und diese Batch dann dort anstelle Deines Tools eintragen mit Laufwerk:\Verzeichnis\Name.bat.

    Wenn Du mit Rechtsklick auf diese Batch dann noch auswählst Reiter Programm > Ausühren und hier minimiert, wird kein Fenster für diese Batch geöffnet.

    MfG maneich
     
  3. @maneich,

    Ich Danke Dir, ich werde es einmal so versuchen!

    Gruß Mayrix
     
  4. @maneich,

    Eine Frage habe ich noch:

    Wie finde ich den richtigen Eintrag??
    Denn dort sind ja xx Einträge zu dem tool!

    Gruß Mayrix
     
  5. Hallo,

    da ich das Tool nicht kenne und auch nicht weis, wo es sich überall in der Registry eingetragen hat, kann ich also nur sagen, in welchem Registry-Schlüssel die Programme mit Windows gestartet werden.

    1. startet wenn Windows noch nicht vollständig geladen ist
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunServices

    2. startet nachdem Windows geladen ist
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    3. startet sonstige Fremdprogramme ganz zum Schluss
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

    Sicher ist Dein Eintrag unter 1. oder 2. zu finden und es sollte auch nur ein Eintrag für den Verbindungsaufbau zuständig sein.

    Auch Deine Wireless Karte bzw. der Verbindungsaufbau muß hier ja in einem der Schlüssel eingetragen sein oder in der Datei Win.ini oben unter load oder run.

    Wenn Du nicht weiter kommst, melde dich nochmal mit Infos über
    1. welches Tool Verbindung aufnehmen will und
    2. mit welchem Eintrag es sich unter 1.,2. oder 3. oben eingetragen hat und
    3. wo der Verbindungsaufbau Deiner Wireless Karte eingetragen ist.

    MfG maneich
     
  6. Ja ich werde es testen!

    Zur Info:

    ich habe pyAnyware drauf und in diesen einen host eingerichtet!
    Jetzt Meldet sich der host bei Windows start warscheinlich am Router an, aber da ja die Wireless Verbindung noch nicht besteht, bekomme ich keine host verbindung!

    Ich teste jetzt noch einmal, und melde mich falls es Probleme gibt!

    Übrigens meine Wireless Karte (D-Link) finde ich in keinen der 3 Einträgen!

    Gruß Mayrix
     
  7. Also es geht so auch nicht!

    Das Problem ist folgendes:

    mache ich es mit einer XX.txt Datei, wird diese geöffnet, aber das Programm nicht!
    Wenn ich eine Verknüpfung zu dem Programm anlege, startet dieses darüber ganz normal! Auch im Autostart geht es mit dieser Verknüpfung! Aber sobald ich es mit der bat und dem selben Pfad versuche, wird es nicht gestartet!

    Woran könnte das liegen, da muß doch irgend wo ein Fehler bei mir sein!

    Gruß Mayrix
     
  8. Hallo,

    die xx.txt Datei mußt du noch umbenennen in xx.bat.
    Also Rechtsklick auf diese Datei und Umbenennen auswählen und dann in dem Kästchen mit dem Namen xx.bat eintragen und aktivieren. Die Abfrage, daß dadurch die Datei umbrauchbar werden könnte, ignorieren.

    In der Batch muß natürlich das stehen, was in der Registry für den Programmaufruf bzw. den Verbindungsaufbau für dieses Programm eingetragen ist.

    Danach weiterverfahren, wie bereits beschrieben.

    MfG maneich
     
  9. OK ich teste noch ein wenig!

    Danke für Deine Hilfe!

    gruß Mayrix
     
Die Seite wird geladen...

Autostart Verzögern?? - Ähnliche Themen

Forum Datum
Siehe Diashow für 2. Monitor per Autostart Software: Empfehlungen, Gesuche & Problemlösungen 29. Jan. 2016
Autostart, Internet Explorer und eine duale Grafikarte Windows 7 Forum 6. Mai 2015
Problem mit Autostart bei Windows Windows 7 Forum 22. Nov. 2014
Kontextmenü - Autostart Windows 7 Forum 10. März 2014
autostartprogramme Windows XP Forum 27. Okt. 2013