batch: problem beim anlegen von verzeichnissen auf gemapte lw

Dieses Thema batch: problem beim anlegen von verzeichnissen auf gemapte lw im Forum "Webentwicklung, Hosting & Programmierung" wurde erstellt von jan2, 19. Juli 2008.

Thema: batch: problem beim anlegen von verzeichnissen auf gemapte lw hi ! ich habe ein skript bei dem mit mkdir unter xp verzeichnisse angelegt werden. das merkwürdige ist nun, dass...

  1. hi !

    ich habe ein skript bei dem mit mkdir unter xp verzeichnisse angelegt werden.

    das merkwürdige ist nun, dass dieses anlegen auf einem lokalen lw funktioniert - bei einem gemapten lw hingegen nicht.

    hat einer von euch ähnliche erfahrungen gesammelt und wie habt ihr das umschifft ?

    ps: an dden berechtigungen sollte es nicht liegen - im explorer können entsprechende verzeichnisse angelegt werden.

    gruß Jan .-)
     
  2. mkdir ist nicht in der Lage, zwischen Netzlaufwerk und lokalem Laufwerk zu unterscheiden. Was passiert denn, wenn du mit mkdir einen Ordner anlegen willst, wie lautet die Ausgabe/Fehlermeldung?
     
  3. hp
    hp
    ansonsten versuch es mal über den unc-pfad, also so md \\rechner_mit_freigabe\freigabe\verzeichnis wobei bei rechner_mit_freigabe auch die ip-adresse stehen kann ...

    greetz

    hugo
     
  4. moin !

    @twoday: beim erstellen selber kommt keine meldung. erst wenn in dieses verzeichnis daten kopiert werden sollen kommt es zu einer zugriffsverletzung.

    @hp: unc hat bis dato keinen erfolg gebracht. mit der ip-adresse habe ich das noch nicht ausprobiert - werde ich aber am montag einmal testen.

    gruß Jan :)
     
  5. Ob UNC, Computername oder IP-Adresse dürfte egal sein. Eine Zugriffsverletzung deutet auf ein Berechtigungsproblem.
     
  6. hp
    hp
    da hat tüüt natürlich recht ... solche infos gehören auch in den ersten post mit rein, damit man nicht falsche tips postet. also mal die berechtigungen in der freigabe überprüfen. und uns die nötigen infos´s zukommen lassen, wenn wir weiter helfen sollen: welches xp? sind server oder w2k kisten im spiel? einfache freigabe aktiviert? gast account aktiviert (wenn einfacher freigabe aktiviert ist) bzw. ist der gast-account deaktiviert? benutzer auf allen kisten angelegt wenn keine einfache freigabe aktiviert ist? gruppe jeder schreibrechte auf die freigeabe? etc pp.

    greetz

    hugo
     
  7. Aha - dann ist auch mkdir gar nicht das Problem.
    Wie sehen die Berechtigungen auf der Freigabe denn aus?
    Vererbung aktiv?
     
  8. hi !

    ich glaube da ist etwas falsch verstanden worden !

    die meldung bzgl. der zugriffsverletzung kommt beim KOPIEREN in ein verzeichnis das mit MKDIR angelegt werde SOLLTE - aber nicht wurde !!!

    wenn es das verzeichnis nicht gibt, dann kann das kopieren auch nicht in dem angegebenen, weil nicht vorhandenen verzeichnis, auch nichts ablegen !!!

    gruß Jan :)
     
  9. Ich glaube eher, dass du da nicht ganz durchblickst.

    Beim Kopieren auf einen nicht vorhandenen Pfad kommt keine Zugriffsverletzung, sondern die Fehlermeldung:

    Das System kann den angegebenen Pfad nicht finden.

    Willst du dich nicht erst mal sachkundig machen, bevor du weiter antwortest und die angesprochenen Punkte mal durchgehen?
    Man kann nach md bzw. mkdir auch einfach nachsehen, ob der Pfad existiert. ::)
     
Die Seite wird geladen...

batch: problem beim anlegen von verzeichnissen auf gemapte lw - Ähnliche Themen

Forum Datum
Probleme beim Ausführen einer Batch-Datei Windows XP Forum 5. Mai 2013
batch: problem mit der änderung des dateisuffix Windows XP Forum 3. Dez. 2009
Problem beim Ausführen einer Batchdatei Webentwicklung, Hosting & Programmierung 22. Okt. 2009
Batch-Problem mit IF-Abfrage Webentwicklung, Hosting & Programmierung 31. Juli 2009
problem mit ausführen einer batch in einem anderen verzeichnis Windows XP Forum 15. Dez. 2008