Blätter verknüpfen xls 2000

Dieses Thema Blätter verknüpfen xls 2000 im Forum "Microsoft Office Suite" wurde erstellt von bergfranke, 26. Feb. 2006.

Thema: Blätter verknüpfen xls 2000 Bin in der Excelhilfe nicht richtig fündig geworden. Folgendes Problem: Ich habe auf einem Blatt eine Namensliste...

  1. Bin in der Excelhilfe nicht richtig fündig geworden.
    Folgendes Problem:
    Ich habe auf einem Blatt eine Namensliste mir ca 1500 Namen, die laufend aktualisiert und erweitert wird. Sie enthält 15 Spalten (Name, Vorname, geb. usw)
    Diese möchte ich zusätzlich ! Alphabetisch auf weitere Blätter anordnen.
    Also Blatt 1 = Alle Namen
    Blatt 2 = Alle Namen mit A
    Blatt 3 = Alle Namen mit B usw.
    Wobei u. U. auch nur ein (Nach)Name auf ein Blatt soll.
    Wie kann ich nun erreichen, dass Änderungen in 1 auch auf die anderen Blätter übernommen werden.
    Weiters Problem.
    Wenn ich neue nun neue Namen in 1 einfüge. Soll ich da an der richtigen Stelle Zellen einfügen oder den Namen ans Ende setzen und neu ordnen. Wie wirkt sich das auf die weiteren Blätter aus. Oder muss ich die neue Zeile manuell ind das alphabetisch passende Blatt einfügen.
    gruss clasaf
     
  2. Noch mal hoch schupps ;)
    Wenn so etwas nicht geht, wäre es auch eine Antwort.
    gruss clasaf
     
  3. Da mußt du in die erste Seite eine Hilfsspalte einfügen, welche dir bei jedem Namen den Anfangsbuchstaben und eine Ordnungsnummer gibt. Dann in den Einzelblättern per SVERWEIS abfragen. Kann aber eine zieblich große Datei werden.

    Schick mal die Datei rüber (alle Tabellenblätter bereits angelegt!), dann bastel ich dir ein Beispiel für A und poste die Lösung hier nachdem ich sie am konkreten Beispiel herausgepfriemelt habe.
     
  4. Danke für Dein Angebot. Muss das mit dem Aufteilen erst noch machen. Habe im Moment erst nur nur die Tabelle 1 (gesamt), weil ich erst noch auf eine Lösung gewartet habe. Schicke Dir die Mappe dann zu, wenn sie fertig ist.
    Noch eine Frage dazu. Blätter oder Teile davon kann ich doch dann auch ohne Verweis wieder in eine andere Mappe kopieren?
    gruss clasaf
     
  5. Ja, aber nur als Werte einfügen, sonst ziehst du den Formelkram mit, was zu falschen Verknüpfungen führt.
     
  6. Danke. das klappt ja bei Dank eines früheren Hinweises von Dir mit dem entsprechenden Button.  :)
    Werde die Mappe wohl morgen fertig machen und kommt dann zu Dir.
    gruss clasaf
     
  7. Mein Vermächtnis: Der Werte-einfügen-Button 8)
     
  8. Die Lösung in einer allgemeinen Form für die Allgemeinheit:
    In die Gesamttabelle (Blattname Gesamt) wird vorne noch eine Spalte eingefüft, so daß der Familienname jetzt in Spalte B ist.
    In A2 Kommt folgende Formel:
    =LINKS(B2;1)&TEXT(WENN(LINKS(B1;1)<>LINKS(B2;1);1;RECHTS(A1;3)+1);000)
    Formel bis zum letzten Datensatz runterziehen.
    Die bewirkt, daß die Datensätze mit gleichem Anfangsbuchstaben durchgezählt werden: A001, A002, A003,...B001, B002, B003,... Hierbei ist es egal, ob es mehrere gibt, die Müller heißen.
    Mit der vorliegenden Formel geht das für bis zu 999 Datensätze pro Anfangsbuchstabe.

    In die anderen Tabelllenblätter kommt eine Tabelle der gleichen Struktur wie die Gesamttabelle. In diesen Blättern wird in Zelle A1 der jeweilige Anfangsbuchstabe geschrieben, der auf diesem Tabellenblatt aufgelistet werden soll. Es ist nur ein Anfangsbuchstabe pro Tabelle möglich.
    Zelle A2: =$A$1&TEXT(WENN(C1=Name;1;RECHTS(A1;3)+1);000)
    Zelle B2: =WENN(SVERWEIS($A2;Gesamt!$A:$P;2;FALSCH)=;;SVERWEIS($A2;Gesamt!$A:$P;2;FALSCH))
    Achtung, hier hatte ich einen Fehler:
    Zelle C2: =WENN(SVERWEIS($A2;Gesamt!$A:$P;3;FALSCH)=;;SVERWEIS($A2;Gesamt!$A:$P;3;FALSCH))
    usw.
    Formeln runterziehen bis mindestens eine Zeile unterhalb der Anzahl der Ergebnisse. So hat man immer als letztes eine Fehlerzeile, die einem Bestätigt, daß es in der Hauptliste nicht mehr Datensätze gibt, as man in der Zielliste verformelt hat.
    So läuft es.
     
  9. Auweia, die Rübe raucht beim Dau. Bei den Formelmonstern bekomme ich Alpträume. ;D
    Also mit Formel in A2 ist klar. Geht jetzt auch in der Tabelle. Auch ändern und neuer Name einfügen hat geklappt. Übertragen erfolgt erst nach Speichern, das hatte ich natürlich wieder nicht kapiert. ::). Bin nur gespannt, wie ich mit komletter neuer Seite fertig werde.  ;)
    machs wohl am besten nach und nach über >Inhalte einfügen.
    Nur was ich jetzt noch mit den Formeln für B2 machen soll, kapiere ich nicht. Die Zelle ist ja auch in Deinen fertigen Blättern leer.
    Natürlich noch mal besten Dank.
    gruss clasaf
    edit. Blatt komplett einfügen hat geklappt! :)
    Eine Frage noch: Daten sortieren.
    Geht das und wo machen. Wohl in Blatt 1 am besten. Name in Spalte C ist natürlich immer erste Sortierspalte.
    gruss clasaf
     
  10. In deiner Tabelle ist in den Buchstabenblättern in Spalte B nix. Das liegt daran, daß ich in der Gesamtliste für deine Tabelle eine weitere Hilfsspalte zur Erkennung der Ausnahme-Namen eingefüht habe. Das habe ich hier in der Lösung für die Allgemeinheit ausgelassen. Diese Spalte braucht man in den Buchstaben-Tabellen nicht, aber um die Spaltenintegrität zu erhalten, habe ich dort jeweils eine Leerspalte eingefügt.

    Sortieren solltest du nur in der Gesamttabelle.
    Spalte C ist natürlich letzte Sortierspalte, denn man sortiert immer von hinten, also erst nach Vorname und danach erst nach Familienname.
     
Die Seite wird geladen...

Blätter verknüpfen xls 2000 - Ähnliche Themen

Forum Datum
Excel - Werte unterschiedlicher Tabellenblätter für Übersicht automatisch ziehen Microsoft Office Suite 22. Aug. 2010
Frage zum Drucken von Excel-Datenblättern Microsoft Office Suite 2. Juni 2010
Re: Liste bestimmter Werte aus allen Tabellenblättern erstellen Windows XP Forum 12. Mai 2009
Liste bestimmter Werte aus allen Tabellenblättern erstellen Windows XP Forum 12. Mai 2009
Deckblätter Kartenspiel ASolitär Windows XP Forum 12. Juni 2008