Calc - Summe nach Monaten

Dieses Thema Calc - Summe nach Monaten im Forum "StarOffice, OpenOffice und LibreOffice" wurde erstellt von kreakustik, 2. Juli 2003.

Thema: Calc - Summe nach Monaten Hallo! Ich habe ein (Anfänger?)-Problem mit Calc. Ich möchte so etwas wie ein Rechnungsbuch erstellen. Ich habe in...

  1. Hallo! Ich habe ein (Anfänger?)-Problem mit Calc. Ich möchte so etwas wie ein Rechnungsbuch erstellen.

    Ich habe in der Spalte A das Datum der Rechnung, dann in Spalte B den Betrag. Nun möchte ich die Gesamtumsätze pro Monat ausrechnen lassen. Mein Problem ist aber, dass es zwar funktioniert, wenn ich zur Abfrage genaue Daten eingebe (also für Januar z.B. 01.01.2003 bis 31.01.2003). Ich möchte das ganze aber unabhängig von Jahreszahlen haben, d.h. ich möchte nur den Monat auslesen und nicht ein absolutes Datum.
    In Excel habe ich folgende Formel, die auch funktioniert:

    =SUMME(WENN(GANZZAHL(MONAT(A1:A15))=1;B1:B15))

    Bei Calc funktioniert das aber nicht, da rechnet er mit dieser Formel immer alles zusammen und berücksichtigt nicht die Monate.
     
  2. OLa,

    ich war so erstaunt, dass ich die Formel probiert habe (unter Excel) Bei mir zeigt die Formel den (für mich nicht unerwarteten) Fehler #Wert! an. Das sollte auch so sein, da als Parameter für Monat nur eine Zahl, nicht aber ein Bereich gültig ist.

    Wenn es bei Dir tatsächlich funktionert, bin ich an der Tabelle interessiert...
     
  3. sol
    sol
    Hast Du dich schon mal mit dem Datenpilosten beschäftigt? Vielleicht findest Du da eine Lösung
    Gruss, claudia
     
  4. itz
    itz
    Hallo,

    wie wärs mit einer Hilfsspalte (hier z.B. Spalte C)?
    Annahme: Daten in Spalte A, Beträge in Spalte B
    • Formel in C1: =MONAT(A1)
    • Formel für den ganzen Bereich runterkopieren (am besten gleich die ganze Spalte)
    • Spalte C bei Bedarf ausblenden
    • Formel für Deine Berechnung
      für Januar: =SUMMEWENN(C1:C15;1;B1:B15)
      für Februar: =SUMMEWENN(C1:C15;2;B1:B15)
      ...etc.
    So long,
    Steffan.
     
  5. ;D

    @itz: wäre auch mein Vorschlag, auch unter Excel. Monat() liefert die Zahl und SummeWenn wertet aus. Eventuell könnte die Zahl des Monats noch in eine Zelle extra, bsp. F1. Dann reicht eine Formel SummeWenn:
    =SUMMEWENN(C1:C15;F1;B1:B15)

    Wenn dann in F1 die Zahl verändert wird, ändert sich das Ergebnis in den gewünschten Monat
     
  6. Hallo, erstmal danke für Eure Antworten.
    Bei mir funktioniert unter Excel XP die Formel problemlos - auch in der englischen Version:

    =SUM(IF(ABS(MONTH(A1:A4))=3;B1:B4))

    Also mit einem Bereich als Monatsangabe. Wichtig ist, sie mit STRG+Umschalt+Enter abzuschließen. Aber wie gesagt, unter Calc gehts immer noch nicht... Geht es vielleicht auch erst seit XP?



     
  7. Ola,
    das erklärt doch alles ;D

    ich denke nicht, dass Du damit unter StarCalc erfolg hast: Die Funktionalität von Calc ist Excel zwar ähnlich, aber nicht identisch. Versuch den Weg, den Itz vorgeschlagen hat.
     
  8. itz
    itz
    Unter Excel funktioniert die Array-Formel wirklich bestens (s.a. http://www.excelformeln.de/formeln.html?welcher=183).
    Lt. Online-Hilfe von Oo_Org werden dort ebenfalls Arrays in Formeln unterstützt, aber irgendwie klappt es bei mir genausowenig.
    Deshalb also die Frage:
    Hat jemand schon Erfahrungen mit Arrays in Formeln in SO/Oo_Org gesammelt was sind die Unterschiede zu dieser Funktion in MS-Office?

    Steffan.
     
Die Seite wird geladen...

Calc - Summe nach Monaten - Ähnliche Themen

Forum Datum
Import Datensatz inkl = und - Zeichen in Excel/Libre CALC Software: Empfehlungen, Gesuche & Problemlösungen 20. Mai 2016
calc.exe verschwunden Software: Empfehlungen, Gesuche & Problemlösungen 9. Apr. 2013
LibreOffice Calc: Zeitdifferenz berechnen und als Industriestunden anzeigen StarOffice, OpenOffice und LibreOffice 26. Jan. 2013
LibreOffice Calc: Datum wird nicht richtig angezeigt nach Formatierung Windows XP Forum 26. Jan. 2013
StarOffice Calc Windows XP Forum 31. Mai 2012