CD-Autostart wiederbeleben

Dieses Thema CD-Autostart wiederbeleben im Forum "Windows XP Forum" wurde erstellt von KFSoftware, 2. März 2006.

Thema: CD-Autostart wiederbeleben Hallo zusammen, auf meinem System (Intel P4 2.8 GHz, XP Professional SP2) ist das Autorun-Feature der CD-Laufwerke...

  1. Hallo zusammen,
    auf meinem System (Intel P4 2.8 GHz, XP Professional SP2) ist das Autorun-Feature der CD-Laufwerke deaktiviert. Aus softwaretechnischen Gründen hätte ich dieses Feature jedoch gerne wieder zum Leben erweckt, weil ich ein Programm entwickle, das sich, auf CD gebrannt, per Autorun selbstständig installieren soll und ich das vorher ausgiebig testen möchte.

    Einer plausibel klingenden Anleitung, zu finden unter folgender URL:

    http://www.windows-tweaks.info/html/sp2-autostart.html

    folgte ich bis ins Detail, aber bewirkt hat dieser Lösungsansatz wenig bis nichts. Der WinTotal-Tipp zu diesem Thema blieb ebenso wirkungslos wie das Wenige, was Microsoft selbst dazu zu sagen hat, ohne Geld dafür zu verlangen.

    Es ist vielmehr im Augenblick so, dass das Autorun-Feature nur funktioniert, wenn ich mein DVD-Laufwerk (Typ TEAC DV-516D) per Gerätemanager deinstalliere und einen PC-Neustart ausführe. Beim Hochfahren wird das DVD-Laufwerk erneut erkannt und eingebunden.

    Nach dem nächsten Neustart, ohne Deinstallieren des DVD-Laufwerks per Gerätemanager, ist das Autorun-Feature wieder stillgelegt. Es bedarf keiner Erwähnung, dass TweakUI (englischsprachige Version) und ähnliche Utilities zwar die zuständigen Registryschlüssel modifizieren, im Endeffekt aber auch nichts bewirken.

    Nun hoffe ich, dass hier jemand den durchschlagenden Kniff kennt, welcher zur Wiederbelebung des Autorun-Features führt.

    Schließlich kann ich nicht ständig anderer Leute PCs benutzen, um meine Scheibe daran auszuprobieren...

    Schonmal herzlichen Dank für jedes Posting zu diesem Thema :)

    Beste Grüße: Klaus.
     
  2. Versuche auch folgendes:
    Start - Ausführen, Eintrag gpedit.msc - OK.
    In dem Fenster Gruppenrichtlinie auf der linken Seite: Computerkonfiguration - Administrative Vorlagen - System.
    Rechtes Fenster: Doppelklick auf Autoplay deaktivieren
    Im Fenster Eigenschaften von Autoplay deaktivieren die Option Deaktiviert auswählen (oder die Option Nicht konfiguriert - das weiß ich jetzt nicht) und neben Autoplay deaktivieren auf: CD-ROM-Laufwerke auswählen.
    Möglicherweise ist auch ein Neustart erforderlich.

    Ich hoffe, es funktioniert. Melde dich wieder!

    Gruß
    Wolfgang
     
  3. was ist mit.....

    regedit

    hkey_local_machine\system\currentcontrolset\services\cdrom

    Wert Autorun von 0 auf 1 ändern

    restart
     
  4. Der Tip mit den Gruppen-Gruppenrichtlinien zieht m.M. nur, wenn ein AD vorhanden ist.
    Dann kann man dies über die Gruppenrichtlininien auf die einzelnen OU´s runterbrechen, aber an einem lokalen Rechner würde ich sagen: nada
     
  5. @fulda:
    bereits probiert, bewirkt nichts  :'(

    @katzenwurst:
    Registryschlüssel ist bereits auf diesen Wert eingestellt. Keine Wirkung  :'(

    @wowische:
    Werde ich ausprobieren, Ergebnisbericht dann später.

    Besten Dank für die Hilfe nochmal,

    Klaus  :)
     
  6. Es funktioniert wunderbar auf einem einzelnen PC mit der Gruppenrichtlinie. :)
     
  7. @wowische:
    Einstellung war nach dem Öffnen auf Nicht konfiguriert. Umgestellt auf Deaktiviert. Art der Laufwerke lässt sich bei mir nur dann auswählen, wenn die Optionsschaltfläche Aktiviert ausgewählt ist; sind die beiden anderen Optionsschaltflächen ausgewählt, ist das Dropdown neben Autoplay deaktivieren auf... inaktiv. Nach der Umstellung Neustart ausgeführt - keine Wirkung, alles beim alten. :'(

    @ohmsl:
    Das MS-Tool AutoFix produzierte folgenden Bericht:

    AutoFix [V5.2.3790.67]
    Time [2006-03-03 18:21:53]
    Microsoft Windows Version [5.1 (Service Pack 2) <2600>]

    Test [The Shell Hardware Detection service is running.] - Instance [N/A]:
        Result [AutoStart Setting]: OK
        Result [The Shell Hardware Detection service is running.]: OK

    Test [Policies] - Instance [D:\, Drive Type: 5]:
        Result [HKCU\...\Policies!NoDrives]: OK {Absent}
        Result [HKCU\...\Policies!NoDriveAutorun]: OK {Present}
        Result [HKCU\...\Policies!NoDriveTypeAutorun]: OK {Present}
        Result [HKLM\...\Policies!NoDrives]: OK {Absent}
        Result [HKLM\...\Policies!NoDriveAutorun]: OK {Present}
        Result [HKLM\...\Policies!NoDriveTypeAutorun]: OK {Present}
        Result [Driver level policies]: OK {
            HKLM\...\Services\cdrom!Autorun (Present) <Allows>
            HKLM\...\Services\cdrom\Parameters!Autorun (Absent) <Allows>
            HKLM\System\CCS\Enum\...!AlwaysEnable (Absent) <Not set>
            HKLM\System\CCS\Enum\...!AlwaysDisable (Absent) <Not set> }

    Test [Drive Notification] - Instance [D:\, Drive Type: 5]:
        Result [Legacy Notification]: OK
        Result [AutoPlay V2 Notification]: Problems {
            Service (Silent)
            Shell (Deaf) }
        >> Repair << [Autoplay V2 Event]
          Step: No steps to take.
          Result: This AutoPlay setting cannot be fixed. Either the device is malfunctioning, or the wizard cannot determine the problem.

    >> Required action: The wizard found problems but cannot fix them -> None

    Wie man sieht, hat auch dieses Tool keine Chance. Das Laufwerk als solches funktioniert übrigens hervorragend, d.h. es liest Musik- und Daten-CDs ebenso problemlos wie diverse Formate von Video-DVDs.

    Scheint eine harte Nuss zu sein, schon fast peinlich... :-[

    Nochmals vielen Dank für die Mühe!

    Beste Grüße,
    Klaus
     
  8. Nix ist da peinlich - nur herausfordernd... 8)

    Mal sehen...
    Wenn laut Registry der Autostart erlaubt ist (sehe ich das so richtig?!), solltest du noch die Einstellungen im Internet Explorer überprüfen:

    Extras - Internetoptionen - Erweitert. Herunterscrollen bis Sicherheit, und hier die beiden Einträge aktivieren:
    Ausführung aktiver Inhalte in Dateien auf dem lokalen Computer zulassen und Ausführung aktiver Inhalte von CDs auf dem lokalen Computer zulassen.

    Außerdem:
    Registryschlüssel HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
    policies\Explorer.
    Hier den Hexadezimalwert von NoDriveTypeAutoRun auf 95 setzen, um den Autostart zu aktivieren. Dann Neustart.

    Jetzt bin ich mal gespannt... ::)

    Gruß
    Wolfgang
     
Die Seite wird geladen...

CD-Autostart wiederbeleben - Ähnliche Themen

Forum Datum
CD-Autostart-Menüs erstellen? Software: Empfehlungen, Gesuche & Problemlösungen 22. Juni 2005
CD-Autostart funktioniert nicht Windows 95-2000 3. Jan. 2004
CD-Autostart Windows XP Forum 4. Nov. 2003
CD-Autostart funzt nimmer Windows XP Forum 3. Nov. 2002
Geerbten Windows-PC wiederbeleben Software: Empfehlungen, Gesuche & Problemlösungen 14. Apr. 2016