Debian nach True Image restore

Dieses Thema Debian nach True Image restore im Forum "Linux & Andere" wurde erstellt von tinte, 6. Mai 2005.

Thema: Debian nach True Image restore Moin, Ihr habt ja einiges an Tests mit TI gemacht und kommentiert. Im echten Einsatz habe ich jetzt erstmalig ein...

  1. Moin,

    Ihr habt ja einiges an Tests mit TI gemacht und kommentiert.

    Im echten Einsatz habe ich jetzt erstmalig ein Problem, für das ic keie Lösung finde:
    Beim Restore meiner Sicherungen sind alle unterschiedlichen Betriebssysteme (Windows, SuSE-Linux) wieder lauffaähig, nur debian nicht mehr.
    Der OS-Selector findets gar nicht; starten mit->ner Rettungs-CD startet ein halbes debian, dass dann nur noch im textmodus hochkommt, aber nicht wirklich läuft ...

    hat wer nen Tipp?

    Danke und Grüße
    tinte

    Verschoben aus Software&Problemlösungen
     
  2. Ola,

    hast Du die gesmate Platte oder nur die Partition mit Debian gesichert bzw. wieder hergestellt? Kann es sein, dass Debian nicht auf der ersten Partition war? Hat Debian vielleicht Informationen auf einer anderen Partition abgelegt, die nach dem Restore nicht mehr verfügbar waren?
     
  3. Moin,

    ich habe alle Partitionen gesichert und zurück geladen.
    debian ist - wie SuSE - auf der zweiten Platte; und nicht in der ersten Partition - wohl aber einer aktiven.
    Ein Unterschied zwischen der SuSE- und er debian-Inst. ist dass bei SuSE LILO als Bootloader eingestellt ist, bei debian GRUB. Legte der vielleicht Daten noch in anderen Bereichen ab (MBR)?

    Gruß
    tinte
     
  4. Ola,

    ich denke, dass Du bei der Installation entschieden hast, wo GRUB installiert wird. Da könntest Du also auch eine Varainte erwischt haben, die den MBR verändert .... Ich bin nun nicht der Linuxfachmann, aber ich habe solche Aussagen im Ohr wie von der CD starten und Grub neu konfigurieren ....

    aber ich verschieb dich mal ins Linuxforum ....
     
  5. Hi,

    wo liegt denn nun Grub? Im /root?
    Prüf doch mal deine menu.lst, ob die Einträge korrekt sind, auch ein Blick in die etc/fstab kann nicht schaden.
    Wenn Grub auf der hdx installiert wurde, werden keine Einträge im MBR gemacht.
    Wenn der Acronis OS nichts findet, könnte es evtl. auch sein, daß die Partition versteckt ist.
    Welche RettungsCD verwendest du?
     
  6. Moin,

    ja, GRUB liegt in /

    Sieht absolut richtig aus.

    Top-Zustand

    Hatte ich auch gedacht: install in hdc5.

    in diesem Falle die SuSE-Install-CD; die erkennt ja, dass Linuxe installiert sind und bootet die ja auch.

    Gruß
    tinte
     
  7. Hallo,

    Du musst den grub neu installieren:

    - Mit einer Debian oder Knoppix CD booten und das eigentliche Debian chrooten:
    --> mkdir /mnt/debian
    ---> chroot /dev/hdxx /mnt/debian (Wobei hdxx deiner Debian Partition entspricht - z.B. /dev/hda3)
    - grub aufrufen:
    --> grub --no-floppy
    ---> root (hdx,x) (Wobei x,x deiner Partition entsprechen muss - z.B. hd0,2 für die dritte Partition)
    ----> setup (hdx) (Wobei x deiner Festplatte entspricht - z.B. hd0 für die erste Festplatte)
    -----> quit
    - die chroot Umgebung verlassen und die Platte unmounten:
    --> exit
    ---> umount /mnt/debian

    reboot

    Gruß
    Sven
     
Die Seite wird geladen...

Debian nach True Image restore - Ähnliche Themen

Forum Datum
Re: debian-kanotix netzwerkkarte nach booten immer wieder neukonfigurieren Linux & Andere 17. Juli 2005
Zugriff auf VMWare (Debian Server) von WindowsXP (nicht über Browser) Software: Empfehlungen, Gesuche & Problemlösungen 4. Feb. 2009
PHP5 mitm Apache unter Debian will keine Dateien Includen ?:-( Windows XP Forum 27. Okt. 2008
Debian 64Bit Linux & Andere 18. Nov. 2006
Debian saveset root Linux & Andere 7. Okt. 2006