DNS Problem

Dieses Thema DNS Problem im Forum "Windows Server-Systeme" wurde erstellt von marque, 10. Feb. 2004.

Thema: DNS Problem Hallo, mein DNS Server funktioniert (w2k3). Ein Problem ist jedoch, dass viele Programme einfrieren, wenn sie Daten...

  1. Hallo,

    mein DNS Server funktioniert (w2k3). Ein Problem ist jedoch, dass viele Programme einfrieren, wenn sie Daten in die Anwendungsdaten schreiben und es so lange dauert. Das liegt daran, dass der Router falsch am Server eingestellt ist. Momentan schaut das Ganze so aus:
    • Client hat in den Netzwerkeinstellungen Router als Router und Server als DNS Server.
    • Der Server hat in den Netzwerkeinstellungen Router als Router und sich selbst als DNS Server.
    • Weiterhin steht in den DNS Einstellungen, dass er den Router befragen soll, falls er DNS nicht selbst auflösen kann.
    Deaktiviere ich das auflösen von DNS funktioniert kein Internet mehr, jedoch funktioniert lokal Ordnerumleitungen oder Anmeldungen gewohnt schnell. Mit aktivierter Internet-DNS auflösung dauert es viel länger.

    Bitte um Hilfe.
     
  2. Mein ipconfig /all:

    EDIT: Daten ergänzt.
     
  3. Also, das Problem ist schon wieder ein Stück weiter begrenzt:

    • Es hapert an der DNS-Weiterlung in der DNS-MMC.
    • Wenn vom Client eine Anfrage kommt (DNS-Anfrage) sucht er erst im Internet und dann lokal, ob er die Anfrage auflösen kann. Das bedeutet, dass wenn Outlook z.B. mit Exchange kommunizieren will erst im Internet gesucht wird und dann der lokale Server gefragt wird.
    Wie löse ich diese Problem?
     
  4. Ich poste hier nocheinmal mein nslookup:


    Das sollten doch jetzt genug Informationen sein.. ich bin wirklich über jede Hilfe dankbar. Noch einmal das Problem in einem Satz:

    Anfragen, die eigentlich im lokalen Netz aufgelöst werden müssten werden zuerst versucht im Internet über den Router aufzulösen und erst dann im lokalen Netz. Das kostet Zeit.
     
  5. Hallo Marque,

    die Frage die sich stellt ist, ob Dein DNS-Server überhaupt Anfragen ins Internet leiten muß/soll?! Wenn nein, installiere eine Root-Zone. Dein Posting hört sich so an, als ob die Clients einen WWW-Zugang nicht bräuchten. Außerdem kann man zum Routing bislang nur sagen, daß bei Dir gar nix geroutet wird. Ließ doch bitte einmal Deine Ausgabe v. ipconfig /all richtig - das wäre eine Grundvoraussetzung zum Arbeiten mit Diagnose-Programmen. Das steht ganz klar, :

    ...
    Knotentyp . . . . . . . . . . . . : Unbekannt
    IP-Routing aktiviert . . . . . . : Nein

    und ferner

    Beschreibung . . . . . . . . . . : Name der Netzwerkkarte
    Physikalische Adresse . . . . . . : 00-00-00-00-00-XX

    Hast Du die Daten entfernt wegen des Postings? Wenn nicht, dann stimmt mit der NIC was nicht!

    Erkläre mir doch bitte einmal, wohin u. wie Du mit einer einzigen NIC routen willst?

    Die langen Namensabfragen (Timeouts) wundern mich also gar nicht...

    Gruß, Frank
     
  6. Hey, yippy,

    ich muss dir leider recht geben, es kann gut sein, das mir ein Fehler unterlaufen ist. Vielleicht habe ich eines der vielen Tutorials im Internet einfach falsch angewendet oder beim Übersetzten eines Windows Servers 2000 Tutorials in Windows 2003 einen Fehler gemacht. Wahrscheinlich habe ich den Begriff Routen falsch interpretiert (Ist Routen != Internet Weiterleiten?).

    Im Prinzip gibt es bei mir einen Server, 15 Clients einen Hub und einen Router (Hardware).
    Die Clients sollen natürlich Internet bekommen.

    Nun habe ich folgendes gemacht:

    BTW: Die physikalische Adresse habe ich entfernt, du hast eigentlich Recht, ist ja nichts geheimes, die hätte ich eigenltich Posten können, tut mir Leid. Ich habe sie wieder ergänzt.

    Jetzt musst du mir nur noch verraten, warum für dich die langen Wartezeiten kein Wunder sind, ich komme nicht von alleine darauf.
     
  7. Die Lösung sollte recht banal sein:
    Deine Clients lösen DNS vom lokalen Server auf, dieser muss ins Internet weiterleiten, was er selbst nich kennt. Mehr ist eigentlich nicht zu tun.

    Cheers,
    Joshua
     
  8. Hey, Joshua,

    klar, soweit war ich schon, wie wir noch den alten Server hatten. Aber genau beim weiterleiten ins Internet, welches du nur mit einem kurzen Satz abhakst, liegt ja das Problem. Ich habe in meinem Beitrag über dir noch einmal genau geschrieben, wie es bei mir so ausschaut. Vielleicht kannst du das Mehr ist eigentlich nicht zu tun wenigstens grob Stichpunktartig ausführen.

     
  9. Öffne am Server das MMC-SnapIn DNS (unter Verwaltung => DNS), klicke mit der rechten Maustaste auf den Server und wähle Eigenschaften.
    Nun trägst du auf der Registerkarte Weiterleitungen einfach einen offiziellen DNS-Server z.B. deines Providers ein (Einstellung: für alle anderen DNS-Domänen), fertig.

    Nun frage deine Clients zuerst deinen Server, wenn der nix weiss, fragt er im Netz und reicht das ganze weiter an die Clients....

    Cheers,
    Joshua
     
  10. Hallo,

    ich hatte es genau so, wie du geschrieben hast, nur eben mit der IP des Routers. Doch auch wenn ich eine der dubiosen T-Online DNS IPs eintrage verkürzt sich die von yippy angesprochene Timeout Zeit nicht. Es macht wohl keinen Unterschied, ob ich nun die IP des Routers oder eine T-Online IP eintrage! Das Internet geht auch mit einer IP von T-Online, aber trotzdem verkürzt sich die Zeit z.B. vom starten von Outlook (in Verbindung mit Exchange nicht).

    Aktiviere ich den Haken bei Rekursionsvorgang (und Forwarder) deaktivieren so werden neue Hosts zwar nicht mehr gefunden, aber Outlook startet sofort und das ganze Netzwerk geht wieder normal.

    PS: Ich lösche immer Servercache und aktualisiere das DNS-Snapin und überprüfe per nslookup ob noch alles geht und ob die neuen Einstellungen übernommen wurden.

    Edit: ENTFERNE ich die REVERSE-LOOKUP-Zone funktioniert alles wie gewünscht! Zumindest öfters, als zuvor - wenn auch nicht immer.

    Wie habe ich die Reverse Lookup-Zone eingerichtet?

    Was ist daran falsch?
     
Die Seite wird geladen...

DNS Problem - Ähnliche Themen

Forum Datum
SEHR DRINGEND: Probleme bei Upgrade auf Windows 7 Windows Vista Forum 13. Nov. 2016
Problem - Laptop mit angeblich win 10 und win 7 Windows 10 Forum 13. Nov. 2016
Dualboot Windows Uhrzeit Problem Windows 10 Forum 10. Nov. 2016
W10M - Glance Screen & DTTWU Probleme Windows 10 Forum 4. Nov. 2016
probleme mit windows 7 update bitte um hilfe. Windows 7 Forum 4. Nov. 2016