DNS-Server einen DNS-Domänenname geben (DDNS)?

Dieses Thema DNS-Server einen DNS-Domänenname geben (DDNS)? im Forum "Windows Server-Systeme" wurde erstellt von AlexD, 26. Jan. 2004.

Thema: DNS-Server einen DNS-Domänenname geben (DDNS)? Hallo, hab schon im Forum gesucht, aber leider nichts gefunden das mir weiterhilft. Folgendes Problem: Ich möchte...

  1. Hallo,

    hab schon im Forum gesucht, aber leider nichts gefunden das mir weiterhilft.

    Folgendes Problem:
    Ich möchte auf einem W2k-Server nur den DNS- DHCP- und WINS laufen lassen, ohne das dieser als DC mit AD betrieben wird.

    Die Forward-Lookupzone ist eine Primäre (lanarea.net).

    In der Ereignisanzeige bekomme ich immer den Fehler das der DNS-Server im Moment keinen DNS-Domänennamen hat.
    Ereignis-ID: 414

    Wo, wie wird dieser Angegeben?!

    Der Server soll nur für LAN-Parties verwendet werden.
    Die Clients sollen Dynamisch in die Forward-Lookupzone eingetragen werden. Die dynamische Registrierung hab ich aktiviert.

    Ich hoffe Ihr könnt mir weiterhelfen!
    Weitere Fragen zur Konfiguration beantworte ich natürlich gerne!

    Gruß
    Alex
     
  2. Hast du sonst keinen DC im Netzwerk?
     
  3. @Marco
    Nein, es befindet sich sonst kein DC im Netzwerk.
    Es sollte ohne Domäne sein, da es immer sehr aufwendig ist alle in diese zu integrieren.

    @Joshua
    Hab schon ähnliches gelesen, so wie ich das Verstehe wird hier die Arbeitsgruppe in der Netzweridentifikation gemeint.

    Da dies bei mir ebenfalls ein Stand-alone DNS ist kann ich diese Meldung im Ereignisprotokoll ignorieren? Wenn ich das richtig verstanden habe....

    Als Arbeitsgruppe hab ich Lanarea eingetragen und die Forward-Lookupzone heisst bei mir lanarea.net und diese als Primär konfiguriert.

    Hab mal mit einem Clienten getestet, nur wird dieser leider nicht in der Forward-Lookupzone registriert.

    Der Befehl ipconfig -all bringt auf dem Client folgendes Ergebnis:

    Verbindungsspezifisches DNS-Suffix: lanarea.net
    NIC: Accton.....
    Physikalische Adresse: .....
    DHCP: ja
    Autokonfiguration aktiviert: ja
    IP-Adresse: 192.168.1.21
    Subnet: 255.255.255.0
    Standartgateway: -----------
    DHCP-Server: 192.168.1.1
    DNS-Server: 192.168.1.1
    Primärer WINS-Server: 192.168.1.1
    Lease beginn...
    Lease ablauf.......

    Soweit würd das schon gut aussehn, nur erscheint eben der Client nicht in der Zone des DNS-Servers.
    In der Forward-Lookupzone ist die dynamische Registrierung auf ja gesetzt, ebenfalls in der Reverse-Lookupzone.

    Bei einem Ping auf den Server vom Client wird der Name mit dem DNS-Suffix aufgelöst:
    LAN-Server.lanarea.net [192.168.1.1], Ping ich jedoch den Client an so wird nur der Computername aufgelöst Game-Server [192.168.1.21]

    Gruß
    Alex
     
  4. Keiner mehr eine Idee warum die Clients nicht registriert werden ???

    Hab die Forward-Lookupzone einfach nochmal gelöscht und sie einfach nur lanarea statt lanarea.net genannt. Das Suffix im DHCP natürlich auch geändert. Forward- als auch Reverse-Lookupzone für dynamisches Registrieren aktiviert.

    Hab bei mir privat auch ein Netzwerk auf dem ebenfalls ein W2k-DNS läuft, auch mit DHCP und DDNS. Jedoch ist dieser auch DC mit Active Directory. Computer die in der Domäne sind, werden auch schön mit DDNS registriert, andere nicht!

    Darum möchte ich ja gerne für die LAN-Party einen Stand-Alone DNS damit ich nicht zig PC's in eine Domäne integrieren muß, was zB. bei XP-Home usw. schonwieder so eine Sache wäre......

    Ich steh echt am Schlauch!! :(
    Auf den Clienten die ich zum Testen verwende ist unter den TCP/IP Einstellungen DNS Adressen dieser Verbindung in DNS registrieren aktiviert! Ist eigentlich standartmäßig aktiviert.

    Ich weiß nicht wo ich noch suchen soll.
     
  5. Hallo AlexD,

    [...]
    >Ich steh echt am Schlauch!!...

    Wenn Du da runter gehst, könnten wir das Problem lösen... :)

    [...]
    >Da dies bei mir ebenfalls ein Stand-alone DNS ist kann ich diese
    >Meldung im Ereignisprotokoll ignorieren?

    Das wär->ne ganz schlechte Lösung...


    Zuerst deaktivierst Du den DHCP-Server. Den kannst Du anschließend, wenn die Auflösung vernünftig läuft, von mir aus wieder aktivieren - allerdings würde ich versuchen darauf zu verzichten, wenn Du diesen nicht unbedingt benötigst.

    Danach nennst Du auf ALLEN Maschinen die Suffixe um in net, ohne Punkt o.ä., nur net, sei so nett! Dies realisierst Du über die Eigenschaften der jeweiligen Verbindung, sprich über die Eigenschaften der entsprechenden NIC (Weg ist ja wohl bekannt...), also DNS-Suffix für diese Verbindung. Dort aktivierst Du auch gleich noch die beiden letzten Optionen bez. der Registratur in DNS! Alles schließen. Dann über Arbeitsplatz\Eigenschaften\Netzwerkidentifikation\Eigenschaften\Erweitert\dort als primäres DNS-Suffix des Computers dito net eintragen. Achte darauf, daß die Option darunter aktiviert ist! Alles schließen, die Kiste will dann starten.

    Lösche im Ereignisprotokoll alle Einträge des DNS ohne sie zu speichern.

    Im DNS löschst Du anschließend beide Zonen (forward u. reverse) kompl.! Klicke dann mit der re. Maustaste auf den Namen des Servers u. wähle Cache löschen. Mache Dir->ne CMD auf und leere den Cache nochmals manuell mit ipconfig /flushdns. Wechsele wieder ins DNS u. erstelle eine neu prim. Forward-Zone. Diese nennst Du net, wieder nix anderes, nur net. Für BEIDE ZONEN mußt Du die Zonenübertragung deaktivieren und die dynamische Aktualisierung auf JA setzen. Wechsele wieder in eine CMD u. gib ipconfig /registerdns ein.

    Auf dem Client verfährst Du genauso, halt ohne Zonenerstellung. Denke ans Deaktivieren vom DHCP - vorher!!

    Eigentlich sollten nslookup's jetzt positiv ausfallen, egal wie rum Du auflöst.

    Achja, Feedback wäre schön.

    Gruß, Frank
     
  6. danke schon mal im Voraus,

    werd erst morgen Abend dazu kommen.... Feedback kommt auf jeden Fall!!
     
  7. Hallo AlexD,

    irgendwie bin ich im Schlaf hochgefahren weil es heißen muß:

    Wechsele wieder ins DNS u. erstelle eine neu prim. Forward-Zone und danach eine prim. Reverse-Zone. ;-)

    Gruß, Frank
     
  8. Hallo Frank,

    hab die radikale Tour gemacht, DNS und DHCP deinstalliert und mal nur den DNS wieder installiert.

    Paar Infos
    DNS-Server:
    IP: 192.168.1.1
    Name: lan-server

    Client:
    IP: 192.168.1.2
    Name: game-server

    Vorher noch den DNS-Cache manuell gelöscht.
    Dann bei der Installation den DNS als einzigen bzw. ersten DNS-Server deklariert.
    Eine Forward-Lookupzone (einfach nur net) danach eine Reverse-Lookupzone erstellt.
    In beiden Zonen die Zonenübertragung deaktiviert und die dynamische Registrierung auf Ja gestellt. Beide Zonen sind primär!!

    Dadurch das das ich den DNS als einzigen angegeben habe, sind in der Forward-Lookupzone noch folgende Ordner:
    . -> arpa -> net


    Der Fehler bzw. die Warnung Ereignis-ID: 414 Der DNS-Server hat zurzeit keinen DNS-Domänennamen. Möglicherweise wurde keine primäre DNS-Domäne für diesen Servercomputer konfiguriert.... ist leider immer noch vorhanden. ???

    Hab die Suffixe in den Verbindungen auf dem Server so eingetragen wie von Dir beschrieben, und der Server selbst wird dann auch registriert, und zwar im Ordner . der Forward-Lookupzone nicht im net ordner.
    Wird wohl i.O. sein, denn die nslookups sind in beide Richtungen positiv!

    Am Client (game-server) das gleiche Spiel, erst mal mit statischer IP, und auch die Suffixe eingetragen (Neustart wird nicht verlangt, troztdem gemacht).
    DNS-Cache manuell auf dem Client gelöscht und danach mit ipconfig /registerdns registriert. Leider wird er dann nur in der Reverse-Lookupzone registriert!!
    nslookup's name zu IP schlagen fehl
    => game-server wurde von lan-server.net nicht gefunden: non-existent domain
    Auflösung IP zu Name funkioniert einwandfrei!!

    Folgende Meldung ist nach Registrierungvrsuch in der Ereignisanzeige des Clients zu finden:

    Ereignis-ID: 11151
    Typ: Warnung
    Quelle: DnsApi

    Der Netzwerkadapter konnte mit folgenden Einstellungen nicht registriert werden:

    Adaptername : {961E3234-A19E-4B25-AA37-48188F91DFC8}
    Hostname : game-server
    Adapterspezifisches Domänensuffix : net
    DNS-Serverliste :
    192.168.1.1
    Server, an den Aktualisierung gesendet wurde : None
    IP-Adresse(n) :
    192.168.1.2

    Diese DNS-Registrierung ist aufgrund eines DNS-Serverfehlers fehlgeschlagen.
    Mögliche Ursache ist eine Zonenübertragung, die den DNS-Server für die anwendbare Zone,
    die der Computer zum Registrieren benötigt, blockiert.

    (Die anwendbare Zone sollte mit dem oben angegebenen adapterspezifischen
    Domänensuffix übereinstimmen.) Sie können versuchen, den Netzwerkadapter und seine
    Einstellungen manuell zu konfigurieren, indem Sie in der Befehlszeile ipconfig /registerdns
    eingeben. Wenden Sie sich bezüglich des Netzwerkzustands an den Netzwerksystemadministrator,
    falls das Problem weiterhin besteht.

    Hoffe Du kannst mir da noch ein wenig helfen....

    Gruß
    Alex

    P.S.: Den DHCP würd ich schon sehr sehr gerne einsetzten, da ich keine Lust hab zu 40 Leuten (nächste evtl. ca 100) zu laufen wegen IP. Gedacht ist es halt so das man sich nur anstöpseln braucht....
     
  9. Hallo AlexD,

    da ist Dir irgendwo ein Fehler unterlaufen!

    Lösche beide Zonen. Anschließend den Cache (re. Maustaste etc. pp. im DNS) löschen. Dann hälst Du den DNS an (re. Maustaste auf den Eintrag NET u. Alle Tasks u. Beenden wählen. Anschließend den DNS nochmals deinstallieren. Danach wechselst Du nach %systemroot%sysem32. Dort gibts->nen Ordner dns - den löschst Du bitte! Sollte Windows merkern mußt Du neu starten u. den Zugriff auf den Ordner zu beenden - dann halt nach dem Neustart löschen. Installiere den DNS wieder in der bereits vorgeschlagenen Weise u. registriere den Server selber wie auch den Test-Client in der von mir angesprochenen Weise. Solltest Du wider Erwarten Unterverzeichnisse im DNS in der Forward finden lösche diese manuell. Denke an die Einstellungen im DNS, also Zonenübertragung etc. pp. Laß den DHCP bitte vorerst deaktiviert!

    Ich schaue nachher noch mal vorbei...

    Gruß, Frank
     
Die Seite wird geladen...

DNS-Server einen DNS-Domänenname geben (DDNS)? - Ähnliche Themen

Forum Datum
WLAN Verbindungsabbrüche / Vermutlich DNS-Server Problem / Dringende Hilfe benötigt Firewalls & Virenscanner 8. Jan. 2012
DNS-Server Eintrag in der Netzwerkkarte Netzwerk 5. März 2010
DNS-Server unter Windows Server 2003 Windows Server-Systeme 11. Feb. 2009
W2K-DNS-Server Windows XP Forum 12. Dez. 2007
WIn2003-Firewall und DNS-Server Windows Server-Systeme 3. Sep. 2007