Doppelte Wenn Funktion

Dieses Thema Doppelte Wenn Funktion im Forum "Microsoft Office Suite" wurde erstellt von Areus, 2. Nov. 2010.

Thema: Doppelte Wenn Funktion In A1 steht ein Datum und ist folgendermaßen formatiert TTT, TT.MM.JJJJ (Di, 02.11.2010) In A2 steht eine...

  1. In A1 steht ein Datum und ist folgendermaßen formatiert TTT, TT.MM.JJJJ (Di, 02.11.2010)
    In A2 steht eine Stundenzahl 5
    In A3 soll nun folgendes passieren

    Es soll geprüft werden, ob A1 ein Samstag oder Sonntag ist.
    Wenn das so ist soll nichts ausgegeben werden.
    Wenn das nicht so ist soll geprüft werden, ob A1 ein Freitag ist.
    Wenn das so ist soll 5-A2 gerechnet werden
    Wenn nicht (Also wenn Mo-Don) soll 8,25-A2 gerechnet werden

    Kann mir jemand die Formel sagen? Ich hab noch nie mit Formeln gearbeitet die mehrere Bedingungen prüfen
     
  2. Du hast die meiste Arbeit schon gemacht, indem du die vorzunehmenden Prüfungen so säuberlich untereinander aufgeschrieben hast.
    Das brauchst du nur noch der Reihe nach in eine Formel zu packen. Schrittweise aufgebaut sieht das so aus:

    Es soll geprüft werden, ob A1 ein Samstag oder Sonntag ist.
    Code:
    =WENN(WOCHENTAG(A1;2)>5;
    Wenn das so ist soll nichts ausgegeben werden.
    Code:
    =WENN(WOCHENTAG(A1;2)>5;;
    Wenn das nicht so ist soll geprüft werden, ob A1 ein Freitag ist.
    Code:
    =WENN(WOCHENTAG(A1;2)>5;;WENN(WOCHENTAG(A1;2)=5;
    Wenn das so ist soll 5-A2 gerechnet werden
    Code:
    =WENN(WOCHENTAG(A1;2)>5;;WENN(WOCHENTAG(A1;2)=5;5-A2;
    Wenn nicht (Also wenn Mo-Don) soll 8,25-A2 gerechnet werden
    Code:
    =WENN(WOCHENTAG(A1;2)>5;;WENN(WOCHENTAG(A1;2)=5;5-A2;8,25-A2))

    Edit:
    Ein ganz anderer Ansatzpunkt wäre mit Hilfe der WAHL-Funktion zu arbeiten:
    Code:
    =WAHL(WOCHENTAG(A1;2);8,25-A2;8,25-A2;8,25-A2;8,25-A2;5-A2;;)
     
  3. super funktioniert. Danke dass Du Dir die Mühe gemacht hast die Formel auch noch aufzuschlüsseln. Toll!
     
  4. Hallo,

    nur zur Info, Exel kann insgesamt 8 Wenn Funktionen in einer Formel berechnen.

    MfG
     
Die Seite wird geladen...

Doppelte Wenn Funktion - Ähnliche Themen

Forum Datum
doppelte dateien Software: Empfehlungen, Gesuche & Problemlösungen 13. März 2015
Doppelte Symbole bei Programmen auf dem Desktop Windows 7 Forum 12. März 2014
Netzwerk doppelter Eintrag Windows XP Forum 16. März 2013
USB Umts STick Xs Manager nach Neuinstallation doppelte Einträge Hardware 27. Okt. 2011
doppelter Programmordner und Desktopicons Windows XP Forum 4. Jan. 2010