Excel - Abfrage über 2 Spalten

Dieses Thema Excel - Abfrage über 2 Spalten im Forum "Microsoft Office Suite" wurde erstellt von Ezechiel666, 8. Mai 2006.

Thema: Excel - Abfrage über 2 Spalten Hallo, habe bereits gegoogelt und auch Stunden lang selbst rumprobiert, allerdings komme ich einfach nicht auf die...

  1. Hallo,
    habe bereits gegoogelt und auch Stunden lang selbst rumprobiert, allerdings komme ich einfach nicht auf die Lösung, die ich suche. Ich habe folgende Aufgabe in Excel zu lösen.

    Das erste sheet mit dem Namen Daten sieht z.B. wie folgt aus
    [​IMG]

    Das 2. sheet mit dem Namen Abfrage soll gleich aussehen (auch mit den Spalten Name, Vorname....)
    Wenn nun Name und Vorname mit denen im Datensheet übereinstimmen, soll es mir Geburtsdatum und Ort automatisch ausfüllen.

    Ist das überhaupt möglich? Wenn ja, wie?

    Danke für eure Hilfe
    EzE
     
  2. Eine Wenn(Und())-Funktion sollte dabei helfen ;)
     
  3. MAl ein Beispiel für Geburtsdatum

    =WENN(UND(Abfrage!A2=daten!A2;Abfrage!B2=daten!B2);daten!C2;)
     
  4. Hallo,
    danke für die schnelle Antwort. Soweit war ich auch schon, das heißt aber nur, dass
    wenn A2 und B2 von beiden Blättern übereinstimmen, C2 ausgefüllt wird.

    Was aber wenn ich bei Abfrage!A2 und Abfrage!B2 die Werte von Daten!A4 und Daten!B4 eintrage?
    Ich habe es schon mit =WENN(UND(Abfrage!A2=daten!A2:A40;Abfrage!B2=daten!B2:B40);daten!C2:40;)
    probiert, aber dann bekomme ich kein Ergebnis...

    Ist ein wenig kompliziert zum erklären... ich möchte in Abfrage!A2 und Abfrage!B2 eine UND-Abfrage über die gesamten Spalten Daten!A und Daten!B machen.

    Hoffe man hat mich verstanden

    Gruß
    EzE
     
  5. Neues Beispiel für Geburtsdatum für Zelle C2 im Sheet Abfrage

    =VERWEIS(2;1/(daten!A$1:A$100&daten!B$1:B$100=Abfrage!A2&Abfrage!B2);daten!C$1:C$100)
     
  6. Funktioniert einwandfrei!!!!

    Vielen vielen Dank!

    Gruß
    EzE 

    PS: Anbei der verdiente Applaus [​IMG][​IMG][​IMG]
     
Die Seite wird geladen...

Excel - Abfrage über 2 Spalten - Ähnliche Themen

Forum Datum
Excel: Erweitern einer WENN Abfrage ?? Windows XP Forum 21. Nov. 2007
Instant-SQL-Abfragen für Excel-Sheets? Windows XP Forum 9. Juli 2007
Excel benden ohne Abfrage Windows XP Forum 27. März 2007
Brauche Hilfe bei Excel Webabfrage Microsoft Office Suite 14. Feb. 2006
Excel: Verschachtelte WENN-Abfragen anschaulich darstellen? Microsoft Office Suite 7. Dez. 2005