Excel - bedingte Formatierung

Dieses Thema Excel - bedingte Formatierung im Forum "Microsoft Office Suite" wurde erstellt von lummo, 13. Okt. 2006.

Thema: Excel - bedingte Formatierung Hallo liebe Liebenden, ich bin auf der Suche nach einer einfachen Kontrolle für Excel-Formeln. Schüler sollen in...

  1. Hallo liebe Liebenden,

    ich bin auf der Suche nach einer einfachen Kontrolle für Excel-Formeln. Schüler sollen in von mir festgelegte Zellen ihre Formeln eingeben. Zur Kontrolle ob die Formel richtig ist, soll dazu die Zelle in grün (Hintergrund) aufleuchten.

    Ich dachte dabei an eine bedingte Formatierung nach dem Motto: Formel ist =c2*c3 -> dann grün leuchten.

    Leider spielt mir Excel diverse Streiche.
    A: Um überhaupt was anzuzeigen, muss in der Zelle c2 und c3 was drinstehen
    B: Es reicht auch, wenn in c2 und c4 was drin steht, um die grüne Formatierung anzuzeigen
    C: Es zeigt auch grün, wenn ich eine falsche Formel drin hab

    Den selben Versuch hab ich mit Zellwert ist gleich =c2*c3 gestartet. Auch da die oben genannten Aussetzer.

    Wer weiß mir eine Möglichkeit, ohne großes Makro, dass ich rucki-zucki eine Kontrolle über richtig eingegebene Formeln habe. Es wär halt schön, wenn die Schüler was eingeben und als Ergebnis gleich sehen, richtig oder falsch.

    Danke im Voraus für die Hilfe,

    lummo
     
  2. Hallo lummo,

    eine Methode an die Formeln mit Formeln heranzukommen ist mir nicht bekannt.
    Eigentlich schade  :(

    Drum ein kleines Makro:
    Hier als Beispiel die Überwachung von
    A2: Formel =C2*C3
    B2: Formel =SUMME(D2:D4)
    Das kann beliebig erweitert werden

    Code:
    Option Explicit
    Private Sub Worksheet_Change(ByVal Target As Excel.Range)
     
    ->Beispiel zur Überwachung der eingegebenen Formeln in
     
     Dim Zelle As Range, sAddress As String
     
     For Each Zelle In Target
      sAddress = Zelle.Address(False, False)
      Select Case sAddress
       Case A2: Call ZellformelBewerten(Zelle, =C2*C3)
       Case B2: Call ZellformelBewerten(Zelle, =SUMME(D2:D4))
      End Select
     Next
     Set Zelle = Nothing
    End Sub
    '*******************************************************************
    Private Function ZellformelBewerten(Zelle As Range, sFormel As String)
     
     Const cColorIndexRot = 3
     Const cColorIndexGruen = 4
     
     Dim sF As String
     
     If Not Zelle.HasFormula Then sF =  Else sF = Zelle.FormulaLocal
     
     If sF = sFormel Then
      If Zelle.Interior.ColorIndex <> cColorIndexGruen Then
       Zelle.Interior.ColorIndex = cColorIndexGruen
      End If
     Else
      If Zelle.Interior.ColorIndex <> cColorIndexRot Then
       Zelle.Interior.ColorIndex = cColorIndexRot
      End If
     End If
    
    End Function
    Diesen Code in die Code-Seite des entsprechenden Tabellenblattes kopieren.

    Wie kommt man da hin ?
    Tabellenlasche mit rechter Maustaste anklicken ->Code anzeigen

    Probier's mal aus.

    Gruß Matjes :)
     
  3. Hallo,

    die Frage habe ich nicht richtig geschnallt.

    Willst du eine vorgegebene Schreibweise der Formeln erreichen?

    Dann mit Anführungszeichen! Zellwert ist: gleich: =c2*c3 oder Formel ist: =c2*c3, sonst rechnet Excel mit den in den Zellen stehenden Werten und kommt zwangsläufig zu falschen Ergebnissen.

    Aber vielleicht hat Matjes ja schon den Finger drauf.

    Edit:

    Ich glaube es hat klick gemacht. Leg doch eine nicht sichtbare Kontrollzelle mit der Formel =c2*c3 an (zB.c10), in der bedingten Formatierung lässt du die Eingabezelle mit dieser prüfen.

    Zellwert ist: gleich: =c10
     
  4. Hallo lummo, bis du Mathelehrer und willst, daß die Schüler den Rechenweg zu einem vordefinierten Ergebnis aufzeigen?
    Dann gibt es eine Lösung für die bedingte Formatierung.
    In Zelle C2 steht eine Zwei und in Zelle C3 steht eine Drei
    Zuerst mußt du die Zelle, in der die Formel durch den Schüler eingetragen werden soll (nehmen wir mal Zelle C1), als Text formatieren. Dann bleibt die Zeichenfolge =c2*c3 Zeichen für Zeichen dort stehen. Wenn du die Zelle nicht als Text formatierst, steht nach dem Eintrag das Ergebnis der Formel drin, also eine Sechs.

    Zur Prüfung erstellst du jetzt in C4 eine Vergleichszelle, die auch als Text formatiert ist und das korrekte Ergebnis enthält. Diese Zelle kannst du ja ausblenden, damit die Schüler sie nicht sehen.

    Dann machst du in Zelle C1 folgende bedingte Formatierungen:
    1. =C1=C4 --> grün
    2. =C1<> --> rot
    Jetzt verursacht eine falsche Eingabe eine rote Zelle und eine richtige Eingabe eine grüne Zelle. Eine leere Zelle bleibt weiß

    War's das?
     
Die Seite wird geladen...

Excel - bedingte Formatierung - Ähnliche Themen

Forum Datum
Excel 2010 - Filter, bedingte Formatierung Windows 7 Forum 27. Okt. 2014
Bedingte Formatierung Excel 2010 bei Datum Microsoft Office Suite 11. Okt. 2012
Excel Tabelle -> Word mit bedingter Formatierung Microsoft Office Suite 21. Dez. 2010
Bedingte Formatierung Excel 2007 Microsoft Office Suite 19. Apr. 2010
Bedingte Formatierung in EXCEL Microsoft Office Suite 9. März 2007