Excel: Berechnung in Abhängigkeit von Spalte A

Dieses Thema Excel: Berechnung in Abhängigkeit von Spalte A im Forum "Windows XP Forum" wurde erstellt von falcon30, 26. März 2008.

Thema: Excel: Berechnung in Abhängigkeit von Spalte A Hallo Zusammen, ich habe mal wieder ein problem. Unzwar habe ich folgende Tabelle: C1 23 3 C1 1231 1 C1 234 4...

  1. Hallo Zusammen,

    ich habe mal wieder ein problem.
    Unzwar habe ich folgende Tabelle:
    C1 23 3
    C1 1231 1
    C1 234 4
    C1 52345 1
    C1 54 0
    C1 634 9
    C1 634 0
    C1 690 5
    C1 677 0
    C1 636 0
    D1 3223 0
    D1 245 0
    D1 24 0
    D1 34 0
    E1 66 1
    E1 3452 0
    E1 252 4
    E1 248 1
    E1 5832 0
    E1 2178 0

    Ich möchte nun die Anzahl der E1, D1, C1, usw. berechnen die kein 0 haben.
    Hier im Beispiel müsste für E1 als Ergebnis 3 heraus kommen.
    Mit Zählenwenn habe ich es nicht hinbekommen.
    Wie mache ich das?
    Ich hoffe ihr könnt mir helfen.

    Vielen Dank!!

    Grüße
    falcon30
     
  2. Hallo falcon30,

    wenn die Werte in A1:C22 stehen lautet die Formel für->E1':
    Code:
    =SUMMENPRODUKT((A1:A22=E1)*(C1:C22<>0))
    wobei hier die 0 als Text stehen muß. Ist sie als Zahl formatiert lautet die Formel:
    Code:
    =SUMMENPRODUKT((A1:A22=E1)*(C1:C22<>0))
    Gruß matjes :)
     
  3. Hallo Matjes,

    vielen Dank für die Klasse antwort.

    Funktioniert 1A.

    Danke!!

    Grüße
    falcon30
     
Die Seite wird geladen...

Excel: Berechnung in Abhängigkeit von Spalte A - Ähnliche Themen

Forum Datum
Datumsberechnung in Excel 2007 Microsoft Office Suite 14. Juni 2012
(Wie) kann eine Excel-Formel die eigene Zeile in die Berechnung einbeziehen? Windows XP Forum 6. Nov. 2010
Excel - Ratenberechnung über mehrere Jahre Microsoft Office Suite 15. Sep. 2010
Excel > Berechnung von Anzahl Tage.... Windows XP Forum 17. Okt. 2009
Excel Mittelwertberechnung Windows XP Forum 16. Juli 2007