Excel: Fehlerwerte verzerren Diagramme

Dieses Thema Excel: Fehlerwerte verzerren Diagramme im Forum "Microsoft Office Suite" wurde erstellt von Ace_NoOne, 24. Apr. 2006.

Thema: Excel: Fehlerwerte verzerren Diagramme Hallo zusammen, gibt es bei Excel 2000 eine Möglichkeit zu verhindern, dass Leer- und Fehlerwerte (, #VALUE, #DIV/0...

  1. Hallo zusammen,

    gibt es bei Excel 2000 eine Möglichkeit zu verhindern, dass Leer- und Fehlerwerte (, #VALUE, #DIV/0 etc.) in Diagrammen als Nullwert interpretiert werden? Das führt nämlich regelmäßig dazu, dass es in Diagrammen zu verzerrten Anzeigen kommt, wenn es z.B. für den jwlg. Monat noch keine Werte gibt.
    Ich habe bereits versucht, das Problem mit WENN-DANN-Abfragen (»=IF(ISERROR(Z17/CD17), , Z17/CD17)«) in den relevanten Datenreihen zu umgehen, aber das führt zu keiner Veränderung...

    Für hilfreiche Hinweise wäre ich, wie immer, sehr dankbar!


    PS: Sorry für die englischen Bezeichnungen; die deutschen habe ich gerade nicht parat...
     
  2. dann eben zweisprachig

    Code:
    =IF(OR(CD17=,CD17=),,IF(OR(Z17=,Z17=0),,Z17/CD17)
    Code:
    =WENN(ODER(CD17=;CD17=);;WENN(ODER(Z17=;Z17=0);;Z17/CD17)
    Gruß Matjes :)
     
  3. Sorry, Matjes, aber bei mir im Diagramm hat deine Formel den gleichen Effekt wie meine; die Zelle wird als nicht leer erkannt und entsprechend als 0 interpretiert:
    http://file.autohotkey.net/Ace_NoOne/tmp/DiagrammFehler.xls
    Was fehlt, ist also quasi ein NULL-Wert - denn scheint ja diesen Effekt nicht zu haben...

    Trotzdem vielen Dank!
     
  4. Hallo Ace_NoOne,

    Im Diagramm ist in Spalte A die Zeitachse mit den Werten Jan05 bis Dez06.
    In Spalte B werten tatsächliche Werte eingegeben, in Spalte C und D stehen Formeln, die sich auf Spalte B beziehen. Diese 3 Kurven werden im Diagramm dargestellt.

    Wenn ich das richtig verstanden habe, willst du, dass im Diagramm die Darstellung der Linien aufhört, wenn keine Werte vorhanden sind.

    Für Spalte B paßt das, da hier tatsächliche Werte stehen oder eben nichts.

    Bei Formeln empfindet das excel anders. Hier muß man excel direkt sagen, daß diese Zelle leer ist. Dies geschieht mit der Formel NV().

    Also muß die Formel für Spalte D lauten:
    Code:
    =IF(OR(CD17=0,CD17=),NV(),IF(OR(Z17=,Z17=0),NV(),Z17/CD17)
    Die Formel in Spalte C muß auch so angepaßt werden.

    Dann wird auch #NV in den Zellen mit keinem Wert ausgegeben.

    Diese Punkte werden dann im Diagramm auch nicht ausgegeben.

    Gruß Matjes  ;)

    ps: in den Formel oben wurde fälschlicherweise
    Code:
    CD17=,CD17=
    angegeben.
    Muß natürlich
    Code:
    CD17=,CD17=0
    lauten.
     
  5. Super, jetzt klappt es - vielen, vielen Dank!!

    Nach eben dieser NV()-Funktion hatte ich gesucht. Damit klappt jetzt auch meine ursprüngliche (weniger verschachtelte) Formel:
    Code:
    =WENN(ISTFEHLER(C25/B25-1); NV(); C25/B25-1)
    bzw.
    Code:
    =WENN(ISTFEHL(C25/B25-1); NV(); C25/B25-1)
    Das wiederum bedeutet, dass ich morgen eine ganze Reihe von Excel-Tabellen anpassen muss... *seufz* ;)


    PS: Ich glaube nicht, dass die Formel so klappt, wie sie bei dir steht - da hast du wohl versehentlich die beiden Sprachen vermischt. Ich vermute mal, dass NV() (nicht verfügbar/vorhanden?) in der englischen Version NA() (not available) heißt - werde das aber morgen auf der Arbeit sowieso ausprobieren.
    Sorry für die Besserwisserei... ;)
     
  6. Jo, da hast du wohl recht   ::)

    Gruß Matjes  :)
     
Die Seite wird geladen...

Excel: Fehlerwerte verzerren Diagramme - Ähnliche Themen

Forum Datum
Excel-Feature gesucht Microsoft Office Suite 11. Okt. 2016
Excel Tabelle Werte zu ordnen Microsoft Office Suite 23. Sep. 2016
Excel: Bereiche auf 'leer' Überprüfen Microsoft Office Suite 15. Sep. 2016
Import Datensatz inkl = und - Zeichen in Excel/Libre CALC Software: Empfehlungen, Gesuche & Problemlösungen 20. Mai 2016
Bestimmter User kann seine Excel Dateien nicht mehr direkt öffnen Software: Empfehlungen, Gesuche & Problemlösungen 16. Apr. 2016