Excel-Formel -> Ich steh' auf'm Schlauch!

Dieses Thema Excel-Formel -> Ich steh' auf'm Schlauch! im Forum "Windows XP Forum" wurde erstellt von Buttermaker, 30. Dez. 2005.

Thema: Excel-Formel -> Ich steh' auf'm Schlauch! :-\ Hallo Zusammen, ich hab' wiedermal ein Problemchen und würde mich über Eure Hilfe riesig freuen. Mein Chef...

  1. :-\

    Hallo Zusammen,

    ich hab' wiedermal ein Problemchen und würde mich über Eure Hilfe riesig freuen.

    Mein Chef will zur Berechnung der Frachtkosten die wir bei einer Spedition zahlen (und den Kunden in Rechnung stellen) eine einfache Eingabe-/Ausgabemaske.

    Die Frachtkosten setzen sich wie folgt zusammen:

    Minimum je Sendung 14,90 ?
    bis 250 kg 0,256 ? / Kg
    bis 900 kg 0,218 ? / Kg
    bis 2500 kg 0,197 ? / Kg

    Ich hatte für jede Zeile eine eigene Formel erstellt (=D2*B2, usw.)

    A B C D
    1 min. 14,90
    2 250 0,256 =D2*B2 z.B. 234
    3 900 0,218 =D3*B3 z.B 648
    4 2500 0,197 =D4*B4 z.B. 1890

    Er möchte aber nur ein Feld in dem er das Gewicht eingibt (egal wieviel die Palette wiegt) und ein Feld in dem dann der Endpreis (also ggf. bei niedrigem Gewicht das Minimum von 14,90 ?, usw. steht.)

    Angefangen hatte ich z.B. damit: =WENN(D2<=A2;SUMME*B2)
    (So steht's zumindest in der Excel-Hilfe.)
    Auch wenn damit nur ein Bruchteil der Aufgabe erfüllt wäre.
    Aber selbst das haut schon nicht hin. :-\
    Ergebnis: #NAME?

    Irgendwie steh' ich auf'm Schlauch! :'(

    Ich würde mich echt riesig freuen wenn ihr mir auf die Sprünge helfen könntet.

    Schöne Grüße

    Buttermaker
     
  2. Hallo Buttermaker,

    folgende Formel sollte für eine Eingabe Kg in A2 das Gewünschte berechnen:

    Code:
    =WENN(A2=0;0;WENN(A2*0,256<=14,9;14,9;WENN(A2<=250; A2*0,256; WENN(A2<=900; A2*0,218; WENN(A2<=2500; A2*0,197; A2*0,197)))))
    1.WENN
    - Abfrage->keine Eingabe' -> dann 0
    2.WENN
    - Abfrage kg * 0,256 ?/kg  <= 14,90  ja -> 14,90 ?
    3.WENN
    - Abfrage A2 <= 250 Kg                   ja -> A2 *0,256 ?/kg
    4.WENN
    - Abfrage A2 <= 900 Kg                   ja -> A2 *0,218 ?/kg
    5.WENN
    - Abfrage A2 <= 2500 Kg                 ja -> A2 *0,197 ?/kg
                                                    nein -> A2 *0,197 ?/kg

    Bei->bis 2500 kg' hört die Tabelle auf. Bei größeren Werten wird ebenfalls 0,197 ? / kg berechnet.

    Gruß Matjes :)
     
  3. Traumhaft! :D

    Super. Danke.

    Jetzt hab ich's wohl auch verstanden.
    Mein (Denk)-Fehler war, das ich davon ausging =) bei den Bezügen (nach kleiner_gleich) Zellen angeben zu können. ???
    Da habe ich Excel wohl zuviel zugetraut ;)

    Nochmals danke für die schnelle und perfekte Hilfe. O0

    Guten Rutsch ins neue Jahr

    Buttermaker
     
Die Seite wird geladen...

Excel-Formel -> Ich steh' auf'm Schlauch! - Ähnliche Themen

Forum Datum
Wie kann ich eine Excel-Formel in die nachfolgenden Zeilen mit variablem Multiplikator ziehen ? Microsoft Office Suite 4. Dez. 2015
(Wie) kann eine Excel-Formel die eigene Zeile in die Berechnung einbeziehen? Windows XP Forum 6. Nov. 2010
benötige Excel-Formel Windows XP Forum 14. Jan. 2010
Excel-Formel Windows XP Forum 17. Mai 2004
¿ Crystal Disk Info warnt ID05: Ich versteh' nix:-( ? Hardware 26. Nov. 2010