Excel: Konvertierung unterbinden

Dieses Thema Excel: Konvertierung unterbinden im Forum "Microsoft Office Suite" wurde erstellt von Cledith, 16. Sep. 2003.

Thema: Excel: Konvertierung unterbinden Hi, ich habe heute mal ein Excel Problem. Und zwar: Ich möchte eine Tabelle aus der I-Net in eine Exceltabelle...

  1. Hi,
    ich habe heute mal ein Excel Problem.
    Und zwar:

    Ich möchte eine Tabelle aus der I-Net in eine Exceltabelle kopieren. Ansich kein Problem. Doch jetzt sind in der Tabelle Werte wie z.B. 3.6 oder 7.8 enthalten. Diese konvertiert mir Excel nun immer als Datum, wobei ich selbstverständlicherweise die Zahlen behalten möchte.

    Wenn ich die Zellen nachträglich als Text konvertiere, dann schreibt er mir eine wohl beliebige 5 stellige Zahl hinein.

    Wenn ich vorher die Tabelle selektiere und alle Zellen als Text formatiere, wandelt er mir die Zahlen ebenfalls in Daten um.

    Bei als Zahl formatierten Zellen passiert dasselbe.

    Wie kann ich Excel also nun dazu bringen die Finger von den Daten zu lassen?

    Danke für eure Hilfe.
    Mfg,
    Cledith
     
  2. Hallo Cledith,

    das ist eine altbekannte Schwierigkeit.

    Eine vielverwandte Methode ist, die Textdatei mit einem Texteditor zu öffnen, alles zu markieren und Punkt gegen Komma zu ersetzen.
    Dann klappt der Import in Excel.

    Gruß Matjes :)
     
  3. Och nö :(

    Danke erstmal für deine Hilfe!

    Ein Arbeitskollege von mir hat das auch schon - wenn gleich auf eine recht höhnische Art und Weise - vorgeschlagen.

    Da gibt es keine andere Möglichkeit?
    Ich meine bei kleinen Tabellen ist das nicht unbedingt die Sache, aber wie...

    wie ist das denn in Amerika geregelt? Hat da schon mal jemand angesetzt? Das Komma entspricht da nun mal dem Punkt und das Datum wird gleich geschrieben wie hier in Europa (also mit Punkt [.])

    Da muss es doch auch irgendwie gehen?!?! Es kann doch nicht angehen, dass wenn die Kommazahlen in eine Tabelle eingeben, aus diesen Zahlen erstmal Wochentage gemacht werden...

    Mfg,
    Cledith
     
  4. Ein neuer Versuch - mal sehn ob es dir gefällt ;D

    Hab noch mal etwas herumprobiert.

    Die Umwandlung hab ich aus einer Semikolon-separierten Textdatei durchgeführt.

    Datei->öffenen->als *.txt-> Textdatei.txt auswählen->öffnen
    Textassistent öffnet sich
    Schritt 1 weiter
    Schritt 2 Semikolon markiert, weiter
    Schritt 3
    - Zahlereihe markiert (Reiter über der Spalte klicken, so dass die Spalte schwarz wird-> Datenformat der Spalten->Text

    Jetzt erscheinen die Zahlen in der Spalte mit Punkt, aber leider mit dem falschen Format.
    Wenn man sie anklickt und dann die Zelle verläßt hat man die fünfstelligen Zahlen.

    Den folgenden Makro hab ich dann dazu verwendet, die->scheinbaren' Zahlen in Zahlen mit zwei Nachkommastellen zu konvertieren.

    Der Makro bearbeitet in dieser Form die 3.Spalte, ist änderbar in der Konstatnten c_Spalte.

    Gruß Matjes :)

    Code:
    Sub SpalteInDoubleWandeln()
      Const c_Spalte As Long = 3
      Dim i As Long, s_tmp As String
      
      For i = 1 To ActiveSheet.Cells( _
                  ActiveSheet.Rows.Count, c_Spalte).End(xlUp).Row
        s_tmp = ActiveSheet.Cells(i, c_Spalte).Value
        ActiveSheet.Cells(i, c_Spalte).NumberFormat = 0.00
        ActiveSheet.Cells(i, c_Spalte).Value = s_tmp
      Next
    End Sub
     
  5. Hi,
    na das ist doch schon mal was ;D

    Nun ja, werde ich mich wohl erstmal mit abfinden. So wichtig ist es dann ja nun auh nicht.

    Danke dir.
    Mfg,
    Cledith
     
  6. Es geht auch einfacher: Du mußt die Spalten, die nicht ins Datumsformat umformatiert werden sollen, in der Zieltabelle als Text vorformatieren. Die Daten, die du reinkopieren willst, dann aber nicht mit [Strg+V] reinkopieren, sondern mit Werte einfügen. Siehe dazu den Eintrag von safer hier: http://www.wintotal-forum.de/?board=17;action=display;threadid=23244;start=msg130691#msg130691

    Es wäre auch interessant, zu wissen woher du die Daten kriegst, die du reinkopieren willst. Ist es eine Web-Abfrage (...aus der I-Net... ? :-\) oder eine Excel-Tabelle?
     
  7. HI,
    oh, das muss ich mal ausprobieren.
    Als Text hatte ich alle Felder formatiert, jedoch über STRG + V eingefügt und nicht über Werte einfügen.

    Die Daten kommen direkt aus dem Netz, HTML.

    Werde ich - sobald ich Zeit habe - mal ausprobieren. Melde mich dann.
    Mfg,
    Cledith

    Edit:
    Habe das jetzt mal eben ausprobiert, jedoch bei mir zu Hause. Jetzt habe ich aber wirklich mal ne Frage ;D

    Auf dem anderen Rechner hat er das Format der Tabelle automatisch beibehalten. Fand ich echt gut ;D (die Tabelle ist diese hier: von tarif4you.de: http://www.tarif4you.de/tarife/ -> beliebiges Land)

    Nun, bei mir hat er das Format nicht beibehalten und alles in eine Spalte untereinander eingefügt. Einzig postives daran: er ist nicht auf die Idee gekommen das ganze als Datum zu formatieren, auch wenn ich es über STRG + V eingefügt habe. Wie kommt das denn? Wo gibt es denn so was einzustellen?

    Werte einfügen kann ich demnach im Moment nicht probieren. Melde mich diesbezüglich Montag.

    Mfg,
    Cledith
     
  8. Mein Trick funktioniert nur, wenn du die Daten in korrekter Form bereits in einem Excel-Sheet hast. Die Webabfrage ist anscheinend immer einem [Strg+V] gleichzusetzen.

    Ich bin auf keinen grünen Zweig gekommen. Man müßte irgendwo die Standardformatierung für Excel-Zellen auf Text setzen können. Entweder in Excel selbst oder in der Registry muß vermerkt sein, daß Excel aus 6-7 standardmäßig den 6. Juli macht.

    Hat wohl was mit Autoformat zu tun, aber in der Excel-Hilfe stand etwas nicht nachvollziehbares unter:
    Verhindern, daß beim Aktualisieren eines externen Datenbereichs die automatische Formatierung erneut angewendet wird
    [...]
    3. Stellen Sie sicher, daß Daten das Kontrollkästchen AutoFormat anwenden deaktiviert ist, und klicken Sie dann auf OK.
    [...]
    Diesen Satz kapier ich nicht, vor allem nicht Daten.


    edit 23.09.2003 10:15
    Dadurch werden wohl auch beim Importieren von .CSV- oder .TXT-Dateien alle Spalten auf Standard formatiert und nicht auf Text

    Also: Wer weiß, wo man das einstellen kann?
     
  9. [nachobenschieb]
    Wer weiß, wo man das Standardformat für die Excel-Zellen von Standard auf Text ändern kann?
     
Die Seite wird geladen...

Excel: Konvertierung unterbinden - Ähnliche Themen

Forum Datum
Konvertierung von pdf in Excel Software: Empfehlungen, Gesuche & Problemlösungen 4. März 2008
Excel: "Automatische Konvertierung" ausschalten Windows XP Forum 22. Feb. 2005
Fragen zur Konvertierung Excel 97/2000/XP Windows XP Forum 16. Sep. 2003
Excel-Feature gesucht Microsoft Office Suite 11. Okt. 2016
Excel Tabelle Werte zu ordnen Microsoft Office Suite 23. Sep. 2016