Excel -> Problem mit einer Formel

Dieses Thema Excel -> Problem mit einer Formel im Forum "Microsoft Office Suite" wurde erstellt von Karamanga, 21. Nov. 2003.

Thema: Excel -> Problem mit einer Formel Hallo Leute, ich habe ein Problem mit einer Formel in meinem Excel-Dokument. Das Feld X soll einen Wert anzeigen,...

  1. Hallo Leute,

    ich habe ein Problem mit einer Formel in meinem Excel-Dokument.
    Das Feld X soll einen Wert anzeigen, wenn in Feld A ein bestimmter Wert steht.

    Konkret sieht das so aus:

    Spalte A beinhaltet das Datum (Feld formatiert : TTTT, den TT. MMM JJ). Das ergibt dann z.B. Samstag, den 15. Nov 03.

    In Spalte B soll immer dann der Wert 20 erscheinen, wenn in Spalte A der Wert Freitag auftaucht. Ansonsten soll der Wert in Spalte B 60 betragen.



    WIE MUSS DIE ENTSPRECHENDE FORMEL LAUTEN ?!?
     
  2. Ola,

    =WENN(WOCHENTAG(A1)=6;20;60)
     
  3. jetzt habe ich noch eine Frage :

    wie funzt das, wenn Spalte B als Uhrzeit formatiert ist ?
    Zur Zeit erhalte ich immer nur 0:00.
     
  4. Ola,

    sollten der Wert 20 bzw. 60 Minuten sein? Warum soll Spalte B in diesem Format erscheinen?
     
  5. ich baue mir eine Art Stempeluhr.
    Mo-Do. beträgt die Sollarbeitszeit = 8 Std.
    Freitags = 5 Std.

    Wenn ich nun angebe, dass ich um 7:30 Uhr gekommen bin und um 18:00 Uhr gegangen bin, dann wären das 10:30 Std. Arbeitszeit.
    Allerdings muss ich Mo-Do. noch einmal 60min. Pause, und Fr. 20min. Pause davon abziehen.
    Da alle Angaben Zeitangaben sind, muss ich die Felder als Uhrzeit formatieren.

    Die Spalte mit den Sollarbeitszeiten und den Pausenzeiten sollen sich aus dem Datum ergeben (Freitag, den 01.01.2004 soll zum Beispiel eine Sollarbeitszeit von 5 Std. und eine Pausenzeit von 20min. ergeben).
     
  6. Ola,

    dann verändere erstens die Formel:
    =WENN(WOCHENTAG(A1)=6;1/24*3;1/24)

    1/24 ergibt bezogen auf eine Tag genau eine Stunde = 60 Minuten
    1/24*3 ermittelt den dritten Teil einer Stunde = 20 Minuten

    Für die Formel mit 8 Stunden nimmst Du halt 8/24, bei Fünf 5/24.

    Für die Formatierung verwendest Du das Zellformat 37:30:55 in der Kategorie Uhrzeit.
     
  7. 1/24*3 ermittelt aber 3 Std. !

    habe jetzt 1/24*0,3333 ermittelt den dritten Teil einer Stunde = 20 Minuten
     
  8. okok..... die Formel habe ich nun fertig.
    Jetzt muss ich die Soll-Arbeitszeit mit der geleisteten verrechnen (um die +/-Differenz zu erhalten).

    Dazu rechne ich:
    1. gearbeitet bis-gerarbeitet von = Arbeitszeit
    2. Arbeitszeit-Sollarbeitszeit = +/-Differenz

    Hier habe ich nun das Problem, dass ich kein Ergebnis erhalte, wenn ich eine Minus-Differenz habe (Arbeitszeit < Sollarbeitszeit).

    Hilfe !!!
     
  9. Ola,

    das ist das übliche Problem. Die einfachste Lösung ist, unter Extras Optionen bei Berechnung auf 1904-Datumswerte zu gehen. Dann zeigt xl die negativen Werte auch negativ an. allerdings musst Du dann die schon vorhandenen Jahresangaben um vier Jahre zurücksetzen.

    Alternativ nimmst Du eine Wennformel in jeweils eine andere Spalte, die das ganz abfängt:

    Wenn(Sollarbeitszeit>Arbeitszeit;Sollarbeitszeit-Arbeitszeit;)
    Wenn(Sollarbeitszeit<Arbeitszeit;Arbeitszeit-Sollarbeitszeit;)

    Der zweite Weg ist aber komplizierter ....
     
Die Seite wird geladen...

Excel -> Problem mit einer Formel - Ähnliche Themen

Forum Datum
Excel 2003 - Kleines Problem mit einer Formel Microsoft Office Suite 25. Juni 2014
Problem mit Excel-2000-Verknüpfung von AutoCAD Windows XP Forum 1. März 2011
Excel Makro Problem! Windows XP Forum 24. Nov. 2010
Beim Office 2010-Excel Seitenansicht Problem Microsoft Office Suite 10. Nov. 2010
Probleme beim öffnen von Excel u. PowerPoint Dateien (Office2010) Microsoft Office Suite 14. Sep. 2010