excel summewenn

Dieses Thema excel summewenn im Forum "Microsoft Office Suite" wurde erstellt von hans jupp, 20. Apr. 2006.

Thema: excel summewenn hallo, ich habe in einer exceltabelle 3 spalten: - in spalte a stehen kontonummern - in spalte b stehen beträge -...

  1. hallo,

    ich habe in einer exceltabelle 3 spalten:
    - in spalte a stehen kontonummern
    - in spalte b stehen beträge
    - in spalte c stehen ja/nein kriterien

    nun möchte ich für jede vorhandene kontonummer die beträge, die als kriterium->ja' haben addieren lassen.

    mit summewenn bekomme ich die gesamtsummen pro konto hin, habe im moment aber leider keine idee, wie ich das kriterium mit einfließen lassen kann.

    vielen dank schonmal für euer hilfe :)

    gruß,
    kath.hundefriseursalon
     
  2. Es gibt die möglichkeit über (wenn) bei Excel.
    Ich habe das bei Staroffice mal gemacht und das sieht so aus
    =WENN(A2<>;A3+B3;)
    Die funktion geht wie folgt:
    du schreibst als Beispiel in A1 diese zeile
    Dann prüft er ob in B2 was drin ist es muß nicht
    umbedingt ja sein es reicht ein Zeichen dann
    rechnet er dir B3 und A3 zusammen und schreibt es
    dann die Summe in  A1
    Gruß
    Thomas
     
  3. Salue,

    ich versuche schon seit langem zu erfahren, was die bedeuten. Die Lösung ist soweit ich sehe in Ordnung :D
     
  4. hallo,

    das problem mit der wenn formel ist nur, daß ich damit nur einzelne zeilen prüfen kann.
    ich habe aber etwa 1000 zeilen, deren werte in abhängigkeit der kontonummer und des ja/nein kriteriums addiert werden sollen.

    bsp. (wobei a=kontonummer, b=wert, c=kriterium)
    a b c
    - - -
    1 3 ja
    1 2 ja
    1 4 nein
    2 1 ja
    2 6 ja

    als ergebnis soll dann herauskommen:
    1 = 5
    2 = 7

    ich hoffe, ihr versteht was ich meine ...

    gruß,
    kath.hundefriseursalon
     
  5. Hallo
    Ich kann dir nur eine Lösung geben
    die in meinen Augen am leichtesten ist.

    Alle Konten untereinander schreiben dann
    in D die Formel =WENN(C1<>;B1;) dann
    kannst du am ende von D dir die summe zusammen Rechnen.
    Vor der ganzen sache eine Sicherheits Kopie machen
    denn so eine sache kann schnell mal ins Auge gehen.
    Ich gehe mal davon aus  das du deine Tabelle schon Fertig
    hast  und die Nummern alle durch einander sind
    aber kein Problem du must sie dir nur einmal Sortieren
    dann zwischen den einzelnen Konten eine Zeile Einfügen wo
    du die summen Errechnet werden.
    Jetzt könnte es ja sein das wie bei deinem Beispiel eine 1
    dazukommt dann einfach wieder eine Zeile Einfügen.
    Beispiel du Fügst vor der Zeile 33 eine neue Zeile
    ein dann must du das feld D32 nach D33 Kopieren.

    Man kann in die ersten Anführunsstriche auch ein ja ja
    eingeben dan must du in dem zu Prüfenden feld auch ja eingeben
    Dann muß die formel aber so aus sehen =WENN(C1=ja;B1;)

    Es mag ja noch viele arten geben um das zu errechnen
    aber das ist das einzige was ich so schnell heraus finden kann.
    Ich hoffe es hilft dir bei deinen Berechnungen.

    Gruß
    Thomas
     
  6. Probiere es doch mal mit SUMMENPRODUKT

    Beispiel
    =SUMMENPRODUKT((A2:A10=kto1)*(C2:C10=ja)*(B2:B10))
    kto1 steht für die erste Kontonummer, dies musst Du anpassen für die jeweilige.

    Leerer Text.
     
  7. THX
     
  8. hallo,

    vielen dank für eure hilfe und anregungen!!!

    ich habe das problem jetzt mit einer hilfsspalte gelöst.
    in spalte d habe ich für jede zeile die formel: =wenn(c2=nein;;a2)
    da in spalte d dann nur konten auftreten, die auch addiert werden sollen, funktioniert dies dann mit->summewenn'.

    vielen dank nochmal für eure mühe :)

    gruß,
    kath.hundefriseursalon
     
Die Seite wird geladen...

excel summewenn - Ähnliche Themen

Forum Datum
Excel-Feature gesucht Microsoft Office Suite 11. Okt. 2016
Excel Tabelle Werte zu ordnen Microsoft Office Suite 23. Sep. 2016
Excel: Bereiche auf 'leer' Überprüfen Microsoft Office Suite 15. Sep. 2016
Import Datensatz inkl = und - Zeichen in Excel/Libre CALC Software: Empfehlungen, Gesuche & Problemlösungen 20. Mai 2016
Bestimmter User kann seine Excel Dateien nicht mehr direkt öffnen Software: Empfehlungen, Gesuche & Problemlösungen 16. Apr. 2016