Excel: Werte in einer n-ten zelle berechnen

Dieses Thema Excel: Werte in einer n-ten zelle berechnen im Forum "Microsoft Office Suite" wurde erstellt von jürschi, 12. Okt. 2010.

Thema: Excel: Werte in einer n-ten zelle berechnen Vielleicht kann mir jemand von den Experten bei folgenden Problem helfen: Ich benötige Gesamtsumme, Mittel-,...

  1. Vielleicht kann mir jemand von den Experten bei folgenden Problem helfen:

    Ich benötige Gesamtsumme, Mittel-, Maximum- und Minimumwerte von bestimmten Messergebnissen. Berechnet werden sollen die Werte von jeweils drei Messreihen, die (in einer sehr umfangreichen Tabelle) unmittelbar nach Abnahme abgepeichert wurden. Die Tabelle sieht (verkürzt) etwa so aus wie im angehängten JPG.

    Dabei beinhaltet Spalte A die hier relevanten Messergebnisse, die (drei) Messreihen sind farblich unterschiedlich gekennzeichnet. In den Zellen B3 - E5 sollen über eine Formel die gesuchten Werte berechnet werden.

    Für die Summenberechnung der blauen Messreihe in B3 habe ich auf eine Formel zurückgegriffen, die in einem definierten Bereich (hier A6 bis A1560) immer eine n-te Zelle (hier jede 3. Zelle, beginnend ab A6) addiert:
    B3: {=SUMME(WENN(REST(ZEILE(A6:A1560);3)=0;A6:A1560))} .
    Das Ergebnis ist korrekt.

    Ich war der Meinung, dass diese Formel ohne weiteres auch auf die gesuchten anderen Werte wie folgt übertragen werden kann:
    B4: {=SUMME(WENN(REST(ZEILE(A7:A1560);3)=0;A7:A1560))}
    B5: {=SUMME(WENN(REST(ZEILE(A8:A1560);3)=0;A8:A1560))}
    C3: {=MITTELWERT(WENN(REST(ZEILE(A6:A1560);3)=0;A6:A1560))}
    C4: {=MITTELWERT(WENN(REST(ZEILE(A7:A1560);3)=0;A7:A1560))}
    C5: {=MITTELWERT(WENN(REST(ZEILE(A8:A1560);3)=0;A8:A1560))}
    D3: {=MAX(WENN(REST(ZEILE(A6:A1560);3)=0;A6:A1560))}
    D4: {=MAX(WENN(REST(ZEILE(A7:A1560);3)=0;A7:A1560))}
    D5 {=MAX(WENN(REST(ZEILE(A8:A1560);3)=0;A8:A1560))}
    E3: {=MIN(WENN(REST(ZEILE(A6:A1560);3)=0;A6:A1560))}
    E4: {=MIN(WENN(REST(ZEILE(A6:A1560);3)=0;A6:A1560))}
    E5: {=MIN(WENN(REST(ZEILE(A6:A1560);3)=0;A6:A1560))}
    Das Ergebnis ist aber enttäuschend. Nur der Wert D3 ist korrekt, alle anderen sind falsch.

    Was ist verkehrt? Wo liegt mein Denkfehler?

    Gruß Jürschi
     
  2. Der Denkfehler liegt beim (Ab-)Zählen der Zeilen.

    In den Formeln in Zeile 4 muss vom Ergebnis der Funktion ZEILE() 1 abgezogen werden, bevor der Rest ermittelt wird.
    Also:

    Code:
    {=SUMME(WENN(REST(ZEILE(A7:A1560)-1;3)=0;A7:A1560))}
    Entsprechend in Zeile 5 den Wert 2 abziehen.
     
  3. Hi IrksEye,

    ganz herzlichen Dank! Das löst das Problem für die Summen-und Max-Werte.

    Noch eine Idee für die Mittel- und Min-Werte?

    Gruß Jürschi
     
  4. Das müßte eigentlich so gehen... In allen Formeln in Zeile 4 muss eins, in allen Formeln in Zeile 5 muss zwei an der genannten Stelle abgezogen werden.

    Mir fiel auf, dass der Bereich in den Formeln in E4 und E5 auch bei A6 anfängt und nicht analog zu den anderen Formeln bei A7 und A8... das ist zwar etwas inkonsequent, sollte aber eigentlich trotzdem klappen.
    Sind alle Formeln auch wirklich als Matrixformel eingegeben (Strg+Shift+Enter, die geschweiften Klammern werden dann automatisch erzeugt)? Das ist auch eine häufige Fehlerquelle beim Zurechtbiegen von Formeln, dann kommt nämlich nicht etwa eine Fehlermeldung sondern irgendein Wert heraus. Die geschweiften Klammern dürfen nicht über die Tastatur eingegeben werden.
     
  5. Oh sorry, da habe ich in meinem Themenstarter zu E4 und E5 etwas Falsches notiert. Natürlich fängt auch hier der jeweilige Bereich mit A7 bzw. A8 an.

    Der->Abzug' funktioniert in C und E leider nicht. Das scheint mir aber an einem grundsätzlichen Fehler in der Formel zu liegen, weil schon die Ergebnisse in C3 und E3 falsch sind ...

    Ach so, die Matrixformeln sind alle korrekt eingegeben.
     
  6. Hallo zusammen,

    Also folgende Formeln als Matrixformel (Strg+Shift+Enter) eingegeben sollten funktionieren

    Code:
    B3: =SUMME(WENN(REST(ZEILE(A6:A1560);3)=0;A6:A1560))
    B4: =SUMME(WENN(REST(ZEILE(A6:A1560);3)=1;A6:A1560))
    B5: =SUMME(WENN(REST(ZEILE(A6:A1560);3)=2;A6:A1560))
    C3: =MITTELWERT(WENN(REST(ZEILE(A6:A1560);3)=0;A6:A1560))
    C4: =MITTELWERT(WENN(REST(ZEILE(A6:A1560);3)=1;A6:A1560))
    C5: =MITTELWERT(WENN(REST(ZEILE(A6:A1560);3)=2;A6:A1560))
    D3: =MAX(WENN(REST(ZEILE(A6:A1560);3)=0;A6:A1560))
    D4: =MAX(WENN(REST(ZEILE(A6:A1560);3)=1;A6:A1560))
    D5: =MAX(WENN(REST(ZEILE(A6:A1560);3)=2;A6:A1560))
    E3: =MIN(WENN(REST(ZEILE(A6:A1560);3)=0;A6:A1560))
    E4: =MIN(WENN(REST(ZEILE(A6:A1560);3)=1;A6:A1560))
    E5: =MIN(WENN(REST(ZEILE(A6:A1560);3)=2;A6:A1560))
    Gruß Matjes :)
     
  7. Hallo Matjes,

    ich kann zZ leider nur sporadisch vorbeischauen - daher die etwas verspätete Reaktion.

    Danke für den Beitrag.

    Das Problem ist allerdings weiterhin nicht komplett gelöst. Die Gesamt- und Max-Werte sind richtig berechnet, die Werte für Mittel- und MIN-Werte leider nicht.
    Die Ergebnisse in meinem Beispiel:
    C3 = 0,07736 (Soll: 6,3667), C4 und C5 dto.
    E3 = 0 (Soll: 5,1), E4 und E5 dto.

    Gruß Jürschi
     
  8. Also nach Ansicht der Datei lag es an der nicht angepassten Bereichsangabe.
    Abhilfe wurde dadurch geschaffen, dass die Fromeln über die gesamte Spalte A ab A6 laufen und in den Formeln abgefragt wird, ob überhaupt etwas in Spalte A steht.
    Code:
    B3: =SUMME(WENN((REST(ZEILE(A6:A65500);3)=0)*(<>(A6:A65500));A6:A65500))
    B4: =SUMME(WENN((REST(ZEILE(A6:A65500);3)=1)*(<>(A6:A65500));A6:A65500))
    B5: =SUMME(WENN((REST(ZEILE(A6:A65500);3)=2)*(<>(A6:A65500));A6:A65500))
    
    C3: =MITTELWERT(WENN((REST(ZEILE(A6:A65500);3)=0)*(<>(A6:A65500));A6:A65500))
    C4: =MITTELWERT(WENN((REST(ZEILE(A6:A65500);3)=1)*(<>(A6:A65500));A6:A65500))
    C5: =MITTELWERT(WENN((REST(ZEILE(A6:A65500);3)=2)*(<>(A6:A65500));A6:A65500))
    
    D3: =MAX(WENN((REST(ZEILE(A6:A65500);3)=0)*(<>(A6:A65500));A6:A65500))
    D4: =MAX(WENN((REST(ZEILE(A6:A65500);3)=1)*(<>(A6:A65500));A6:A65500))
    D5: =MAX(WENN((REST(ZEILE(A6:A65500);3)=2)*(<>(A6:A65500));A6:A65500))
    
    E3: =MIN(WENN((REST(ZEILE(A6:A65500);3)=0)*(<>(A6:A65500));A6:A65500))
    E4: =MIN(WENN((REST(ZEILE(A6:A65500);3)=1)*(<>(A6:A65500));A6:A65500))
    E5: =MIN(WENN((REST(ZEILE(A6:A65500);3)=2)*(<>(A6:A65500));A6:A65500))
    
    Gruß Matjes:)
     
  9. Hallo Matjes,

    Problem gelöst! Die Formeln sind in jeder Beziehung->passend' :froehlich1:.

    Nochmals->großes Dankeschön' für deine persönliche Hilfe!

    Grüße Jürschi
     
Die Seite wird geladen...

Excel: Werte in einer n-ten zelle berechnen - Ähnliche Themen

Forum Datum
Excel Tabelle Werte zu ordnen Microsoft Office Suite 23. Sep. 2016
Excel '10 - Frage zu Option "AutoVervollständigen für Zellwerte!" Microsoft Office Suite 16. Juli 2012
Excel: Summe beliebiger Anzahl Zellen (also nicht die Werte) ? Microsoft Office Suite 2. Dez. 2010
Excel - Werte unterschiedlicher Tabellenblätter für Übersicht automatisch ziehen Microsoft Office Suite 22. Aug. 2010
Excel 2007 Datenblatt - Standardwerte wiederherstellen? Windows XP Forum 9. Aug. 2009