EXCEL:Zeitangaben addieren? Wie? 00:00:02

Dieses Thema EXCEL:Zeitangaben addieren? Wie? 00:00:02 im Forum "Microsoft Office Suite" wurde erstellt von herich, 18. Okt. 2004.

Thema: EXCEL:Zeitangaben addieren? Wie? 00:00:02 Wie addiere ich Zeitangaben. Eventuell auch noch mit Framerate. Bsp.: 00:00:02:14 + 00:00:22:14 müsste 00:00:25:03...

  1. Wie addiere ich Zeitangaben. Eventuell auch noch mit Framerate.
    Bsp.: 00:00:02:14 + 00:00:22:14 müsste 00:00:25:03 ergeben bei 25 Frames per sec.
     
  2. Die Lösung ist ziemlich kompliziert.
    Ein Haken ist noch ungelöst, aber ich arbeite daran.

    [edit]
    bin leider noch nicht dazu gekommen, aber es gedeiht. Es ist doch viel komplizierter als ich gedacht hab.
    [/edit]

    [edit 20.10.2004]
    ich bin voll bis unters Dach, aber ich vergesse es nicht. Interessiert mich nämlich selber. In den nächsten Tagen kommt sicher ein Ergebnis. Es ist wirklich wahnsinnig kompliziert.
    [/edit]
     
  3. Heureka! ;D ;D ;D ;D ;D ;D ;D
    Es sieht im Ergebnis nicht besonders spektakulär aus, aber die Herleitung war vom allerfeinsten. Also: nicht versuchen zu verstehen, sonst Kurzschluß :p

    Du mußt die Zeiten geteilt eingeben: Spalte A: Stunden, Spalte B: Minuten, Spalte C: Sekunden, Spalte D: Frames, Spalte E: Klartext
    Das Ergebnis steht in Zeile 2.
    In A3:A1000 schreibst du jeweils die Stunden deiner Zeitabschnitte rein.
    In B3:B1000 die Minuten.
    In C3:C1000 die Sekunden.
    In D3:D1000 die Frames.
    Für den Fall, daß du auch Wert auf konventionelle Darstellung legst (hh:mm:ss:ff), habe ich in Spalte E folgende Zusatzspalte gebastelt:
    in E2:
    Code:
    =WENN(UND(A2=;B2=;C2=;D2);;TEXT(A2;00)&:&TEXT(B2;00)&:&TEXT(C2;00)&:&TEXT(D2;00))
    Formel bis E1000 runterziehen.

    Jetzt zu den Ergebnis-Zellen:
    A2:
    Code:
    =SUMME(A3:A1000)+(SUMME(B3:B1000)+(SUMME(C3:C1000)+(SUMME(D3:D1000)
    -REST(SUMME(D3:D1000);25))/25-REST(SUMME(C3:C1000)+(SUMME(D3:D1000)
    -REST(SUMME(D3:D1000);25))/25;60))/60-REST(SUMME(B3:B1000)+(SUMME(C3:C1000)
    +(SUMME(D3:D1000)-REST(SUMME(D3:D1000);25))/25-REST(SUMME(C3:C1000)
    +(SUMME(D3:D1000)-REST(SUMME(D3:D1000);25))/25;60))/60;60))/60
    B2:
    Code:
    =REST(SUMME(B3:B1000)+(SUMME(C3:C1000)+(SUMME(D3:D1000)-REST(SUMME(D3:D1000);25))/25
    -REST(SUMME(C3:C1000)+(SUMME(D3:D1000)-REST(SUMME(D3:D1000);25))/25;60))/60;60)
    C2:
    Code:
    =REST(SUMME(C3:C1000)+(SUMME(D3:D1000)-REST(SUMME(D3:D1000);25))/25;60)
    D2:
    Code:
    =REST(SUMME(D3:D1000);25)
    Aber sag mal: zu was braucht man denn sowas ???
     
  4. Mal ganz abgesehen von dem Spezialfall mit den Frames...
    Ein Zeit-Feld sieht hat folgendes Format: hh:mm:ss
    Mit STUNDE(feld), MINUTE(feld) und SEKUNDE(feld) kann man die einzelnen Werte der Zeitangabe im Feld feld ansprechen. Vielleicht hilft das ja schon weiter.
    BTW: zwei Zeit-Felder addieren funktioniert hier ohne weiteres.
    Wie gesagt: alles mal ganz abgesehen von dem Spezialfall mit den Frames...

    Greetz
    M.
     
  5. :)
    Danke für die Lösung des Problems.
    Werde es beim nächsten mal ausprobieren.

    Das das nicht irgendwie implementiert ist und so kompliziert ist, hätte ich nicht gedacht.

    Ich hatte eine Schnittliste eines Filmes wo sich einige Szenen dazwischengeschoben haben. Somit haben sich auch alle nachfolgenden Zeiten verschoben.
     
  6. Hallo,
    unterstützt Excel auch andere Zeitformate. Ich hatte mal versucht von einer Arbeitszeiterfassung die Zeiten zu adddieren.
    Dort sind ja die minuten immer auf 100 bezogen.

    gruß wapi
     
  7. Für Industrieminuten mußt du die genannten Formeln entsprechend ändern. Meines Wissens hat Excel keine Industrieminuten.
    Aber viel einfacher ist es doch, einfach mit Dezimalzahlen zu arbeiten.
     
Die Seite wird geladen...

EXCEL:Zeitangaben addieren? Wie? 00:00:02 - Ähnliche Themen

Forum Datum
VB 2008 - Ziffern addieren Webentwicklung, Hosting & Programmierung 1. Apr. 2010
Excel, werte addieren wenn buchstabe in zelle Windows XP Forum 8. März 2007
Referenzdatum in Excel addieren Microsoft Office Suite 2. Sep. 2006
OO: Zellen (Zahl) kopieren und um 1 addieren StarOffice, OpenOffice und LibreOffice 22. Sep. 2005
Kopieren - Aufaddieren Windows XP Forum 18. Juli 2005