excel: Zellen ausblenden wenn nächstes monat

Dieses Thema excel: Zellen ausblenden wenn nächstes monat im Forum "Windows XP Forum" wurde erstellt von 2beers, 21. Juni 2006.

Thema: excel: Zellen ausblenden wenn nächstes monat Hoi! Ich muss immer wieder (meist monatlich...:-)) monatslisten in excell erstellen. Dafür habe ich mir eine...

  1. Hoi!

    Ich muss immer wieder (meist monatlich...:)) monatslisten in excell erstellen.
    Dafür habe ich mir eine vorlage geschaffen, in welche ich nur noch oben das jeweilige monat eingebe, excel schreibt mir dann die datumsangaben nach meinen wünschen hin.
    Was excel nicht macht, ist am ende des monats zu stoppen:
    Meine listen sind natürlich lange genug um monate mit 31 tagen vollständig anzuzeigen. Wenn das monat nun aber weniger tage hat, werden diese ebenso angezeigt & ich muss sie jedesmal händisch ausblenden bzw löschen.
    Wie kann ich das automatisieren?




    [SW]
    Zellen ausblenden, verstecken, monatsliste erstellen
     
  2. Hallo 2beers,

    Du kannst mit DATWERT() prüfen, ob das Datum existiert. Wenn nicht, wirft diese Funktion einen Fehler. Den kannst du mit ISTFEHLER abfragen und in einer WENN Funktion dann die Zelle entsprechend setzen.

    Beispiel:
    A1 - Monatszahl
    A4 - Datum des 1. des Monats
    .....
    A31 - Datum des 28. des Monats
    A32 - Datum des 29. des Monats
    A33 - Datum des 30. des Monats
    A34 - Datum des 31. des Monats

    In A4 die Formel:
    Code:
    (ZEILE(A4)-ZEILE($A$4)+1)&.&$A$1&.2006
    diese Formel ist runtergezogen bis A34, so daß in A34 steht:
    Code:
    (ZEILE(A34)-ZEILE($A$4)+1)&.&$A$1&.2006
    Wie oben beschrieben, änderst Du die Formel in A4 zu:
    Code:
    =WENN(ISTFEHLER(DATWERT((ZEILE(A4)-ZEILE($A$4)+1)&.&$A$1&.2006));;(ZEILE(A4)-ZEILE($A$4)+1)&.&$A$1&.2006)
    und ziehst sie dann bis A34
    Code:
    =WENN(ISTFEHLER(DATWERT((ZEILE(A33)-ZEILE($A$4)+1)&.&$A$1&.2006));;(ZEILE(A33)-ZEILE($A$4)+1)&.&$A$1&.2006)
    Gruß  Matjes :)
     
Die Seite wird geladen...

excel: Zellen ausblenden wenn nächstes monat - Ähnliche Themen

Forum Datum
Zellen in Excel ziehen Ergänzung des vorhandenen Makors Microsoft Office Suite 10. Juli 2011
Excel 2003 Kann man bestimmte Zellen im Listenbereich schützen? Microsoft Office Suite 24. Feb. 2011
Excel: Summe beliebiger Anzahl Zellen (also nicht die Werte) ? Microsoft Office Suite 2. Dez. 2010
Excel: Zellen verbinden Windows XP Forum 25. Juni 2010
Excel - Anfänger - Zelle soll nur durch best. Anzahl der Zellen teilen Windows XP Forum 5. Feb. 2010