Excel

Dieses Thema Excel im Forum "Microsoft Office Suite" wurde erstellt von ministry, 29. Sep. 2003.

Thema: Excel So Leute ich hab da ein Problem habe die Aufgabe zu jedem Kunden eine Kundennummer zu schreiben. Da manche Kunden...

  1. So Leute ich hab da ein Problem

    habe die Aufgabe zu jedem Kunden eine Kundennummer zu schreiben. Da manche Kunden 10 oder mehrfach vorkommen suche ich eine möglichkeit das alles zu ver einfachen.

    hatte mir gedacht ob das nicht mit einer if abfrage geht?

    quasi


    wenn Spalte E=Firma dann schreibe in spalte f=Kundennummer
    sonst
    wenn Spalte E=Firma dann schreibe in spalte f=Kundennummer


    usw.

    danke schonmal
     
  2. Das geht, aber ich brauch mehr Informationen.
    Soll es eine beliebige Kundennummer sein?
    Sollen die Kundennummern fortlaufend sein? Bei 1 anfangen?
    Wieviel Kunden sind es überhaupt?
    Gibt es mehrere Kunden, die Müller heißen, und wenn ja, wie unterscheidet man sie? Gibt es also eine Spalte Name und eine Spalte Vorneme oder steht der ganze Kunde in einer einzigen Zelle?
    Soll die Aktion einmalig sein oder soll jeder neue Kunde automatisch eine Kunednnummer kriegen?
    Schick mal ein originalgetreues Beispiel (ca. 50 Zeilen lang).
     
  3. Also


    Die Kundennummern sind bereits vergeben.
    Die Kundennummern sollen jetzt in die bestehende EXCEL liste eingefuegt werden.
    Doppelnamen sind keine. Ich muss quasi die schon Festvergebenen Kundennummern in eine Excel Tabelle ein ordnen.
     
  4. Es gibt also 2 Listen: eine mit Kundennummern und eine ohne?
    In der Liste mit ist jeder Kunde nur ein einziges Mal enthalten?
    In der Liste ohne sind nur Leute, die auch in der Liste mit sind?
    In der Liste ohne könnte aber ein und derselbe Kunde mehrfach auftauchen?
    Und bei jedem Datensatz ohne soll die korrekte Kundennummer aus mit eingefügt werden?

    ohne mit
    A B | A B
    1 Meier | Meier - 1001
    2 Müller | Müller - 1002
    3 Huber | Huber - 1003
    4 Huber | Lehmann - 1004
    5 Meier | ...
    6 Müller | ...
    7 Lehmann | ...
    8 Meier | ...
    ... | ...

    Stimmt das so?
    Damit hätten wir es schon fast geschafft.
    Die Datensätze in mit aufsteigend nach Namen sortieren.
    In die Zelle B2 in ohne folgende Formel reinschreiben:
    =SVERWEIS(A2;mit!$A$1:$B$10000;2;WAHR)
    Die Formel ziehst du jetzt in Spalte B der Liste ohne nach unten.

    Erklärung:
    mit!$A$1:$B$10000 ist die Matrix in der Liste mit, wo nach den Kundennummern gesucht werden soll (im Beispiel bin ich von 10000 definierten Kunden ausgegangen).
    2 bezieht sich darauf, daß der Wert der 2. Spalte der Matrix (also Spalte B im Beispiel) ausgegeben wird.
     
  5. ja danke das war schonmal sehr hilfreich,
     
Die Seite wird geladen...

Excel - Ähnliche Themen

Forum Datum
Excel-Feature gesucht Microsoft Office Suite 11. Okt. 2016
Excel Tabelle Werte zu ordnen Microsoft Office Suite 23. Sep. 2016
Excel: Bereiche auf 'leer' Überprüfen Microsoft Office Suite 15. Sep. 2016
Import Datensatz inkl = und - Zeichen in Excel/Libre CALC Software: Empfehlungen, Gesuche & Problemlösungen 20. Mai 2016
Bestimmter User kann seine Excel Dateien nicht mehr direkt öffnen Software: Empfehlungen, Gesuche & Problemlösungen 16. Apr. 2016