Excell Tabelle mit 30 Werten ausgebenlassen?

Dieses Thema Excell Tabelle mit 30 Werten ausgebenlassen? im Forum "Windows XP Forum" wurde erstellt von Schlorz, 19. Jan. 2006.

Thema: Excell Tabelle mit 30 Werten ausgebenlassen? Hi. Es geht um folgendes Problem: Ich habe eine Tabelle mit die zu 30 Zahlbereichen je einen Wert zur Verfügung...

  1. Hi.

    Es geht um folgendes Problem:
    Ich habe eine Tabelle mit die zu 30 Zahlbereichen je einen Wert zur Verfügung stellt. Ich soll eine Funktion für Excell schreiben, die nach eingabe einer Zahl den zugehörigen Wert ausspuckt.

    Kein Ding mit WENN(eingabekoordinate<=1;0.1;WENN(...)) usw.. Bis auf einen kleinen aber entscheidenen Punkt: Excell kann nur 7 Ebenen verarbeiten.
    30 wären demnach nicht drin.

    Was nu?
     
  2. Hallo Schlorz,

    das mit 7 WENN bezieht sich auf die Schachtelungstiefe. Wenn man es in Teile Zerlegen kann und diese Teile dann einfach verkettet gehts auch weiter. Die nächste Begrenzung ist dann die Länge der Formel. Irgendwann sagt Excel Formel zu lang.

    Dies ist auch bei der Erstellung dieser Formel passiert  :mad:
    Um deinem Beispiel möglichst Nahe zu kommen, hab ich die Zelle A2 mit dem Namen->eingabekoordinate' belegt und ihn dann in der Formel benutzt. Ruckzuck bekam ich die Meldung.
    Daraufhin hab ich den Namen von->eingabekoordinate' in->ek' geändert und dann klappt es . :D

    Wert x kannst Du dann durch die Bereichs-Angabe deiner 30 Zellen ersetzen.

    Code:
    =WENN(UND(A2>=0;A2<=5);WENN(ek=0;;WENN(ek=1;Wert 1;WENN(ek=2;Wert 2;WENN(ek=3;Wert 3;WENN(ek=4;Wert 4;WENN(ek=5;Wert 5;))))));)&
    WENN(UND(A2>=6;A2<=11);WENN(ek=6;Wert 6;WENN(ek=7;Wert 7;WENN(ek=8;Wert 8;WENN(ek=9;Wert 9;WENN(ek=10;Wert 10;WENN(ek=11;Wert 11;))))));)&
    WENN(UND(A2>=12;A2<=17);WENN(ek=12;Wert 12;WENN(ek=13;Wert 13;WENN(ek=14;Wert 14;WENN(ek=15;Wert 15;WENN(ek=16;Wert 16;WENN(ek=17;Wert 17;))))));)&
    WENN(UND(A2>=18;A2<=23);WENN(ek=18;Wert 18;WENN(ek=19;Wert 19;WENN(ek=20;Wert 20;WENN(ek=21;Wert 21;WENN(ek=22;Wert 22;WENN(ek=23;Wert 23;))))));)&
    WENN(UND(A2>=24;A2<=29);WENN(ek=24;Wert 24;WENN(ek=25;Wert 25;WENN(ek=26;Wert 26;WENN(ek=27;Wert 27;WENN(ek=28;Wert 28;WENN(ek=29;Wert 29;))))));)&
    WENN(UND(A2>=30);WENN(ek=30;Wert 30;nicht Zulässig :-));)
    Gruß Matjes  ;)
     
  3. danke.

    :)
     
Die Seite wird geladen...

Excell Tabelle mit 30 Werten ausgebenlassen? - Ähnliche Themen

Forum Datum
Nach Download von OO 2.4 Probleme mit Formeln aus Excell- Tabellen StarOffice, OpenOffice und LibreOffice 29. Apr. 2008
(Excell) Dropdown mit "Haken" und "X" einfügen !? Windows XP Forum 29. Juni 2012
.txt Dateien mit Excelliste zusammenführen Microsoft Office Suite 22. Nov. 2006
Doppelte Einträge in Excellisten filtern Windows XP Forum 23. Jan. 2006
Datenauswahl in Excell aus Access Datenbank Windows XP Forum 25. Feb. 2004