Explorerersatz

Dieses Thema Explorerersatz im Forum "Windows 95-2000" wurde erstellt von Mintschi, 24. Sep. 2003.

Thema: Explorerersatz Hallo, da mir in letzter Zeit ewig der Windows Explorer aufgrund irgendwelcher Speicherprobleme abstürzte hatte ich...

  1. Hallo,

    da mir in letzter Zeit ewig der Windows Explorer aufgrund irgendwelcher Speicherprobleme abstürzte hatte ich mich dazu entschlossen, den IdosWin-Explorer als Ersatz zu nutzen.
    Ich habe dies über Einstellungen->Ordneroptionen->Dateitypen bewerkstelligt, indem ich alle Explorerzuordnungen auf den IdosWin gelegt habe.
    Nun lassen lassen sich alle Ordner und Laufwerke einwandfrei mit dem IdosWin-Explorer öffnen bis auf Eigene Dateien und alle Sub-Ordner, diese werden noch mit dem Windows Explorer geöffnet.
    Kann mir jemand verraten, wie ich diese Ordner dem IdosWin zuordnen kann?

    Gruß,
    Mintschi
     
  2. Ich kenne IdosWin zwar nicht, aber wenn es ein vollwertiger Explorer-Ersatz ist, dann musst du in der System.ini (c:\windows) folgenden Eintrag unter dem Abschnitt [Boot] ändern:

    von
    shell=explorer.exe

    in
    shell=IdosWin.exe (oder wie immer die Datei heißt).

    Nach einem Neustart solltest du dann deine neue Shell haben. Mache aber lieber vorher eine Sicherheitskopie der system.ini. Falls was schiefgeht, kopierst du die Sicherungskopie einfach über die system.ini.
     
  3. Hi,

    das funktioniert leider nicht, da IdosWin leider kein vollwertiger Explorerersatz ist.
    Gibt es eine andere Möglichkeit, um den Ordner Eigene Dateien in den Griff zu bekommen?

    Mintschi
     
  4. Hallo,

    in Explorer unter Extras >Ordneroptionen>Dateitypen findest Du den Ordner Eigene Dateien bei MyDocs.

    Erweitert anklicken und hier Neu anklicken. Dann bei Vorgang öffnen eintragen und bei Anwendung für diesen Vorgang mal den Verzeichnispfad und den Namen Deiner Datei eintragen plus Endung und danach %1. Muß beides getrennt in Hochkomma stehen.

    Also z.B.
    C:\Programme\Idos\Idoswin.exe %1

    Das ist der normale Vorgang. Da der Ordner Eigene Dateien aber quasi ein SystemOrdner ist, kann ich nicht mit Bestimmtheit sagen ob es auch klappt.

    MfG maneich
     
  5. Moin,

    geht leider nicht. :(

    Mintschi
     
  6. Hallo,

    setze es mal ohne Leerzeichen, also

    C:\Programme\Idos\Idoswin.exe%1

    MfG maneich
     
  7. Nein, geht auch nicht.
    Es wird angezeigt, dass das Programm nicht gefunden wurde. ???
     
  8. Hallo,

    wenn das Programm nicht gefunden wird, sind Deine Pfadangaben falsch.

    Letzte Möglichkeit, lege eine Kopie von dem Programm in C:\Windows ab und gib nur den Dateinamen an.

    Du mußt aber immer in der System.ini hinter

    shell=Explorer.exe;Idoswin.exe setzen

    wenn in Windows abgelegt oder

    shell=Explorer.exe;Verzeichnispfad\Idoswin.exe

    wenn nicht in Windows abgelegt.

    MfG maneich
     
  9. Hi,

    die Datei wurde unter Dateitypen nicht erkannt, da kein Leerzeichen zwischen Pfad und Variablen war, ansonsten wurde der Eintrag akzeptiert.

    Uiuiuiuiuiuiuiuiuiui
    dieser Eintrag hat für Chaos gesorgt und zur Neuinstallation von Windows aufgefordert.
    Ist eigentlich auch logisch, man kann doch schließlich nicht zwei Programme an dieser Stelle zugleich laden, oder?!

    Mintschi
     
  10. Hallo,

    in der System.ini hinter explorer.exe tragen sich gerne unerwünschte Programme ein, die man sich bein surfen holen kann. Also geht es, aber diese Programme müssen schon mit der explorer.exe verträglich sein. Deines ist das nicht.

    Du kannst das also nur über die Datei-Typen austesten.

    Möglicherweise läßt sich der Ordner Eigene Dateien nicht mit einem Fremdprogramm öffnen, da er eine eigene .dll-Datei hat MyDocs.dll in C:\Windows\System und evtl. alles diesen Ordner betreffend darüber gesteuert wird.

    In der Registry unter dem Schlüssel
    HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}
    findest Du auch die entsprechenden Einträge. Darüber hinaus ist die Datei MyDocs.dll auch noch in vielen anderen Registry-Schlüssel eingetragen und ich weis nicht wo man den dort ändern könnte/müßte.

    MfG maneich