Gameport Ressourcenproblem (IRQ) !!!!

Dieses Thema Gameport Ressourcenproblem (IRQ) !!!! im Forum "Hardware" wurde erstellt von babylonbob, 7. Dez. 2004.

Thema: Gameport Ressourcenproblem (IRQ) !!!! Hallo, ich bin so ziemlich am Ende, hoffentlich kann mir jemand helfen. Also folgendes Problem: Ich habe meinen...

  1. Hallo, ich bin so ziemlich am Ende, hoffentlich kann mir jemand helfen.

    Also folgendes Problem:
    Ich habe meinen Computer aufgerüstet und seit der Neuinstallation von WIN XP funktioniert der Gameport meiner PCI Soundkarte nicht mehr (Ressourcenproblem, Code 12). Hatte zuvor habe auch ein MSI Board und es lief einwandfrei.
    Ich habe mittlerweile eine Menge rumgesurft und in vielen Foren gesucht, anscheinend haben auch mehrere dieses Problem, jedoch fand ich noch nirgendwo einen Ansatz zur Lösung.
    Da meine Soundkarte (Creativ) auch bestimmt schon 5 Jahre auf dem Buckel hat, habe ich mir heute auch mal eine neue PCI Karte 5.1 zugelegt, das Problem bleibt aber bestehen: der Sound funktioniert, aber der Gameport kann nicht betrieben werden.

    Im Gerätemanager habe ich mir auch mal die IRQ Verteilung angeschaut, da dies anscheinend das Problem darstellt.
    Die PCI Soundkarte belegt zusammen mit dem VIA OHCI-konformer IEEE 1394 Hostcontroller den IRQ Port 19, aber ich kann den IRQ Port im Bios nirgendwo ändern bzw. selbt zuweisen.
    Ich weiß noch nicht mal genau, wofür diese Hostcontroller gut sein soll, scheint aber doch standardmäßig erforderlich, oder??

    Ich habe nun schon öfter gelesen & gehört, dass man im Bios den ACPI Modus deaktieren muss um einen IRQ Port selbst zuweisen zu können, aber ich finde nur die APIC Einstellung (ist ja was anderes und kann ich nicht einfach so deaktivieren, dann startet der Rechner nicht).

    Also habe ich auch schon mal den seriellen Port im Bios deaktiviert um evtl. einen IRQ Port freuzumachen, aber hat alles nix gebracht.

    Was kann ich im Bios nun noch ändern bzw. wie kriege ich den Gameport nun endlich aktiviert???

    Den Onboard Sound habe ich selbstredend deaktiviert und einen Onboard Gameport gibt es nicht.

    Im Gerätemanager sind neben dem Gameport und der PCI Soundkarte noch folgende Verbindungen angezeigt:
    Legacy Audiotreiber
    Audiocodecs
    Videocodecs
    Mediensteuerungsgerät
    Legacy Videoaufnahmegerät

    Diese Verbindungen kann ich aber werder deaktivieren noch was in den Einstellungen ändern.

    Bitte helft mir.


    Danke
     
  2. Hallo
    Ich hoffe es ist noch aktuell ....

    Hast Du die Karte mal in einen anderen PCI-Slot gesteckt ?
    Sind sonst noch PCI-Karten im Rechner und in welchen Slots stecken sie ?

    In einem guten Handbuch ist auch eine Tabelle , wie intern die PCI-IRQ belegung ist .
     
  3. ja, es ist noch absolut aktuell, aber ich bin schon kurz davor aufzugeben.

    also umgesteckt habe ich die alte wie auch die neue pci-soundkarte, aber bringt keine änderung.
    ich habe auch den via1394 hostcontroller einmal im bios deaktiviert, so dass die soundkarte auf jeden fall einen ungeteilten IRQ port zugewiesen bekam, aber auch ohne erfolg.
    wenn ich im bios die irq verteilung auf manuell statt automatisch stelle, dann kann ich bis IRQ 15 zwar den port reservieren, im gerätemanager hat die soundkarte jedoch den IRQ port 19.
    ich habe natürlich auch versucht die speicheradresse manuell zu ändern, die basiskifuration dann auf 0001 geändert, jedoch bleiben die verschiedenen auszuwählenden E/A bereiche immer im konflikt und ich kann ja nicht einfach irgend welche zahlen eingeben (wurde mir auch von abgeraten, diese adressen manuell zu ändern).

    ich habe nun schon in so vielen foren geblättert und anscheinend haben auch sehr viele dieses problem, aber ich habe noch keinen passenden lösungsansatz gefunden. einen funken hoffnung habe ich noch.


    danke
     
  4. Sind da noch andere Karten in den PCI-Slots ?
    Falls ja , alle Karten Treiber deinstallieren und raus damit.

    Dann zuerst die Soundkarte rein - versuche mal den zweiten PCI unter dem AGP .Dann die Treiber installieren und schauen welchen IRQ die Karte jetzt hat.Fall i.O. die nächste Karte in den nächsten Slot oder die Soundkarte deinstallieren und im 3 PCI stecken ind installierten.

    Falls es im BIOS die Option Reset Configuration Data gibt auf enabled setzen.
     
  5. Logisch weil ACPI und APIC.

    Das ist der Controller für dei Firewire-Schnittstelle.

    Welches Board?
     
  6. also mein board ist ja unten in meinem kommentar angegeben.

    mit dem umstecken deinstallieren und wieder installieren klappt auch nicht, habe ich schon bereits gemacht. ansonsten sind alle pci steckplätze unbelegt.

    und den firewire IRQ habe ich ja auch schon mal probeweise deaktiviert.

    im bios gibt es eine o.g. funktion nicht.
    das komsiche ist ja auch: selbst wenn die soundkarte einen IRQ für sich alleine zugewiesen bekommen hat, funktioniert der gameport trotzdem nicht. der sound selbst ist immer einwandfrei, auch wenn der gameport nicht gestartet werden kann.

    ich habe den gameport auch mal versuchsweise als standardgameport installiert (nicht von creative), aber auch ohne erfolg.

    ich habe wohl in einem forum mal gelesen, dass boards mit den nforce chip 2 (also quasi vorgänger von meinem board) auch dieses problem hatten und das selbst die soundkarten hersteller (z.b. terratec) gesagt haben, dass dieses problem nicht behoben kann (aus designtechnischen gründen der boardhersteller).
     
  7. Wenn Du einen Slot gefunden hast , in dem die Soundkarte einen eigenen IRQ hat würde ich sie darin lassen.Es ist immer von vorteil wenn die Soundkarte einzeln ist .
    Das Problem mit dem Gameport auf allen Nforce2 Board kann ich nicht bestätigen , weil ich den Chipsatz habe und der Gameport funktioniert ohne Probleme .
    Ich vermute jetzt das es vom Treiber kommt .Bei einem IRQ-Problem sollte die Soundausgebe auch betroffen sein .Mein Gameport wird nur als I/O-Adresse angesteuert - ohne IRQ - ist ja auch mit auf der Soundkarte.

    Hast Du die Möglichkeit die I/O-Adresse manuell zu ändern ? versuche es so lange bis eine freie Adresse gefunden ist. Dann nochmal den Treiber installieren.
    Evtl. hilft es mit winRar den creative Treiber zu entpacken und nur den Gameporttreiber zu installieren.
     
  8. die soundausgabe war nie betroffen, egal ob sich die karte mit dem firewire anschluss (via1394 hostcontroller) den IRQ geteilt hat oder nicht. ich habe ihn trotzdem deaktiviert, also die soundkarte hat defintiv einen eigenen IRQ.

    meinst du mit der speicheradresse I/O also den E/A Bereich, oder ist das wieder etwas anderes??
    bei mir steht dort 0200-0207 aber wenn ich diesen manuell ändere kann ich nur zwei andere adressen aussuchen und unten steht direkt wieder dass dort ein konflikt besteht. und ich kann doch nicht irgendeine adresse dort eingeben, oder?? dann könnte doch ein konflikt mit einem anderen gerät entstehen und was soll ich denn sonst ausser den auszuwählenden bereichen nehmen?

    und wenn du mit dem I/O bereich etwas anderes meinst dann sag mal bitte wo ich das denn ändern kann.
    den E/A bereich kann ich ja manuell im gerätemanager beim gameport unter ressourcen ändern.

    auf der creative homepage habe ich mir mal den XP treiber runtergeladen (laut evererst habe ich eine PCI 128 karte), aber da wird nur irgendetwas automatisch entpackt und ich werde registriert. danach startet der computer neu, aber das problem bleibt wie zuvor. und ein verzeichnis in dem der treiber entpackt wird sehe ich auch nicht, wird wohl direkt automatisch installiert.

    ich hoffe ich habe alles verständlich beschrieben.
     
  9. i/O und E/A ist das gleiche

    Mit welchen Adressen entsteht der Konflikt,wenn Du die Adessen manuell änderst ?
     
  10. ich kann folgende adressen auswählen (nur bei basiskonf. 0001):

    0208-020F
    0218 - 021F
    0210 - 0217

    aber unten steht dann immer ressource ist nicht verfügbar und wenn ich es doch auswählen möchte kommt die meldung dass die ressource dann in einem konflikt mit einem anderen gerät steht (aber welches weiß ich nicht)

    bei automat. auswahl steht dort nur folgende adresse:

    0200-0207

    unten steht dann aber auch wieder ressource ist nicht verfügbar.
     
Die Seite wird geladen...

Gameport Ressourcenproblem (IRQ) !!!! - Ähnliche Themen

Forum Datum
Ressourcenproblem bei Gameport Windows XP Forum 23. Feb. 2004
Gameport funktioniert nicht obwohl es auf der Soundkarte vorhanden ist Windows XP Forum 4. Dez. 2008
alter Gameport-Joystick - benötige Installationsdatei Treiber & BIOS / UEFI 25. Juli 2007
Gameport in schule geschlossen. Port umleiten? Windows Server-Systeme 22. Feb. 2007
Gameport von Soundkarte funktioniert nicht als Midi Windows XP Forum 8. März 2006