HTA Startprobleme

Dieses Thema HTA Startprobleme im Forum "Windows XP Forum" wurde erstellt von maicRTT, 7. Apr. 2006.

Thema: HTA Startprobleme Hallo Zusammen! Ich habe sporadische Probleme beim Starten von HTA files. Es kann sein, die Anwendung lässt sich 10...

  1. Hallo Zusammen!

    Ich habe sporadische Probleme beim Starten von HTA files.
    Es kann sein, die Anwendung lässt sich 10 mal starten und dann mal wieder nicht.

    Nun habe ich rausgefunden, dass dieses Problem nur besteht, wenn z.B: Javascript oder VBScript Code
    in der HTA stehen. Leider bringt mir aber eine HTA ohne Scripting nichts :-\

    Wenn man eine HTA startet, wird ein mshta.exe Prozess generiert.
    Schlägt der Start fehl, sieht man zwar meis einen mshta.exe Prozess aber der terminiert dann sofort wieder.

    Ich hab nun schon Stunden gesucht und keine Antwort gefunden. :'(

    Ich hänge hier mal einen Code zum testen an, würde mich interessieren, ob noch jmd das Problem hat, oder
    ob das nur bei den PCs hier auf der Arbeit so ist.


    Bin für jeden Tipp dankbar


    Grüße Maic


    Den folgenden Code einfach in eine Textdatei mit Endung .hta kopieren und Starten.


    +++++++ CODE der Probleme mach mit Java Script +++++++


    Code:
    <head>
    <title>HTA Test</title>
    <HTA:APPLICATION 
       APPLICATIONNAME=HTA Test
       SCROLL=yes
       SINGLEINSTANCE=yes
       WINDOWSTATE=maximize
     
    >
    
    
    
    </head>
    
    <script type=text/javascript>
    	function launch() {
    	  	 
         alert(hallo!);
    
      }
    </script>
    
    <body>
     <input type=button value=Run Script name=run_button onClick=launch()><p>
    
    </body>
    
    
    
    +++++++ Code der Probleme macht mit VBScript (orig. MS Beispiel) +++++++
    <head>
    <title>HTA Test</title>
    <HTA:APPLICATION 
       APPLICATIONNAME=HTA Test
       SCROLL=yes
       SINGLEINSTANCE=yes
       WINDOWSTATE=maximize
     
    >
    </head>
    
    <script language=VBScript>
      Sub TestSub
        Msgbox Testing 1-2-3.
      End Sub
    </script>
    
    <body>
     <input type=button value=Run Script name=run_button onClick=TestSub><p>
    
    </body>
    
    
    ++++++++ Code der keine Probleme macht (ohne Script) +++++++
    
    <head>
    <title>HTA Test</title>
    <HTA:APPLICATION 
       APPLICATIONNAME=HTA Test
       SCROLL=yes
       SINGLEINSTANCE=yes
       
    >
    </head>
    
    
    
    <body>
    hallohallo hallo hallo hallo hallo hallo hallo hallo hallo hallo
    
    
    </body>
    
    
     
  2. Nur zur Info, bei mir geht es ohne Probleme !
     
Die Seite wird geladen...

HTA Startprobleme - Ähnliche Themen

Forum Datum
Startprobleme bei Winz (64Bit) Windows 7 Forum 30. Juni 2016
Startprobleme Desktoprechner - Scan Divices! Please wait - No Devices Hardware 10. Juli 2014
Startprobleme nach umschaltung auf 4 Kerne Windows 7 Forum 31. Jan. 2012
Startprobleme Windows 7 Forum 22. Okt. 2010
Windows 7 Startprobleme Windows 7 Forum 24. Jan. 2010