If-Satz Problem bei Excel

Dieses Thema If-Satz Problem bei Excel im Forum "Microsoft Office Suite" wurde erstellt von Ulle^1, 8. Nov. 2006.

Thema: If-Satz Problem bei Excel Hallo zusammen, Ich habe ein kleines Problem bei Excel. Und zwar habe ich eine Tabelle mit mehreren If-Sätzen...

  1. Hallo zusammen,
    Ich habe ein kleines Problem bei Excel.
    Und zwar habe ich eine Tabelle mit mehreren If-Sätzen gemacht.
    Mein Problem ist, dass wenn ich diesen Satz: =WENN(E35=F35;1;0)
    benutze, kommt automatisch eine 1 in das Feld auch wenn ich noch keine Eingabe gemacht hab.
    Wie kann ich es machen, dass erst die 1 eingetragen wird, sobald eine Eingabe stattgefunden hat?

    Danke schonmal im vorraus!


    Lg Ulle^1
     
  2. Sry für den Doppelpost aber mir is grade nochwas eingefallen.
    Wie mache ich es, dass ich sowas wie eine Livetabelle habe?
    Also ich habe 4Zeilen mit jeweils einer Punktezahl. Und jede Punktezahl will ich einen Platz zuordnen.
    Also z.Bsp.:
    Platz: Punkte
    1 5
    2 4
    3 3
    4 1

    Aber wenn sich die Punktezahlen ändern, sollen sich auch die Plätze ändern.

    Schonmal Danke
     
  3. Hallo Ulle,

    du könntest es z.B. so machen:
    Code:
    =WENN(E35=;;WENN(E35=F35;1;0))
    Zu der Tabelle: schau dir mal die funktion RANG an.

    Gruß Matjes :)
     
  4. Hallo Matjes,
    Danke für die schnell Hilfe. Das mit deinem Befehl hat prima geklappt. :)

    Aber was meinst du mit dem RANG befehl?
    Wo kann ich das hier im Forum nachlesen?
    Ich hab das Forum erst eben gefunden deshalb weiß ich nicht wo ich gucken soll,
    Die SuFu findet nicht hilfreiches.



    Schonmal Danke ,
    Ulle
     
  5. Hallo Ulle,

    anhand deines Beispiel eine kleine Erklärung:

    B1 = Punkte
    B2 - B5: Punktewerte

    A1 = Platz
    in A2 die Formel 
    Code:
    =RANG(B2;$B$2:$B$5;1)
    Formel bis A5 herunterziehen. Damit hast du deine Bewertung.

    Jetzt kannst Du noch sortieren:
    A1:B5 markieren
    Daten->Sortieren-> nach Platz

    Gruß Matjes :)
     
  6. Also das klappt alles bestens, jedoch nur in falscher Reihenfolge^^
    Ich hätte gerne dass für den höchsten Wert der beste Platz zugeordnet wird.
    Aber im Moment ist es genau andersrum ?:)
    Und dann noch eine Frage(Auch wenn ich nerve ::) )

    Ich hab folgenden befehl bentuzt:
    =WENN(E41>F41;1;WENN(E41=F41;2;3))

    Ich hätte aber gerne, dass in den Textfeldern etwas steht dass in einem anderen Feld steht(z. Bsp.: in A1)
    Und wenn das in A1 sich ändert, dass sich das in dem dann auch ändert.



    Danke,

    Gruß Ulle
     
  7. Es hat sich alles erledigt.
    Ich habe es jetzt einfach so gemacht, dass die punkte im negativen Bereich angezeigt werden.
    Somit stimmt der Rang und das andere Problem hab ich auch selber gelöst :)


    Trotzdem nochmal Danke für deine Hilfe Matjes ;)
     
  8. Hallo Ulle,

    die umgekehrte Reihenfolge erhälst du auch mit 0 statt einer 1 als dritten Parameter in RANG.
    Code:
    =RANG(B2;$B$2:$B$5;0)
    statt
    Code:
    =RANG(B2;$B$2:$B$5;1)
    Gruß Matjes :)
     
Die Seite wird geladen...

If-Satz Problem bei Excel - Ähnliche Themen

Forum Datum
SEHR DRINGEND: Probleme bei Upgrade auf Windows 7 Windows Vista Forum 13. Nov. 2016
Problem - Laptop mit angeblich win 10 und win 7 Windows 10 Forum 13. Nov. 2016
Dualboot Windows Uhrzeit Problem Windows 10 Forum 10. Nov. 2016
W10M - Glance Screen & DTTWU Probleme Windows 10 Forum 4. Nov. 2016
probleme mit windows 7 update bitte um hilfe. Windows 7 Forum 4. Nov. 2016