In Excel Negative Zeiten berechnen

Dieses Thema In Excel Negative Zeiten berechnen im Forum "Microsoft Office Suite" wurde erstellt von Pc-Maus, 29. Okt. 2004.

Thema: In Excel Negative Zeiten berechnen Hallöööööchen, Ich denke Ihr habt mal wieder eine Lösung für mein Problem ;o) Ich habe ein Excelblatt indem ich...

  1. Hallöööööchen,

    Ich denke Ihr habt mal wieder eine Lösung für mein Problem ;o)

    Ich habe ein Excelblatt indem ich die Arbeitsstunden errechne.
    Alles geht nur nun möchte ich die Sollarbeitszeit von der Wochenarbeitszeit abziehen und er soll mir die Differenz ausgeben.
    Es geht leider nur bei den positiven Zahlenwerten. Ich kenne die Info das bei negativen Zeitwerten die #### kommen.
    Aber das geht doch bestimmt auch anders.

    Wäre schön wenn Ihr ne Lösung wüßtest.

    Beispiel:
    AnwesenheitBeginnEndeA-zeitPauseStunden+/-
    Fr.01.10.09:0017:0008:0000:4537:30:00
    Sa.02.10.
    So.03.10.
    Mo.04.10.08:1516:4508:3000:45
    Di.05.10.08:3016:4508:1500:45
    Mi.06.10.08:1516:4508:3000:45
    Do.07.10.08:1517:1509:0000:45
    Fr.08.10.08:1517:4509:3000:4540:00:002:30


    menno das verschiebt sich immer.
    aber vielleicht checkt das jemand von euch.

    danke
    PC-Maus
     
  2. Hallo Pc-Maus,

    Zitat aus der Excel-Hilfe:
    Aber Achtung, wenn Du das 1904-Datumsformat anschaltest, wird jedes Datum, das im normalen Datumsformat eingegeben wurde, mit einem Offset von 4 Jahren angezeigt - also aus 2004 wird 2008.

    Wenn Du Exceldateien mit anderen austauscht, die nicht das gleiche Datumsformat verwenden, tritt auch eine Verschiebung von 4 Jahren auf.

    Da die meisten das normale Datumsformat verwenden sollte das 1904-Datumsformat auch nicht benutzt werden. Unter diesen Umständen kann Excel keine negativen Zeiten darstellen.


    Gruß Matjes :)
     
  3. Ich hab's gerade nicht parat, aber am Dienstag im Büro schau ich mal nach wie wir das gelöst haben. Wir haben 1900er Datumsformat und trotzdem negative Zeiten.
    Allerdings nicht bei mir. Ich hab immer Überstunden ;D

    Ein paar Hilfsspalten und ein paar Formeln und schon läuft es wie geschmiert. Mit Kalenderwoche und allem was dazugehört.
     
  4. Ich stelle gerade fest, daß wir die Differenzzeiten zur Soll-Arbeitszeit in Dezimalzahlen angeben.
    A2 ist die Sollzeit: 39:00 Format:[hh]:mm
    B2 ist die Istzeit: 38:30 Format:[hh]:mm
    C2 berechnet die Differenz: =WENN(B2=0;XXX;(B2-A2)*24) --> Ergebnis: -0,5

    Genügt das, oder soll das Ergebnis als -00:30 dargestellt werden?
     
  5. hi,

    also ich hab die lösung mit 1904 genommen. da die einstellungen nur lokal in dieser datei bleiben kann ich damit gut leben.

    1000 dank

    pc-maus
     
  6. Bin gerade auf die Lösung ohne Umstellung auf 1904 gestoßen. Ich wußte doch, ich hab da was rumliegen:

    A2 ist die Sollzeit: 39:00 Format:[hh]:mm
    B2 ist die Istzeit: 38:30 Format:[hh]:mm
    C2 berechnet die Differenz:
    Code:
    =WENN((B2-A2)*24<0;- &
    TEXT((-1)*ABRUNDEN((B2-A2)*24;0);00)&:&TEXT(AUFRUNDEN((-1)*((B2-A2)*24-ABRUNDEN((B2-A2)*24;0))*60;0);00);
    TEXT(ABRUNDEN((B2-A2)*24;0);00)&:&TEXT(AUFRUNDEN(((B2-A2)*24-ABRUNDEN((B2-A2)*24;0))*60;0);00))
    --> Ergebnis: -00:30
     
  7. hi klexy

    das ist ja eine nette Formel

    merci.

    pc-maus
     
  8. Na ja, bisher hat sie mir noch nicht den Kaffe ans Bett gebracht :(
     
Die Seite wird geladen...

In Excel Negative Zeiten berechnen - Ähnliche Themen

Forum Datum
Excel 2010: Rechnen mit negativen Uhrzeiten Microsoft Office Suite 16. Sep. 2012
negative Zahlen Excel 2000 Microsoft Office Suite 25. Nov. 2009
MS Excel, negative Zahlen Microsoft Office Suite 19. Nov. 2007
Excelmakro bei negativen Wert Microsoft Office Suite 13. Okt. 2006
Excel-Feature gesucht Microsoft Office Suite 11. Okt. 2016