Internetxplorer starten mit Systemvariable

Dieses Thema Internetxplorer starten mit Systemvariable im Forum "Webentwicklung, Hosting & Programmierung" wurde erstellt von jan2, 28. Juni 2011.

Thema: Internetxplorer starten mit Systemvariable Hi ! ich möchte eine Seite über den IE mittels Batch aufrufen. Hierzu habe ich folgende Zeile erstelle:...

  1. Hi !

    ich möchte eine Seite über den IE mittels Batch aufrufen.

    Hierzu habe ich folgende Zeile erstelle:

    %ProgramFiles%\iexplore.exe URL

    Beim Ausführen bekomme ich die Meldung:

    Welcher Fehler kann mir unterlaufen sein ??

    Gruß Jan :)
     
  2. Schau mal genau hin. ;)
    Da fehlt als erstes Zeichen das öffnende . Wenn du das einfügst sollte es klappen...
     
  3. ääähhh !

    der teil \iexplore ist doch in Anführungszeichen - der Rest steckt in der Variablen ??

    Ich im dunklen Wald ?!?!?

    Gruß Jan :)
     
  4. Achso, das habe ich übersehen.

    Warum du das iexplorer.exe allerdings in Anführungszeichen gesetzt hast ist mir Schleierhaft.

    SO müsste es funtktionieren:

    Code:
    %ProgramFiles%\iexplore.exe
    
    Möglich sollte auch diese Variante sein:

    Code:
    %ProgramFiles%\iexplore.exe
    
    Der Punkt ist, dass die Variable aufgelöst wird. Leider enthält die Pfadangabe ein Leerzeichen. Leerzeichen werden aber nur akzeptiert/geparst wenn du den gesamten Pfad in Anführungszeichen setzt, da er das Leerzeichen sonst als Steuerzeichen wertet.
     
  5. hi !

    wenn ich aber jetzt

    %ProgramFiles%\iexplore.exe http://www.xxxxxx.xx/tiles_unzip.php

    ausführe dann bekomme ich folgende Meldung:

    D:\DATEN\JAN\openstreetmap\Updates>C:\Program Files\iexplore.exe http://www.xxxx.xx/tiles_unzip.php
    Der Befehl C:\Program Files\iexplore.exe ist entweder falsch geschrieben oder
    ...

    Aber ein IE geht immer noch nicht auf !!!

    ....?

    Gruß Jan :)
     
  6. Dir ist nicht zufällig auffallen, dass dies lediglich ein Beispiel war, oder?
    Du hast nämlich einen Verzeichnisnamen vergessen.

    Unterhalb des Verzeichnisses Program Files befindet sich nämlich keine iexplorer.exe...

    Code:
    %ProgramFiles%\Internet Explorer\iexplore.exe [url]http://google.de[/url]
    
    Das funktioniert 1000%!
     
Die Seite wird geladen...

Internetxplorer starten mit Systemvariable - Ähnliche Themen

Forum Datum
Cyberduck läßt sich nicht starten Windows 7 Forum 29. Aug. 2016
warum kann ich robocopy nicht starten Windows 7 Forum 29. Aug. 2016
Tablet-Modus - Anwendung im Vordergrund starten Windows 10 Forum 7. Apr. 2016
Custom Windows 10 App starten Windows 10 Forum 3. März 2016
CMD - String als Datei Parameter starten. Webentwicklung, Hosting & Programmierung 17. Dez. 2015