Kalenderwoche in Excel berechnen

Dieses Thema Kalenderwoche in Excel berechnen im Forum "Microsoft Office Suite" wurde erstellt von klexy, 16. Mai 2011.

Thema: Kalenderwoche in Excel berechnen In Excel gibt es eine Funktion KALENDERWOCHE, die aber nicht korrekt ist. Excel definiert die Woche, in der der 1....

  1. In Excel gibt es eine Funktion KALENDERWOCHE, die aber nicht korrekt ist.
    Excel definiert die Woche, in der der 1. Januar ist, als KW 1. Das ist aber nicht richtig, denn die KW 1 ist laut DIN EN 28601 die Woche, in welcher der 4. Januar ist.
    Meine Antwort in thread http://www.wintotal-forum.de/index.php/topic,4381.0.html ist also falsch.

    Die korrekte Formel (unter Einbeziehung der fehlerhaften KW-Funktion in Excel) lautet so:

    Code:
    
    =WENN(WENN(KALENDERWOCHE(DATUM(JAHR(A1);1;4);2)=1;KALENDERWOCHE(A1;2);KALENDERWOCHE(A1;2)-(KALENDERWOCHE(DATUM(JAHR(A1);1;4);2)-1))<>0;
    WENN(KALENDERWOCHE(DATUM(JAHR(A1);1;4);2)=1;KALENDERWOCHE(A1;2);KALENDERWOCHE(A1;2)-(KALENDERWOCHE(DATUM(JAHR(A1);1;4);2)-1));
    WENN(KALENDERWOCHE(DATUM(JAHR(A1)-1;1;4);2)=1;KALENDERWOCHE(DATUM(JAHR(A1)-1;12;31);2);KALENDERWOCHE(DATUM(JAHR(A1)-1;12;31);2)-(KALENDERWOCHE(DATUM(JAHR(A1)-1;1;4);2)-1)))
    
    
    Der Vollständigkeit halber.
     
  2. Hallo klexy,

    es geht auch kürzer:
    Formel ermittelt die Deutsche Kalenderwoche

    =KÜRZEN((A1-DATUM(JAHR(A1+3-REST(A1-2;7));1;REST(A1-2;7)-9))/7)

    Info hier:
    http://www.excelformeln.de/formeln.html?welcher=7


    Nachtrag zu deinem Verweis: klexy, der Beitrag ist aber schon ein paar Jahre Alt!
    Re: Kalenderwoche-Anzeige im Excel
    « Antwort #2 am: 16.10.02 um 22:42:15 »
     
  3. Danke für die kurze Formel. Ist raffiniert.
    Hab in Google alles mögliche Andere gefunden. Und in Wintotal nur meinen alten Eintrag. Daher der neue Fred.
     
Die Seite wird geladen...

Kalenderwoche in Excel berechnen - Ähnliche Themen

Forum Datum
Excel 2003 - Kalenderwoche Windows XP Forum 14. Feb. 2005
Kalenderwoche-Anzeige im Excel Microsoft Office Suite 16. Okt. 2002
Kalenderwochen anzeigen Microsoft Office Suite 30. Mai 2006
Kalenderwochen Anzeigen Microsoft Office Suite 25. Aug. 2005
Kalenderwochen Nummerierung ist falsch Windows XP Forum 9. Mai 2005