Komandozeilenparameter

Dieses Thema Komandozeilenparameter im Forum "Windows XP Forum" wurde erstellt von basco, 6. Aug. 2007.

Thema: Komandozeilenparameter Unter Ziel der Verknüpfung sollte die Angabe zur Programmdatei in Anführungszeichen stehen, wenn die Angabe...

  1. Unter Ziel der Verknüpfung sollte die Angabe zur Programmdatei in Anführungszeichen stehen, wenn die Angabe Leerzeichen enthält. Wenn ich sie setze, sind sie jedoch bei erneutem Aufruf wieder verschwunden. Somit wird der Parameter NICHT erkannt.
    Wie kann ich erreichen, dass die Anführungszeichen an Ort und Stelle bleiben?
     
  2. Scaut die Zeile so
    Code:
    C:\Program Files\Program.exe /tuwas
    oder so
    Code:
    C:\Program Files\Program.exe /tuwas
    aus ?
     
  3. Hallo Schrecklicher,
    So sieht sie aus: C:\Program Files\Program.exe /tuwas.
    Leider sind die Anführungszeichen nach der Eingabe aber wieder verschwunden.
     
  4. Wenn ein Ordner oder eine Programmdatei ein Leerzeichen hat, dann wird automatisch unter Ziel deiner
    Verknüpfung die Anführungszeichen gesetzt!
    Anführungszeichen brauchst du nicht setzen, die sind ja da. Oder meinst du nur den Parameter /tuwas ?
    C:\Program Files\Program.exe /tuwas Hat deine Programmdatei überhaupt Parameter, wenn ja, und du den
    Parameter /tuwas dort einträgst und auf Übernehmen klickst, dann bleiben die Anführungszeichen erhalten,
    auch wenn du die Anführungszeichen entfernst, dann sind sie nach dem Aufruf wieder da.

    Vielleicht sind ja keine Leerzeichen in deinem Pfad, und wenn du dann die Anführungszeichen und den
    Parameter eingibst, sind sie nach der Eingabe wieder verschwunden. :froehlich1:

    Gruß Raupe
     
  5. Danke an alle, Problem gelöst. Meine Zeile lautete so: C:\ProgramFiles\Program.exe, also OHNE Leerzeichen. Daher wurden auch die von mir gesetzten Anführungen NICHT übernommen. Wenn die Zeile wie folgt lautet: C:\Program Files\Program.exe (= Leerzeichen zw. Program und Files), dann werden sie übernommen.
    Alles paletti, merci.