Monate pro Kalenderjahr jahresübergreifend auswerten

Dieses Thema Monate pro Kalenderjahr jahresübergreifend auswerten im Forum "Microsoft Office Suite" wurde erstellt von samsine, 7. Juni 2013.

Thema: Monate pro Kalenderjahr jahresübergreifend auswerten Hallo zusammen, ich möchte folgende Tabelle auswerten: Plan von Plan bis Monate 2014 Monate 2015 Monate...

  1. Hallo zusammen,

    ich möchte folgende Tabelle auswerten:

    Plan von Plan bis Monate 2014 Monate 2015 Monate 2016 Monate 2017
    01.01.2013 12 12 12 12
    01.01.2013 30.09.2013
    01.10.2013 30.09.2014 9
    01.10.2014 30.04.2016 3 12 4
    01.05.2016 8 12
    01.01.2014 12 12 12 12

    Ich habe also immer Zeiträume, die in der Vergangenheit, Gegenwart oder Zukunft liegen können, und für die ich die Monate pro Kalenderjahr mit Excel errechnen möchte. Falls es ein Problem ist, dass auch unbefristete Zeiträume dabei sind: das könnte ich noch lösen und alle offenen auf den 31.12.2017 befristen, falls es dann einfacher zu berechnen geht.

    Kann mir jemand mit den entsprechenden Formeln helfen?

    Ups, ich sehe gerade, dass die Beispielwerte in der Vorschau verrutschen, ich hoffe, man kann trotzdem verstehen, was ich benötige.

    Vielen Dank und Grüße
    samsine
     
  2. Hallo samsine,

    also unter der Voraussetzung das
    A1= Plan von
    B1= Plan bis
    C1= Monat 2014
    D1= Monat 2015
    E1= Monat 2016
    F1= Monat 2017

    wären die Formeln:

    für C2:
    Code:
    =WENN(ODER(A2=;JAHR(A2)>2014);;WENN(B2=;WENN(JAHR(A2)=2014;13-MONAT(A2);12);WENN(JAHR(B2)<2014;;WENN(UND(JAHR(A2)=2014;JAHR(B2)=2014); MONAT(B2)-MONAT(A2)+1;WENN(JAHR(A2)=2014;13-MONAT(A2);WENN(JAHR(B2)=2014;MONAT(B2);12))))))
    für D2:
    Code:
    =WENN(ODER(A2=;JAHR(A2)>2015);;WENN(B2=;WENN(JAHR(A2)=2015;13-MONAT(A2);12);WENN(JAHR(B2)<2015;;WENN(UND(JAHR(A2)=2015;JAHR(B2)=2015); MONAT(B2)-MONAT(A2)+1;WENN(JAHR(A2)=2015;13-MONAT(A2);WENN(JAHR(B2)=2015;MONAT(B2);12))))))
    für E2:
    Code:
    =WENN(ODER(A2=;JAHR(A2)>2016);;WENN(B2=;WENN(JAHR(A2)=2016;13-MONAT(A2);12);WENN(JAHR(B2)<2016;;WENN(UND(JAHR(A2)=2016;JAHR(B2)=2016); MONAT(B2)-MONAT(A2)+1;WENN(JAHR(A2)=2016;13-MONAT(A2);WENN(JAHR(B2)=2016;MONAT(B2);12))))))
    für F2:
    Code:
    =WENN(ODER(A2=;JAHR(A2)>2017);;WENN(B2=;WENN(JAHR(A2)=2017;13-MONAT(A2);12);WENN(JAHR(B2)<2017;;WENN(UND(JAHR(A2)=2017;JAHR(B2)=2017); MONAT(B2)-MONAT(A2)+1;WENN(JAHR(A2)=2017;13-MONAT(A2);WENN(JAHR(B2)=2017;MONAT(B2);12))))))
    Die Formeln kannst du dann spaltenweise nach unten ziehen.

    Gruß Matjes :)
     
  3. Hallo Matjes,

    vielen Dank für die Formel. Ich habe in dieser Woche Urlaub, daher kann ich sie im Moment nicht testen. In der nächsten Woche probiere ich sie aus und melde mich wieder.

    Viele Grüße
    samsine
     
  4. Hallo Matjes,

    vielen Dank! Ich bin jetzt aus dem Urlaub zurück und habe die Formel eingegeben. Alles genau so, wie ich es mir gewünscht habe.

    Toll! mml

    Schönen Tag noch,
    Sabine
     
Die Seite wird geladen...

Monate pro Kalenderjahr jahresübergreifend auswerten - Ähnliche Themen

Forum Datum
Seit Monaten Update-Fehler: 8024a000, 80244fff, 8024402F [Windows 8.1 64bit] Windows 8 Forum 19. Nov. 2014
alle (möglichen) XP + Office 2K3 updates der letzten 8 Monate? Windows-Updates 14. Dez. 2006
Festplatte von fuj.-siemens nach 4 Monaten kaputt Hardware 25. Mai 2006
Kalender Übersicht 4 Monate anzeigen? Windows XP Forum 21. Feb. 2006
Wie Testversion erneut installieren ? (hatte vor 12 Monaten schonmal installiert Windows XP Forum 25. Jan. 2006