Netzwerkprobleme unter Linux

Dieses Thema Netzwerkprobleme unter Linux im Forum "Linux & Andere" wurde erstellt von zuc, 19. Feb. 2005.

Thema: Netzwerkprobleme unter Linux hi Ich hab Suse 9.1 nebst Windows 2000 bei mir aufm Rechner installiert und nun hab ich ein Problem mit meiner...

  1. zuc
    zuc
    hi

    Ich hab Suse 9.1 nebst Windows 2000 bei mir aufm Rechner installiert und nun hab ich ein Problem mit meiner Netzwerkkarte.
    Wenn ich Suse starte kann es passieren, dass meine Netzwerkkarte nicht erkannt wird. Danach muss ich dann Suse nochmal neu hochfahren und es geht wieder. Meine Vermutung ist, dass die Karte jedesmal dann nicht erkannt wird, wenn ich von Windows herauskomme und in Linux boote. Wenn ich von Linux heraus Linux neustarte gibt's keine Probleme. Da ich Windows (noch) nicht aufgeben will und es häufig benutze ist das ziemlich ärgerlich.
    Dasselbe Problem hatte ich auch mit anderen Linux Distros, wie Mandrake, Fedora etc., die ich zeitweilig mal installiert hatte.
    Die Netzwerkkarte ist laut Windows ne Broadcom NetXtrem Gigabit Ethernet. Es ist ne Onboard Karte von meinem MSI KT4A Ultra Motherboard. Unter Windows läuft die ohne Probleme. Die Karte verbindet meinen PC über nen Router mit dem DSL-Anschluss.

    Hat jemand vielleicht ne Idee voran das liegt und wie man es beheben kann?

    Auch nervt mich, dass Linux (egal welche Distro) immer sehr lange braucht bis es gestartet ist. Es scheint 2 Minuten oder so nix zu machen bevor es dann anfängt zu laden. Hat vielleicht jemand n paar Tipps wie man das beschleunigen kann?

    Vielen Dank für jede Hilfe  :)
     
  2. Hi,

    wo bleiben die denn 2 Minuten stehn bevor es weitergeht?
    was wird dabei angezeigt?

    Wenn der Hochfährt (und deine Netzwerkkarte nicht erkannt wird) kommt da eine Fehlermeldung bei Setting up network interfaces ?
     
  3. zuc
    zuc
    Also es erscheint der Suse Bildschirm mit der Fortschrittsleiste und da bleibt er dann erstmal stehen. Details anzeigen lassen kann man sich nicht. Erst wenn er dann anfängt die Fortschrittsleiste zu füllen geht das. Bei Madrake dasselbe.

    Wenn er unter Suse die Netzwerkkarte nicht erkennt dann steht da wenn ich das richtig im Kopf habe: waiting for Mandatory devices und er zählt von 20 runter bis 0 und dann kommt failed anstatt Ok.

    So genau hab ich den Text nicht mehr im Kopf. Ich müsste nochmal starten und mir das aufschreiben.
     
  4. Hallo,

    Im BIOS die Option Plug & Play OS ausschalten oder den Kernel neu übersetzen und die Option Plug & Play sowohl für ISA als auch PCI aktivieren.

    Zusätzlich sicherstellen, das das entsprechende Kernel-Modul in der /etc/sysconfig/modules* bzw. /etc/modules* drinsteht.

    Falls das nicht zum Erfolg führt, mal das Modul in die initial Ramdisk einbinden.
    Dazu unter /etc/sysconfig/kernel* das Kernelmodul eintragen bei INITRD_MODULES
    Danach ein mkinitrd und rebooten ;)

    Gruß
    Sven

    Ahja... wenn gar nix mehr geht HIER lesen
     
  5. zuc
    zuc
    Hi

    konnte meine Probleme jetzt lösen.

    Das lange starten war durch Probleme mit dem DMA bei meiner zweiten Festplatte. Hab dort jetzt DMA deaktiviert und nun geht's.

    Das Netzwerkproblem war weil SuSE das tg3 modul benutzt hat und irgendwie kam die karte da nicht drauf klar. Hab mir jetzt die Linux Treiber von Broadcom geholt und installiert und nun klappts wunderbar.
     
Die Seite wird geladen...

Netzwerkprobleme unter Linux - Ähnliche Themen

Forum Datum
Netzwerkprobleme unter XP prof. Windows XP Forum 14. Feb. 2005
Netzwerkprobleme Win10 Windows 10 Forum 21. Mai 2016
Netzwerkprobleme Windows 7 Forum 8. Juni 2015
wieder mal Netzwerkprobleme Windows XP Forum 5. März 2011
Netzwerkprobleme win7 Windows XP Forum 18. Feb. 2011