phpMyAdmin Fehler "mbstring"

Dieses Thema phpMyAdmin Fehler "mbstring" im Forum "Webentwicklung, Hosting & Programmierung" wurde erstellt von Honki77, 4. Mai 2005.

Thema: phpMyAdmin Fehler "mbstring" Hallo... Ich habe mir eine Textumgebung eingerichtet. Ich benutze Suse Linux 9.1, Apache 2.0.54 und MySQL 4.1.11....

  1. Hallo...

    Ich habe mir eine Textumgebung eingerichtet.
    Ich benutze Suse Linux 9.1, Apache 2.0.54 und MySQL 4.1.11.
    Jetzt bekomme ich im phpMyAdmin folgenden Fehler:

    Die PHP-Erweiterung mbstring wurde nicht gefunden, trotzdem jedoch scheinen Sie einen Mehrbyte-Zeichensatz zu verwenden. Ohne besagte Erweiterung ist phpMyAdmin nicht in der Lage Zeichenketten zu trennen, was zu unerwarteten Ergebnissen führen kann.

    Ich hab schon gegooglt. Jedoch sprechen Sie dann von Windows-Fehlern und nicht von Linux.

    Kann mir jemand helfen??

    Danke schon mal im voraus
     
  2. Hallo,

    Dir fehlt die PHP4 Erweiterung mbstring.
    Unter SuSE nachzuinstallieren via YaST.

    Siehe:
    http://ftp.gwdg.de/pub/suse/i386/9.1/suse/i586/
    Datei: php4-mbstring-4.3.4-26.i586.rpm

    Gruß
    Sven
     
  3. Ich habe PHP5 installiert...

    Muss ich dann trotzdem php4-mbstring-4.3.4-26.i586.rpm
    installieren?
    Oder gibt es das auch für PHP5??

    Gruss

    Chris
     
  4. Du musst die Erweiterung einfach in der php.ini laden lassen - such mal in der php.ini nach mbstring und entferne das Kommentar-Zeichen (#).

    Cheers,
    Joshua
     
  5. Ich habe in der php.ini nachgeschaut. Den Eintrag
    ;extension: php_mbstring.dll
    kann ich auskommentieren.

    Aber warum .dll?
    dll-Dateien sind doch normal bei Windows und nicht bei Linux??? Ein falsches PHP kann ich unter Linux doch nicht installieren...???
    Ich habe PHP 5.0.4 kompiliert...
     
  6. Da is der Hase im Pfeffer begraben...
    Du musst PHP mit mbstring kompilieren (./configure --enable-mbstring)

    Gruß
    Sven
     
  7. Hallo Sven...

    Muss ich PHP komplett neu kompilieren?
    Oder wie bekomme ich nachträglich den mbstring hinzu?

    Gruss
     
  8. hab das selbe Problem in Windows, mbstring wurde nicht gefunden.

    hab mir die php.ini angesehen, da gab es leider kein auskommentiertes mbstring.

    Weiß da Jemand rat?

    Gruß Holz
     
  9. ein einfaches Pfadangeben in der confic.inc.php (im phpmyadmin ordner) hat bei mir das Problem gelöst.

    $cfg['PmaAbsoluteUri'] =->';

    in bei mir:

    $cfg['PmaAbsoluteUri'] =->http://localhost/phpmyadmin/';

    ändern! im Bowser neustarten - fertig!

    Der Artikel der mich zum erfolg führte:

    http://cms.world4hosting.de/faq/ind...tikel&cat=343088&id=32&artlang=de

    Gruß HOlz
     
Die Seite wird geladen...

phpMyAdmin Fehler "mbstring" - Ähnliche Themen

Forum Datum
PHPMyAdmin Windows XP Forum 20. Juni 2012
phpmyadmin | Error 500 nach Login Webentwicklung, Hosting & Programmierung 9. Mai 2012
Mssql express Tools gesucht ala phpmyadmin Windows XP Forum 3. März 2010
phpmyadmin Webentwicklung, Hosting & Programmierung 3. Feb. 2006
Bekomme phpmyadmin nicht zum laufen! Webentwicklung, Hosting & Programmierung 20. Juli 2005