phpMyAdmin wirft Fehler

Dieses Thema phpMyAdmin wirft Fehler im Forum "Webentwicklung, Hosting & Programmierung" wurde erstellt von Rael, 3. Apr. 2008.

Thema: phpMyAdmin wirft Fehler Guten Tag. Ich habe mich heute durch die Anleitung Einrichten einer lokalen Testumgebung – Apache, PHP & Mysql...

  1. Guten Tag.
    Ich habe mich heute durch die Anleitung Einrichten einer lokalen Testumgebung – Apache, PHP & Mysql eurer Seite gearbeitet und es hat bisher auch geklappt, doch nun habe ich phpMyAdmin eingerichtet und hier wirft es im Browser beim aufrufen (http://localhost/myadmin) einen Fehler:
    phpMyAdmin - Fehler
    Die Erweiterung mysql kann nicht geladen werden. Bitte pr Sie Ihre PHP-Konfiguration. - Dokumentation

    Was fehlt mir denn? Ich hatte eine sample Datei für die config.inc.php und die hatte es mir total zerschossen (war von anfang an so) und da hab ich mir ein Muster im Web gesucht und noch die Infos aus dem Guide dazugetragen. Sieht jetzt so aus:
    <?php
    $i = 0;
    $i++;
    $cfg['Servers'][$i]['host'] =->127.0.0.1';
    $cfg['Servers'][$i]['extension'] =->mysql';
    $cfg['Servers'][$i]['connect_type'] =->tcp';
    $cfg['Servers'][$i]['compress'] = false;
    $cfg['Servers'][$i]['auth_type'] =->config';
    $cfg['Servers'][$i]['user'] =->root';
    $cfg['Servers'][$i]['password'] =->root';
    $cfg['Servers'][$i]['only_db'] =->';
    $cfg['PmaAbsoluteUri'] =->http://localhost/myadmin';
    ?>

    Ich komme einfach nicht weiter. Bitte helft mir!


    [br][blue]*PCDSven: Verschoben aus "Server-Betriebssysteme und -Anwendungen"*[/blue]
     
  2. Hi,

    schau mal in der php.ini nach. Dort muss die extension=mysql.dll bzw. mysql.so geladen werden...

    Gruß
    Sven
     
  3. Das Problem ist gelöst. Hatte vergessen den Pfad zu den Extensions zu aktivieren. Soweit bringt er jetzt die phpMyAdmin Oberfläche, man kann oben eine Sprache wählen aber dann steht direkt darunter :

    Fehler
    Ab sofort muss ein geheimes Passwort zur Verschlüsselung in der Konfigurationsdatei gesetzt werden (blowfish_secret).

    Was muss ich tun? Ich komm nicht weiter.
     
  4. Achja Standardmäßig ist von Anfang an im Dorpdown Deutsch-German (iso-8859-1) ausgewählt. Wenn ich jetzt im Dropdown dann Deutsch-German (iso-8859-15) auswähle komme ich normal ins php hinein, ist halt bloß nervig, dass man es immer wieder auswählen muss und vor allem dass noch die fette Fehlermeldung dort steht. Kann man iso 15 nicht voreinstellen, sodass ich das gar nicht mehr sehe?
     
  5. Hallo,

    wo ist das ausgewählt?

    Bei Sprache oder bei Zeichensatz / Kollation der MySQL-Verbindung ?


    Alle möglichen Config-Parameter findest du unter http://wiki.cihar.com/pma/Config
     
  6. Na im phpMyAdmin, darum gehts doch :coolsmiley:
    Ich tippe in den Browser http://localhost/myadmin und sehe dann ein Dropdown. Dort steht die Sprache mit der Iso 1 drin und drunter die rote Fehlermeldung. Wenn ich dann im Sprachendropdown die iso 15 wähle, komme ich normal ins phpMyAdmin rein und die Fehlermeldung verschwindet.
     
  7. jo, ist mir klar :), aber bei mir gibt es zwei Auswahlmöglichkeiten (eben Sprache und Zeichensatz / Kollation der MySQL-Verbindung), aber in beiden gibt es kein Deutsch - German (iso-8859-1) oder Deutsch - German (iso-8859-15)

    Welche Version von phpMyAdmin hast du denn?
     
  8. Ich hab 2.11.5.1-all-languages, so heißt auch die zip^^. Ich würd dir ja einen Screenshot machen, sehe aber nicht wo man den hier hochladen kann, deswegen beschreibe ich es mal genau. Ich tippe halt localhost/myadmin in den brwoser. Dann kriege ich nen Fenster wo oben das phpMyAdmin Logo ist, darunter steht: Willkommen bei phpMyAdmin 2.11.5.1, dann kommt direkt darunter Sprache - Language und darunter ist ein Dropdown, wo standardmäßig Deutsch - German (iso-8859-1) drin steht. Und dann unter dem Dropdown steht in nem Rot umrandeten Kasten, der gelb unterlegt ist: Fehler
    Ab sofort muss ein geheimes Passwort zur Verschlüsselung in der Konfigurationsdatei gesetzt werden (blowfish_secret).

    Sobald ich dann das Dropdown aufklappe und das nächste deutsch als Sprache wähle (die iso -15), verschwindet die Fehlermeldung und ich werde eingeloggt. Hatte testweise auch auf cookie umgestellt und nach neuer Sprachwahl stand dann an der Stelle des Fehlers die Anmelderoutine.
     
Die Seite wird geladen...

phpMyAdmin wirft Fehler - Ähnliche Themen

Forum Datum
PHPMyAdmin Windows XP Forum 20. Juni 2012
phpmyadmin | Error 500 nach Login Webentwicklung, Hosting & Programmierung 9. Mai 2012
Mssql express Tools gesucht ala phpmyadmin Windows XP Forum 3. März 2010
phpmyadmin Webentwicklung, Hosting & Programmierung 3. Feb. 2006
Bekomme phpmyadmin nicht zum laufen! Webentwicklung, Hosting & Programmierung 20. Juli 2005