Problem mit dem Beenden von Robocopy

Dieses Thema Problem mit dem Beenden von Robocopy im Forum "Webentwicklung, Hosting & Programmierung" wurde erstellt von Emess, 16. Juli 2013.

Thema: Problem mit dem Beenden von Robocopy Ich habe hier ein kleines Script zusammengeklick. Es tut was es soll. Nämlich Userdaten vom Client zum Server...

  1. Ich habe hier ein kleines Script zusammengeklick. Es tut was es soll.
    Nämlich Userdaten vom Client zum Server kopieren. Nur wenn das Script abgearbeitet ist, will sich die Konsole nicht schliessen. :| :| :|
    Hier mal das Script.
    Code:
    @ECHO OFF
    net use \\SERVER\ipc$ /user:bigboss pw
    robocopy D:\CAD \\Server\J\PC-Buero3_MS /MIR /COPY:DAT /V /E /XO /NP /LOG+:d:\sicher.log /R:10 /W:30 
    net use \\SERVER\ipc$ /del
    
    EXIT
    
    Ich such mir seit Stunden den Wolf im Internet. :(
     
  2. Auf die schnelle würde mir die Kombination pause und exit einfallen. Also:
    Code:
    pause && exit
    Versuch macht kluch(g) ;)
     
  3. Hab das schon probiert. Die Konsole bleibt offen.
    In anderen Foren hab ich gefunden, dass es daran liegen kann, dass der Server keine Rückmeldung gibt.
    Die Lösungsansätze könnte ich aber nicht nachvollziehen.
    Irgendeiner muss es doch wissen! :coolsmiley:
     
  4. Versuchs mal mit:
    Code:
    net use \\SERVER\ipc$ /delete /yes
    *Daumendrück*
     
  5. nein, das Script ist fehlerfrei. Und es tut ja auch, was es soll.

    Wird allerdings diese Stapeldatei auf einem Client ausgeführt, auf dem es noch eine command.com gibt, sprich, wird diese Stapeldatei mit Command.com und nicht mit cmd.exe gestartet, dann wird die Konsole nicht geschlossen.

    Sollte sich leicht überprüfen lassen. Entweder listet der Taskmanager noch einen Prozess mit Namen Command.com. Oder du schließt die Batchdatei mit einem EXIT /B 0 ab, was unter Command.com in einen Fehler laufen wird. *denke ich jedenfalls*.

    Hat der Client ein halbwegs aktuelles Betriebssystem, dann sitzt der Stapeldatei ein Bit quer. Vielleicht hilft dann schlank löschen und neu schreiben.
     
  6. Taskmanager zeigt keine weitere Command.com an!
    Kann ich dann mit EXIT /B 0 schliessen?

    Es läuft überall aktuelles Win 7!
    Was heisst, schlank löschen und neu schreiben?

    Danke für deine Hilfe



    Nachtrag:
    EXIT /B 0bringt auch nix! :|
     
  7. na die Datei in die Tonne schmeißen, heißt das. Und dann noch einmal neu schreiben. SCHREIBEN! Nicht Copy and Paste.
     
  8. Jetzt ist es so
    Code:
    net use \\192.168.0.29\ipc$ /user: pw
    robocopy D:\CAD \\Server\j\PC-Buero3_MS /E /SEC /V /NP /LOG+:log.txt /FFT /R:10 /W:30 
    net use \\192.168.0.29\ipc$ /del
    Exit
    Und so bleib es stehen

    [​IMG]
     
  9. Könnte ein simples start das Geheimnis sein?
    Code:
    start robocopy
     
  10. Mit dem vorgesetztem start schliesst sich das Fenster. Worauf sich sofort ein neues öffnet, mit der Meldung, dass ein log Datei angelegt worden ist.

    Eine Idee?
    Ich meine gelesen zuhaben, dass man den Start einen parameter anhängen kann. Finde es aber nicht mehr
     
Die Seite wird geladen...

Problem mit dem Beenden von Robocopy - Ähnliche Themen

Forum Datum
Win98 Beenden>Neustart Problem Windows XP Forum 25. Mai 2003
SEHR DRINGEND: Probleme bei Upgrade auf Windows 7 Windows Vista Forum 13. Nov. 2016
Problem - Laptop mit angeblich win 10 und win 7 Windows 10 Forum 13. Nov. 2016
Dualboot Windows Uhrzeit Problem Windows 10 Forum 10. Nov. 2016
W10M - Glance Screen & DTTWU Probleme Windows 10 Forum 4. Nov. 2016