Probleme mit .htaccess. HELP

Dieses Thema Probleme mit .htaccess. HELP im Forum "Webentwicklung, Hosting & Programmierung" wurde erstellt von stiech, 18. Juni 2008.

Thema: Probleme mit .htaccess. HELP Hallo, ich habe follgendes vor: Ich möchte mit .htaccess einen Bereich mit Benutzernamen und Passwort...

  1. Hallo,

    ich habe follgendes vor: Ich möchte mit .htaccess einen Bereich mit Benutzernamen und Passwort schützen......funktioniert ansich auch. jetzt meine frage. Ich würde gerne das wenn der Benutzername und das Passwort eingegeben wird der Benutzername mit in mein nächstes php-script genommen wird, so das der Benutzer gleich erkannt wird!

    Ist das möglich oder muß ich eine andere Art von Benutzernamen und Password abfrage mache. Für mich scheint halt diese Passwort abfrage sehr sicher!
     
  2. Hi, danke erstmal
    kannst du mir mal ein beispielskript zeigen in dem mir dann der Benutzername angezeigt wird. Ich hab da glaub ich bei mir nen fehler drin!

    DANKE schonmal



    oder kann es sein dass der Server das nicht unterstützt, mir zeigt er nur das wort array an, keinen Namen :-(

    ich bin bei 1und1
     
  3. Ob der Server das können sollte kannst du mal mit einer einfachen php-datei ausprobieren:
    Code:
    <?php
    phpinfo();
    ?>
    Unter Server API sollte dann was mit Apache stehen.


    Mit
    Code:
    <?php
    echo $_SERVER['PHP_AUTH_USER'];
    ?>
    
    kannste den Usernamen ausgeben lassen (sofern unterstützt).
     
  4. mißt dann hab ich nichts falsch gemacht

    da steht CGI
     
  5. ich habe es

    es ist: $HTTP_SERVER_VARS['REMOTE_USER']


    dann gehts bei mir!
     
  6. ohje, na dann möchte ich nicht wissen, welche php-Version auf deinem Server läuft ;-)
     
Die Seite wird geladen...

Probleme mit .htaccess. HELP - Ähnliche Themen

Forum Datum
SEHR DRINGEND: Probleme bei Upgrade auf Windows 7 Windows Vista Forum 13. Nov. 2016
W10M - Glance Screen & DTTWU Probleme Windows 10 Forum 4. Nov. 2016
probleme mit windows 7 update bitte um hilfe. Windows 7 Forum 4. Nov. 2016
Probleme mit .NET Framework 3.5 installation Windows 10 Forum 19. Okt. 2016
Windows 10 Bluetooth Probleme Windows 10 Forum 17. Okt. 2016