Probleme mit Swat (Samba)

Dieses Thema Probleme mit Swat (Samba) im Forum "Linux & Andere" wurde erstellt von Gandalf_the_Grey, 1. Feb. 2005.

Thema: Probleme mit Swat (Samba) Hallo alle zusammen, da mir einige Leute in letzter Zeit SWAT als super geniales Tool zur Administration von Samba...

  1. Hallo alle zusammen,

    da mir einige Leute in letzter Zeit SWAT als super geniales Tool zur Administration von Samba ans Herz gelegt haben, wollte ich das ganze doch gestern glatt einmal ausprobieren. Also kaum Zuhause gewesen habe ich mich über die Konsole als root angemeldet und folgendes gemacht

    apt-get install apache2 (Apache2 installiert was auch super funzt)
    apt-get install swat (SWAT installiert was auch ohne Probleme geht)

    Danach bin ich dem folgenden Tutorial gefolgt:

    http://www.linuxwiki.de/Samba#head-d6fc5420edb94eaa508a29cbfa4609f23b1dcbb6

    funzt auch alles an sich super. Dann habe ich den inetd Deamon neu gestartet. Nur leider bekomme ich keinen Zugriff auf localhost:901 Firefox sagt mir immer das er keine Verbindung herstellen kann. Als das nicht ging habe ich mir das swat.sh script runtergeladen und ausgeführt. Auch das funzte super und auch dieses Script startete den inetd Deamon neu, aber irgendwie keine Veränderung. Kann mir jemand sagen woran das liegen könnte? Ich blick irgendwie nicht ganz durch bei der SWAT konfiguration.
     
  2. Hallo Gandalf_the_Grey,

    Um welches OS handelt es sich denn ? (SuSE, Debian, ???)
    Installiere mal das Paket nmap - sollte in jeder Distri vorhanden sein.
    Ein nmap localhost auf der Konsole zeigt dir, welche Ports offen sind.

    Beispiel:
    Code:
    dungeon:~# nmap localhost
    
    Starting nmap 3.55 ( [url]http://www.insecure.org/nmap/[/url] ) at 2005-02-01 10:12 CET
    Interesting ports on localhost (127.0.0.1):
    (The 1652 ports scanned but not shown below are in state: closed)
    PORT    STATE SERVICE
    21/tcp  open  ftp
    22/tcp  open  ssh
    25/tcp  open  smtp
    80/tcp  open  http
    110/tcp open  pop3
    143/tcp open  imap
    443/tcp open  https
    
    Nmap run completed -- 1 IP address (1 host up) scanned in 1.042 seconds
    dungeon:~#
    
    Versucht Du über localhost zuzugreifen ? Also von derselben Kiste, wo auch Samba drauf läuft ?
    Bei SuSE ist der Zugriff NUR von localhost erlaubt und muss für andere IP's erst über die hosts.allow freigeschalten werden.

    Du sprichst immer vom inetd Daemon. Normalerweise verwenden SuSE & Co. nur noch xinetd, da inetd zu unsicher ist. Ein ps aux | grep inetd solte dir anzeigen, ob der x/inetd überhaupt läuft.

    Gruß
    Sven
     
  3. Arrghh, jetzt verfalle ich ja auch schon in schlechte angewohnheiten *grummel* Sorry, benutze derzeit Debian Sarge mit dem 2.6.8er Kernel. Kann tatsächlich sein das es der xinetd ist, allerdings müsste ich doch dafür dann auch die einträge in der xinetd.conf machen, oder verwendet der xinetd Deamon auch die inetd.conf. Bin jetzt echt etwas perplex. Vor solchen Problemen stand ich nämlich bisher noch nicht *gg*
     
  4. Hallo,

    hattest du gestern nicht erst geschrieben, man solle sich mit der Konsole vertaut machen ;D

    Lass mal Swat swat sein und mach's von der Konsole mit
    vi /etc/samba.conf o.ä

    kannst du es garnicht lassen müßtest du erstmal swat im xinetd erlauben der Port 901 zuöffnen


    Gruss Kersten
     
  5. Ich hab keine Ahnung, was uns Kersten damit sagen will ??? *gg*

    Schau mal in's offizielle HowTo

    Gruß
    Sven
     
  6. Hallo,

    das will ich damit sagen ;D

    Nein, der port901 muß erst geöffnet werden, im xinetd


    Gruss Kersten
     
  7. Servus KerstenG,

    ich HABE bisher Samba per Konsole administriert, aber darum geht es hier nicht. Man hat mich kürzlich auf den trichter gebracht mir mal SWAT anzuschauen da das ganze damit deutlich einfacher und angenehmer zu administrieren geht (bzw gehen SOLL). Deswegen wollte ich mir davon einen eindruck verschaffen. Mir geht es jetzt darum SWAT erstmal zu laufen zu kriegen, NIX anderes.

    Port 901 IST freigegeben, allerdings im inetd und nicht im xinetd. Da für mich nicht ersichtlich war das xinetd anstatt inetd verwendet wird.

    Ich werde mal den Weg über die offizielle Doku wiederholen denn eigentlich unterscheiden sich die beiden HOWTO's nicht wirklich.
     
  8. Hallo,

    verwundert mich aber jetzt das Debian noch inet verwendet.
    Die roten Hüten benutzen die xinetd.conf und hat ein extra Verzeichnis xinetd.d dort existiert eine datei Namens swat
    deren Inhalt

    ---schnipp---

    service swat
    {
    port=901
    socket_type=stream
    wait=no
    only_from=localhost
    user=root
    server=/usr/sbin/swat
    log_on_failure +=USERID
    disable=yes
    }

    ---schnapp---

    wobei disable= yes auf no gesetzt werden muß
    und natürlich ein restart des xinetd.
     
  9. Also, wie ich gesagt hatte benutzt Debian Standardmäßig inetd, habe es per apt-get install xinetd ausgetauscht. Danach habe ich wie im HOWTO in der xinetd.conf die Einträge gemacht und xinetd neu gestartet. NMAP zeigt mir auch an das der Port 901 für SWAT offen ist, aber ich kriege trotzdem von meinem lieben Firefox gesagt das er die Seite nicht erreichen kann *grummel* So langsam werd ich echt sauer. Dieses blöde SWAT kann ja nicht so schwer zum laufen zu kriegen sein.
     
  10. Noch einmal die Frage: Versuchst Du über den selben Rechner zuzugreifen auf dem auch Samba läuft oder über einen anderen Rechner ???

    Wenn Du mal schaust, steht in der xinetd-Konfiguration only_from=localhost...

    Gruß
    Sven#
     
Die Seite wird geladen...

Probleme mit Swat (Samba) - Ähnliche Themen

Forum Datum
SEHR DRINGEND: Probleme bei Upgrade auf Windows 7 Windows Vista Forum 13. Nov. 2016
W10M - Glance Screen & DTTWU Probleme Windows 10 Forum 4. Nov. 2016
probleme mit windows 7 update bitte um hilfe. Windows 7 Forum 4. Nov. 2016
Probleme mit .NET Framework 3.5 installation Windows 10 Forum 19. Okt. 2016
Windows 10 Bluetooth Probleme Windows 10 Forum 17. Okt. 2016