Probleme mit WSUS Clients

Dieses Thema Probleme mit WSUS Clients im Forum "Windows-Updates" wurde erstellt von V@P, 22. Aug. 2005.

Thema: Probleme mit WSUS Clients Hallo zusammen, erstmal sorry, falls das hier nicht reingehört, aber ich habe sonst kein passenderes Unterforum...

  1. V@P
    V@P
    Hallo zusammen,

    erstmal sorry, falls das hier nicht reingehört, aber ich habe sonst kein passenderes Unterforum gefunden. :)

    Folgende Situation:
    Ein WSUS Server ist auf einem Windows 2000 Server installiert und soll verschiedene Server und Clients mit Updates versorgen. Soweit sogut. Jedoch werden a) nicht alle Clients gefunden und b) einige der gefundenen Clients nicht komplett integriert.
    Vorher war ein SUS Server im Einsatz mit dem es bis dato keine Probleme gab. Ich habe u.a. ein Windows XP Client manuell mit dem neuesten AU Client upgedatet bekomme aber folgenden Fehler vom Client-Diag-Tool geliefert:
    Code:
    WSUS Client Diagnostics Tool
    
    Checking Machine State
    	Checking for admin rights to run tool . . . . . . . . . PASS
    	Automatic Updates Service is running. . . . . . . . . . PASS
    	Background Intelligent Transfer Service is running. . . PASS
    	Wuaueng.dll version 5.8.0.2469. . . . . . . . . . . . . PASS
    		This version is WSUS 2.0
    
    Checking AU Settings
    	AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
    		Option is from Policy settings
    
    Checking Proxy Configuration
    	Checking for winhttp local machine Proxy settings . . . PASS
    		Winhttp local machine access type
    			<Direct Connection>
    		Winhttp local machine Proxy. . . . . . . . . . PASS
    		Winhttp local machine ProxyBypass. . . . . . . PASS
    	Checking User IE Proxy settings . . . . . . . . . . . . PASS
    		User IE Proxy
    		webcheck.pallas.com:8080
    		User IE ProxyByPass
    		localhost; 127.0.0.1; [und viele viele mehr...]<local>
    		User IE AutoConfig URL Proxy . . . . . . . . . PASS
    		User IE AutoDetect
    		AutoDetect not in use
    
    Checking Connection to WSUS/SUS Server
    		WUServer = [url]http://192.168.3.44[/url]
    		WUStatusServer = [url]http://192.168.3.44[/url]
    	UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
    	Connection to server. . . . . . . . . . . . . . . . . . PASS
    
    WinHttpDownloadFileToMemory(szURLDest, NULL, 0, NULL, NULL, NULL, 
    
    &downloadBuffer) failed with hr=0x80190194
    
    Der angeforderte URL ist auf diesem Server nicht vorhanden.
    Ein Blick ins IIS Log verrät folgendes:
    Code:
    2005-08-22 07:10:10 192.168.3.111 - 192.168.3.44 80 HEAD /selfupdate/wuident.cab 0508220710 200 Windows-Update-Agent
    2005-08-22 07:10:10 192.168.3.111 - 192.168.3.44 80 HEAD /selfupdate/AU/x86/XP/de/wusetup.cab 0508220710 404 Windows-Update-Agent
    2005-08-22 07:10:10 192.168.3.111 - 192.168.3.44 80 GET /selfupdate/AU/x86/XP/de/wusetup.cab 0508220710 404 Windows-Update-Agent
    2005-08-22 08:28:18 192.168.3.111 - 192.168.3.44 80 GET /clientwebservice/wusserverversion.xml - 200 Windows-Update-Agent
    2005-08-22 08:28:18 192.168.3.111 - 192.168.3.44 80 GET /selfupdate/au/x86/xp/en/wuaucomp.cab - 404 Windows-Update-Agent
    2005-08-22 08:29:57 192.168.3.111 - 192.168.3.44 80 GET /clientwebservice/wusserverversion.xml - 200 Windows-Update-Agent
    2005-08-22 08:29:57 192.168.3.111 - 192.168.3.44 80 GET /selfupdate/au/x86/xp/en/wuaucomp.cab - 404 Windows-Update-Agent
    Dann ein schneller Blick auf den Server und siehe da! Unter dem Pfad:
    C:\Programme\Update Services\Selfupdate\au\x86\xp\
    gibt es nur ein en Verzeichnis und kein de Verzeichnis und die einzige Datei im en Verzeichnis lautet winhttp.cab. Kein Wunder wieso er die Dateien nicht findet.

    Ich mußte übrigens im IIS manuell ein Virtuelles Verzeichnis anlegen, welches auf C:\Programme\Update Services\Selfupdate zeigt, ansonsten wurden die Clients noch nicht mal im WSUS aufgeführt.

    Stand im WSUS ist der, dass die Clients dort zwar gelistet werden, jedoch bei einigen auf einen Statusbericht gewartet wird, der nicht erstellt wird oder werden kann.

    Aber wieso ist das so? Hab ich bei der Installation was falsch gemacht? Oder hat jemand ähnliche Probleme?

    Wäre gut, wenn jemand Rat wüßte.

    Schönen Gruss, Volker.
     
  2. Hab Geduld ;D
    Das Erstellen der Statusberichte dauert mitunter auch mal ein, zwei Tage - dasselbe Phänomen hatte ich hier auch.

    Auf den Clients gibt es unter C:\Windows eine Datei namens Windowsupdate.log (OHNE Leerzeichen im Dateinamen), die sollte dir noch mehr Infos bringen.

    Das du ein Verzeichnis im IIS manuell anlegen musstest ist ebenfalls ein kleiner, aber bekannter Bug des WSUS.

    Cheers,
    Joshua


    EDIT:
    Du hast eine Domäne und verteilst diese Richtlinie per GPO ?
     
  3. V@P
    V@P
    Hallo PCDJoshua,

    danke für die sehr schnelle Antwort. Und ja richtig, das habe ich vergessen zu erwähnen. Es gibt eine (bzw. mehrere) Domäne(n), welche die Einstellungen per GPO übermittelt bekommen. Diese sind auch auf dem hier angesprochenen Client angekommen und gesetzt.

    Mein Windowsupdate.log auf dem Client schreit nach folgendem:
    Code:
    2005-08-22	10:59:39	1148	1a8	AU	#############
    2005-08-22	10:59:39	1148	1a8	AU	## START ## AU: Search for updates
    2005-08-22	10:59:39	1148	1a8	AU	#########
    2005-08-22	10:59:39	1148	1a8	AU	<<## SUBMITTED ## AU: Search for updates [CallId = {14CDA529-D86E-4336-B578-071E34D94971}]
    2005-08-22	10:59:39	1148	48c	Agent	*************
    2005-08-22	10:59:39	1148	48c	Agent	** START ** Agent: Finding updates [CallerId = AutomaticUpdates]
    2005-08-22	10:59:39	1148	48c	Agent	*********
    2005-08-22	10:59:42	1148	48c	Misc	WARNING: WinHttp: SendRequestToServerForFileInformation failed with 0x80190194
    2005-08-22	10:59:42	1148	48c	Misc	WARNING: WinHttp: ShouldFileBeDownloaded failed with 0x80190194
    2005-08-22	10:59:42	1148	48c	Misc	WARNING: DownloadFileInternal failed for [url]http://192.168.3.44/selfupdate/AU/x86/XP/de/wusetup.cab:[/url] error 0x80190194
    2005-08-22	10:59:42	1148	48c	Setup	FATAL: IsUpdateRequired failed with error 0x80244019
    2005-08-22	10:59:42	1148	48c	Setup	WARNING: SelfUpdate: Default Service: IsUpdateRequired failed: 0x80244019
    2005-08-22	10:59:42	1148	48c	Setup	WARNING: SelfUpdate: Default Service: IsUpdateRequired failed, error = 0x80244019
    2005-08-22	10:59:42	1148	48c	Agent	 * WARNING: Skipping scan, self-update check returned 0x80244019
    2005-08-22	10:59:43	1148	48c	Agent	 * WARNING: Exit code = 0x80244019
    2005-08-22	10:59:43	1148	48c	Agent	*********
    2005-08-22	10:59:43	1148	48c	Agent	** END ** Agent: Finding updates [CallerId = AutomaticUpdates]
    2005-08-22	10:59:43	1148	48c	Agent	*************
    2005-08-22	10:59:43	1148	48c	Agent	WARNING: WU client failed Searching for update with error 0x80244019
    2005-08-22	10:59:43	1148	48c	AU	>>## RESUMED ## AU: Search for updates [CallId = {14CDA529-D86E-4336-B578-071E34D94971}]
    2005-08-22	10:59:43	1148	48c	AU	 # WARNING: Search callback failed, result = 0x80244019
    2005-08-22	10:59:43	1148	48c	AU	#########
    2005-08-22	10:59:43	1148	48c	AU	## END ## AU: Search for updates [CallId = {14CDA529-D86E-4336-B578-071E34D94971}]
    2005-08-22	10:59:43	1148	48c	AU	#############
    2005-08-22	10:59:43	1148	48c	AU	AU setting next detection timeout to 2005-08-22 09:56:49
    2005-08-22	10:59:47	1148	48c	Report	REPORT EVENT: {6A678479-1D95-4792-A2E9-7C439EBA1B38}	2005-08-22 10:59:42+0200	1	148	101	{D67661EB-2423-451D-BF5D-13199E37DF28}	0	80244019	SelfUpdate	Failure	Software Synchronization	Error: Agent failed detecting with reason: 0x80244019
    Die Fehler hab ich hier (http://wsusinfo.onsitechsolutions.com/errorcodes.htm) nachgeschlagen und bedeuten:

    0x80190194 - BG E HTTP ERROR 404
    The requested URL does not exist on the server

    0x80244019 - SUS E PT HTTP STATUS NOT FOUND
    HTTP Status 404 - object not found

    Sprich, hamwa ned, ist ausverkauft.
    Testweise habe ich übrigens die Zeit, Suchhäufigkeit nach neuen Updates auf 1 Stunde gesetzt. Also nicht wundern, wenn der jede Stunde wieder aufs neue nach Updates sucht.

    Die Installation des neuen AU auf dem Client ist aber mittlerweile auch schon ein paar Tage her. Und witziger Weise haben einige Server (2003) sofort die entsprechenden Statusberichte abgeliefert. Ich bin momentan etwas verunsichert, ob es noch ein Konfigurationsfehler ist oder es gar nicht funktionieren kann, aus welchen Gründen auch immer. Ich bin mit meinem Latein irgendwie ein bißchen am Ende was Ideen angeht. :)

    Trotzdem danke schon mal für jede Hilfe oder Idee.

    Gruss Volker.
     
  4. V@P
    V@P
    Hallo zusammen,

    ich melde mich noch mal, jedoch ohne wirklich eine Lösung zu haben. Ich habe aus lautem Frust alles neuinstalliert (WSUS, IIS, MSDE, BITS) und quasi von 0 angefangen, mit dem gleichen Ergebnis.

    Es werden einige Computer erkannt (nicht alle, war aber auch schon vorher so), und davon können einige keinen Status Report erstellen. Die Fehlermeldungen entsprechen denen von oben.

    Sonst hat niemand mehr eine Idee? Falls nicht, sehe ich mich gezwungen, wieder auf SUS zu gehen, da WSUS so definitiv nicht einsetzbar ist bei uns in der Firma.

    Gruss, Volker.
     
  5. Hmm...
    Ich habe mittlerweile ähnliche Probleme und kann mir deren Herkunft auch nicht erklären - allerdings fasse ich mich bis nächste Woche in Geduld und lasse die entsprechenden Rechner mal übers WE laufen. Mal schauen, wie es Montag aussieht...

    Btw, hast du von deinen Problemrechner mal versucht, den Hostnamen des WSUS aufzulösen bzw. mit dem Browser mal direkt auf den WSUS zuzugreifen ?

    Cheers,
    Joshua
     
  6. V@P
    V@P
    Hallo Joshua,

    ja habe ich. Per Browser (MSIE 6.0, SP1) kann ich ohne Probleme auf den Rechner zugreifen, entweder per Namen oder per IP. Geht beides. Lediglich bei Benutzung der IP verlangt er nach meinem Benutzernamen und PW meines Domänenbenutzers. Nach Eingabe geht aber auch dieses.

    Interessanter Weise sind alle Windows XP Clients, die bisher gefunden worden, von dem Problem betroffen und der Windows 2000 Server, auf dem WSUS installiert ist, wird lediglich als Windows 2000 erkannt. Keine Ahnung, ob das so vorgesehen oder ein Fehler ist.

    Ich warte dann auch noch mal das Wochenende ab, vielleicht ergibt sich ja bei dir was.

    In diesem Sinne schon mal ein schönes Wochenende :D

    *wink* Volker
     
  7. V@P
    V@P
    Hallo Community, Hi Joshua,

    also folgendes ist bei mir in der Zwischenzeit vorgefallen. Ich hab WSUS mal komplett auf einem anderen Rechner mit Windows 2003 Server (auf dem anderen war nur Windows 2000) drauf installiert. Das ursprüngliche System ist jetzt wieder mit SUS am Start, da es zu viele Ungereimtheiten gab.

    Bei der Installation von SUS ist mir dann aufgefallen, dass der auch nicht mehr richtig wollte, bis ich WSH (Windows Scripting Host) neuinstalliert hatte! Vielleicht war das auch ein ursprüngliches Problem!? Wer weiss. Jedenfalls läuft WSUS auf dem 2003 Server jetzt ohne Murren und auch einen Server hab ich anschließen können.

    Die fehlenden Sprachverzeichnisse in C:\Programme\Update Services\Selfupdate\au\x86\xp\ sind jetzt auch vorhanden (also auch de, etc.). Allerdings hatte ich dazu VOR der Installation das Paket mittels WinZIP manuell ausgepackt und das Setup manuell gestartet. Keine Ahnung, ob es daran lag, aber das hatte ich noch irgendwo als Tipp gefunden.

    Jetzt werden Überlegungen angestellt, den alten Windows 2000 Server komplett neuzuinstallieren, nachdem die Dienste zuerst entfernt wurden (DHCP, DNS, AD, DC, etc.).

    Vielleicht hilft das ja dem ein oder anderen.

    P.S.: Joshua hat sich bei dir noch was ergeben mit den fehlenden Clients? Konntest du da die Ursache zu finden?

    Gruss Volker.
     
  8. Hallo zusammen,
    habe ähnliche Probleme. Der WSUS steht in der Domäne und die Clients werden über die Gruppenrichtlinie des AD versorgt. Das alles funktioniert problemlos.

    Einige Clients die sich nicht in der Domäne befinden werden über die lokale Richtlinie versorgt. Diese werden dann auch im WSUS aufgenommen und die ersten beiden Updates (Bits, WinHTTP) installiert.
    Doch bei diesen Clients gibt es nun das Problem: Es wird kein Statusbericht erstellt und somit ist auch kein weiteres erforderliches Update möglich. (clients befinden sich schon mehrere Wochen im WSUS)

    Hat jemand ein ähnliches Problem oder kennt jemand eine Lösung?

    mfg Thomas
     
  9. V@P
    V@P
    Hallo Thomas,

    was steht denn in den Log-Files der Clients? Poste doch mal ein paar Infos hier, vielleicht wird es dann etwas konkreter. Bei mir ist seit dem der WSUS Server auf dem Test-Server installiert ist, kein Problem mit Clients aufgetreten. Ok, bisher sind auch nur eine handvoll Clients angeschlossen, aber letztendlich haben die Log-Files der Client schon das Problem genau beschrieben. Es fehlten eben die Unterverzeichnisse innerhalb des Installationsverzeichnisses.

    Gruss, Volker.
     
  10. Hallo Volker,
    hier ist ein Auszug aus der Log von einem der Clients ohne Statusbericht. In der Domäne befinden sich rund 40 Clients bei denen alles problemlos funktioniert. (win2k, xp).

    Thomas

    Code:
    http://server01:8530/ReportingWebService/ReportingWebService.asmx
    2005-09-09	15:20:25	1140	1b0	Report	Reporter successfully uploaded 2 events.
    2005-09-09	16:02:18	1140	478	AU	#############
    2005-09-09	16:02:18	1140	478	AU	## START ## AU: Search for updates
    2005-09-09	16:02:18	1140	478	AU	#########
    2005-09-09	16:02:18	1140	478	AU	<<## SUBMITTED ## AU: Search for updates [CallId = {64EA207E-C64E-4CCE-8885-8BBEBA2F18FA}]
    2005-09-09	16:02:18	1140	3ac	Agent	*************
    2005-09-09	16:02:18	1140	3ac	Agent	** START ** Agent: Finding updates [CallerId = AutomaticUpdates]
    2005-09-09	16:02:18	1140	3ac	Agent	*********
    2005-09-09	16:02:18	1140	3ac	Setup	*********** Setup: Checking whether self-update is required ***********
    2005-09-09	16:02:18	1140	3ac	Setup	 * Inf file: C:\WINNT\SoftwareDistribution\SelfUpdate\Default\wusetup.inf
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\cdm.dll: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\iuengine.dll: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\wuapi.dll: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\wuauclt.exe: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\wuauclt1.exe: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\wuaucpl.cpl: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\wuaueng.dll: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\wuaueng1.dll: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\wucltui.dll: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\wups.dll: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\wups2.dll: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	Update NOT required for C:\WINNT\system32\wuweb.dll: target version = 5.8.0.2469, required version = 5.8.0.2469
    2005-09-09	16:02:18	1140	3ac	Setup	 * IsUpdateRequired = No
    2005-09-09	16:02:22	1140	3ac	PT	+++++++++++ PT: Synchronizing server updates +++++++++++
    2005-09-09	16:02:22	1140	3ac	PT	 + ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = [url]http://server01:8530/ClientWebService/client.asmx[/url]
    2005-09-09	16:02:22	1140	3ac	PT	Initializing simple targeting cookie, clientId = f5c18376-5186-4867-84d0-404a6704ea8c, target group = , DNS name = mobile07.belantis.de
    2005-09-09	16:02:22	1140	3ac	PT	 Server URL = [url]http://server01:8530/SimpleAuthWebService/SimpleAuth.asmx[/url]
    2005-09-09	16:02:31	1140	3ac	PT	+++++++++++ PT: Synchronizing extended update info +++++++++++
    2005-09-09	16:02:31	1140	3ac	PT	 + ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = [url]http://server01:8530/ClientWebService/client.asmx[/url]
    2005-09-09	16:02:34	1140	3ac	Agent	 * Found 0 updates and 8 categories in search
    2005-09-09	16:02:34	1140	3ac	Agent	*********
    2005-09-09	16:02:34	1140	3ac	Agent	** END ** Agent: Finding updates [CallerId = AutomaticUpdates]
    2005-09-09	16:02:34	1140	3ac	Agent	*************
    2005-09-09	16:02:34	1140	3ac	AU	>>## RESUMED ## AU: Search for updates [CallId = {64EA207E-C64E-4CCE-8885-8BBEBA2F18FA}]
    2005-09-09	16:02:34	1140	3ac	AU	 # 0 updates detected
    2005-09-09	16:02:34	1140	3ac	AU	#########
    2005-09-09	16:02:34	1140	3ac	AU	## END ## AU: Search for updates [CallId = {64EA207E-C64E-4CCE-8885-8BBEBA2F18FA}]
    2005-09-09	16:02:34	1140	3ac	AU	#############
    2005-09-09	16:02:34	1140	3ac	AU	AU setting next detection timeout to 2005-09-09 14:56:11
    2005-09-09	16:02:39	1140	3ac	Report	REPORT EVENT: {94480E7C-07A5-4B53-9CF2-89A440BF8E74}	2005-09-09 16:02:34+0200	1	147	101	{00000000-0000-0000-0000-000000000000}	0	0	AutomaticUpdates	Success	Software Synchronization	Agent has finished detecting items.
    2005-09-09	16:02:39	1140	3ac	Report	REPORT EVENT: {351E9FF6-8B0C-4D9F-B50D-8204649E7517}	2005-09-09 16:02:34+0200	1	153	101	{00000000-0000-0000-0000-000000000000}	0	0	AutomaticUpdates	Success	Pre-Deployment Check	Reporting client status.
    2005-09-09	16:10:38	1140	3ac	Report	Uploading 2 events using cached cookie, reporting URL = [url]http://server01:8530/ReportingWebService/ReportingWebService.asmx[/url]
    2005-09-09	16:10:38	1140	3ac	Report	Reporter successfully uploaded 2 events.
    
     
Die Seite wird geladen...

Probleme mit WSUS Clients - Ähnliche Themen

Forum Datum
SEHR DRINGEND: Probleme bei Upgrade auf Windows 7 Windows Vista Forum 13. Nov. 2016
W10M - Glance Screen & DTTWU Probleme Windows 10 Forum 4. Nov. 2016
probleme mit windows 7 update bitte um hilfe. Windows 7 Forum 4. Nov. 2016
Probleme mit .NET Framework 3.5 installation Windows 10 Forum 19. Okt. 2016
Windows 10 Bluetooth Probleme Windows 10 Forum 17. Okt. 2016