Seltsamer Effekt nach Knoppix- Installation

Dieses Thema Seltsamer Effekt nach Knoppix- Installation im Forum "Linux & Andere" wurde erstellt von jüki, 21. Dez. 2004.

Thema: Seltsamer Effekt nach Knoppix- Installation Ich hatte mir nun erfolgreich nach dem Tipp von @Al Bundy (danke!) das Knoppix 3.7 (Danke auch Dir, @aninemo!)...

  1. Ich hatte mir nun erfolgreich nach dem Tipp von @Al Bundy (danke!) das Knoppix 3.7 (Danke auch Dir, @aninemo!) installiert und etwas hineingeschaut. Da mir bei der Installation doch noch dies und jenes unklar war, wollte ich das wiederholen und habe die fragliche Partition mit der Notfall- CD von PM8 formatiert. Und, da ich dies nicht sofort machen wollte, ein (schon mehrfach benutztes, auf einer Wechselrahmen- Festplatte liegendes) Image (Acronis True Image v8) zurückerstellt. Kam auch die Meldung Erfolgreich wieder hersgestellt.
    Doch neu booten? Staun: Der PC blieb stehen, mit der Anzeige L 99 99 99 99... der ganze Bildschirm voller 99- Gruppen.
    Absolut nichts zu machen.
    Noch einmal diese Partition gelöscht und formatiert mit der XP- Setup- CD. Bis zum Ende lief der gelbe Balken, um dann zu vermelden, die Festplatte sei defekt.
    Mir blieb tatsächlich nichts weiter übrig, als ein Null Level vom Hersteller zu saugen und durchzuführen - dann lief es wieder.
    Meine Frage an Euch: Was in drei Teufels Namen könnte ich wohl gravierendes falsch gemacht haben?
    Übrigens: Diesmal hab ich gesucht - und nichts gefunden.
    Jürgen
     
  2. hallo,
    lilo hatte noch einen eintrag im mbr. der wollte auf die /boot partition auf der festplatte verweisen, doch die war eben von dir formatiert worden.

    hank
     
  3. Danke - aber bitte sag mir, was ich falsch gemacht habe?
    Es muß doch möglich sein, eine beliebig installierte Festplatte zu formatieren -ohne sie anschließend mit Null Level bearbeiten zu müssen - ich kann mir schlecht vorstellen, das Knoppix heimtückisch ist - aber sehr gut, das ich einen DAU- Fehler gemacht habe!
    Jürgen
     
  4. Das Formatieren/Löschen/Neuerstellen einer Partition ändert nicht den MBR.
    Somit hast Du a) nix falsch gemacht und b) Knoppix ist nicht heimtükisch ;-)

    So kriegst Du den Lilo wieder los.... --> klickmich

    Gruß
    Sven
     
  5. Danke, @RavensMetaller - das ist recht aufschlußreich und war mir bislang noch unbekannt.
    Trotzdem ist mir da etwas noch vollkommen unklar:
    Wie ich oben schrieb, habe ich diese Partition mit der Notfall- CD von PM8 formatiert. Nun bin ich eigentlich der Meinung, das da eben auch der MBR vollkommen neu geschrieben wird.
    Und anschließend noch einmal mit der Setup- Routine des Windows XP das Gleiche! Wie kann sich - trotz 2- maligen Neuschreibens des MBR da trotzdem noch ein Fehler behaupten, dem erst mit Null Level beizukommen war?
    Bin - trotz emsigen Suchen - da noch immer ziemlich ratlos.
    Jürgen
     
  6. Weil Du nur den Bootrekord der Partition gekillt hast, nicht aber den MASTER Bootrekord.
    's nächste mal kannst Du auch hergehen und lilo bzw. grub (die zwei bekanntesten Bootloader unter Linux) in den Bootrekord der Linuxpartition installieren (was aber nicht wirklich zu empfehlen ist, da die Partition dafür als aktiv markiert sein muss.)

    zur Verdeutlichung:

    /dev/hda = erste (IDE)Festplatte im System (oder hast Du den Bootloader installiert)
    /dev/hda1 = erste Partition auf der ersten Festplatte
    /dev/hda2 = zweite Partition...
    ....
    /dev/hdb = zweite Festplatte
    ...

    Wenn Du auf Deiner Festplatte zusätzlich Windows XP oder 2000 installiert hast, kannst Du via CD (Recovery Konsole) durch fixmbr den Master Bootrekord überschreiben und das System bootet wieder von Windows. Allerdings entfernt fixmbr damit auch die Möglichkeit Linux zu starten. Daher empfehle ich immer bei Kombination Linux/Windows den Bootloader von Linux einzusetzen. Ist sehr elegant die Lösung...

    (vor)weihnachtliche Grüße
    Sven
     
  7. >>nur den Bootrekord der Partition gekillt hast, nicht aber den MASTER Bootrekord<<
    Das ist der Dreh- ind Angelpunkt, der mir fehlte. Das es da Unterschiede gibt, war mir nicht bekannt. Wieder etwas, was mir an Wissen fehlt und noch zu erlernen ist...
    Danke!
    Nein, ich habe kein anderes Betriebssystem auf der Platte installiert - da halte ich nun nicht allzuviel davon.
    Ich benutze in meinem PC (6 Festplatten, 3 über Wechselrahmen) immer nur ein OS (XP Prof) - sollte es mich nach einem anderen gelüsten (Habe da noch XP Home, ME und Win 98SE) schiebe ich einfach eine andere HDD0 ein und boote mit der - ist (jedenfalls in meinen Augen) zuverlässiger und Einfacher.
    Viele dankbare Weihnachtswünsche zurück!
    Jürgen
     
  8. no prob...
    übrigens... ein Tip.
    http://sdb.suse.de ist eine sehr gut Knowledgebase für solche Sachen.
    Einfach unter Stichwortsuche lilo oder grub eingeben.

    Gruß
    Sven
     
Die Seite wird geladen...

Seltsamer Effekt nach Knoppix- Installation - Ähnliche Themen

Forum Datum
Seltsamer Dateiname Windows 7 Forum 24. Nov. 2011
Seltsamer Hinweis beim Löschen eines Ordners Windows 7 Forum 21. Juli 2013
Seltsamer Ordner auf der Festplatte Windows XP Forum 9. Okt. 2010
seltsamer Ordner - liegt es am Update für Microsoft .NET Framework 3.5? Windows-Updates 29. Jan. 2009
Seltsamer Regschlüssel Windows XP Forum 10. März 2008