Squid: Bekomme keine Verbindung über (parent) Firmenproxy

Dieses Thema Squid: Bekomme keine Verbindung über (parent) Firmenproxy im Forum "Linux & Andere" wurde erstellt von Stephan.Woebbeking, 13. Jan. 2009.

Thema: Squid: Bekomme keine Verbindung über (parent) Firmenproxy Hi, bin nicht nur neu im Forum, sondern auch bei Squid... Mit anderen Worten: Hallo erstmal! :froehlich1: Hab...

  1. Hi,
    bin nicht nur neu im Forum, sondern auch bei Squid... Mit anderen Worten: Hallo erstmal! :froehlich1:

    Hab gestern den Squid (2.7.Stable5) für Testzwecke installiert. Ich habe zwei Notebooks, NB1 hängt an einem (parent) Firmenproxy und hat den Squid installiert. Notebook 2 = NB2 kann über WLAN NB1 erreichen; Fehlermeldungen vom Squid kommen auch an. Aber ich bekomme keine echten Inhalte übermittelt, der übergeordnete Proxy ist nicht erreichbar:

    Code:
    2009/01/13 09:28:48| Beginning Validation Procedure
    2009/01/13 09:28:48|  Completed Validation Procedure
    2009/01/13 09:28:48|  Validated 16 Entries
    2009/01/13 09:28:48|  store_swap_size = 61k
    2009/01/13 09:28:49| storeLateRelease: released 0 objects
    2009/01/13 09:28:51| temporary disabling (Moved Temporarily) digest from 10.49.4
    9.49
    2009/01/13 09:29:02| Failed to select source for->[url]http://de.wikipedia.org/wiki/W[/url]
    ikipedia:Hauptseite'
    2009/01/13 09:29:02|  always_direct = 0
    2009/01/13 09:29:02|  never_direct = 1
    2009/01/13 09:29:02|    timedout = 0
    2009/01/13 09:29:02| Failed to select source for->[url]http://de.wikipedia.org/favico[/url]
    n.ico'
    2009/01/13 09:29:02|  always_direct = 0
    2009/01/13 09:29:02|  never_direct = 1
    2009/01/13 09:29:02|    timedout = 0
    2009/01/13 09:29:02| Failed to select source for->[url]http://10.49.7.140/8/MRQ'[/url]
    2009/01/13 09:29:02|  always_direct = 0
    2009/01/13 09:29:02|  never_direct = 1
    2009/01/13 09:29:02|    timedout = 0
    2009/01/13 09:33:51| Detected DEAD Parent: 10.49.49.49
    2009/01/13 09:33:51| Failed to select source for->[url]http://10.49.49.49/squid-inter[/url]
    nal-periodic/store_digest'
    2009/01/13 09:33:51|  always_direct = 0
    2009/01/13 09:33:51|  never_direct = 1
    2009/01/13 09:33:51|    timedout = 0
    2009/01/13 09:33:51| temporary disabling (Gateway Time-out) digest from 10.49.49
    .49
    2009/01/13 09:43:51| Failed to select source for->[url]http://10.49.49.49/squid-inter[/url]
    nal-periodic/store_digest'
    
    Über den Browser auf NB1 bekomme ich aber Zugang (Firefox + IE). Also ist meine Vermutung, dass die Config von Squid noch nicht korrekt ist (scheint mir auch nicht überraschend ;), steh wie gesagt noch am Anfang). Die sieht wie folgt aus:

    Code:
    acl all src all
    acl manager proto cache_object
    acl localhost src 127.0.0.1/32
    acl to_localhost dst 127.0.0.0/8
    acl localnet src 192.185.1.0/24
    acl SSL_ports port 443
    acl Safe_ports port 80# http
    acl Safe_ports port 21# ftp
    acl Safe_ports port 443# https
    acl Safe_ports port 70# gopher
    acl Safe_ports port 210# wais
    acl Safe_ports port 1025-65535# unregistered ports
    acl Safe_ports port 280# http-mgmt
    acl Safe_ports port 488# gss-http
    acl Safe_ports port 591# filemaker
    acl Safe_ports port 777# multiling http
    acl CONNECT method CONNECT
    http_access allow all
    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localnet
    http_access allow all
    icp_access allow localnet
    icp_access deny all
    http_port 3128 transparent
    cache_peer 10.49.49.49 parent  80 80 default login=WoebbekS:Kennwort
    hierarchy_stoplist cgi-bin ?
    cache_dir ufs d:/squid/var/cache 100 16 256
    access_log d:/squid/var/logs/access.log squid
    logfile_daemon d:/squid/libexec/logfile-daemon.exe
    cache_log d:/squid/var/logs/cache.log
    cache_store_log d:/squid/var/logs/store.log
    mime_table d:/squid/etc/mime.conf
    pid_filename d:/squid/var/logs/squid.pid
    unlinkd_program d:/squid/libexec/unlinkd.exe
    refresh_pattern ^ftp:14400,210080
    refresh_pattern ^gopher:144001440
    refresh_pattern -i (/cgi-bin/|\?) 000
    refresh_pattern .00,24320
    acl shoutcast rep_header X-HTTP09-First-Line ^ICY\s[0-9]
    upgrade_http0.9 deny shoutcast
    acl apache rep_header Server ^Apache
    broken_vary_encoding allow apache
    icon_directory d:/squid/share/icons
    error_directory d:/squid/share/errors/English
    never_direct allow all
    dns_nameservers 10.49.3.69 10.49.6.13
    coredump_dir d:/squid/var/cache
    
    Hilft da auch noch ein Schnipsel aus dem Log?

    Code:
    1231835341.972   31 192.185.1.101 TCP_MISS/407 1220 GET [url]http://de.wikipedia.org/wiki/Wikipedia:Hauptseite[/url] - TIMEOUT_DEFAULT_PARENT/10.49.49.49 text/html
    1231835342.003   31 192.185.1.101 TCP_MISS/407 1220 GET [url]http://de.wikipedia.org/wiki/Wikipedia:Hauptseite[/url] - TIMEOUT_DEFAULT_PARENT/10.49.49.49 text/html
    1231835342.003   0 192.185.1.101 TCP_MISS/504 1635 GET [url]http://de.wikipedia.org/wiki/Wikipedia:Hauptseite[/url] - NONE/- text/html
    1231835342.019   0 192.185.1.101 TCP_MISS/504 1607 GET [url]http://de.wikipedia.org/favicon.ico[/url] - NONE/- text/html
    1231835342.081   0 127.0.0.1 TCP_MISS/504 1585 POST [url]http://10.49.7.140/8/MRQ[/url] - NONE/- text/html
    1231836239.175   0 192.185.1.101 TCP_MISS/504 1589 GET [url]http://news.google.com/?[/url] - NONE/- text/html
    
    Vielleicht sieht ja jemand auf Anhieb die Nadel im Heuhaufen, ich hab schon etliches probiert, bin aber nicht weitergekommen. An vielen Stellen fehlt mir auch (noch) das Hintergrundwissen, das will ich mir mit diesen Experimenten auch erschliessen.

    Herzlichen Dank & viele Grüße
    Stephan
     
  2. Gibt's echt keine Lösung dafür? Scheint mir ja unwahrscheinlich... Bin ich da so sehr auf dem Holzweg??? Hmmm, weiss nicht recht, wie ich da jetzt weitermachen kann...
     
Die Seite wird geladen...

Squid: Bekomme keine Verbindung über (parent) Firmenproxy - Ähnliche Themen

Forum Datum
SQUID unter WINDOWS Server 2008 FTP Authentifizierung ermöglichen, WIE ? Windows XP Forum 22. Okt. 2013
SQUID: Proxy alle Anfragen weiterleiten Windows XP Forum 26. März 2013
Squid auf W2K8 Server nur von innen erreichbar Netzwerk 12. Jan. 2012
Squid fuer eine Domain Windows XP Forum 22. Aug. 2009
Re: [TUT] Squid Proxy-Server unter Windows & Linux Windows XP Forum 28. Juli 2006