Suse Linux Win XP und MTBR

Dieses Thema Suse Linux Win XP und MTBR im Forum "Linux & Andere" wurde erstellt von duffy, 14. Okt. 2004.

Thema: Suse Linux Win XP und MTBR Hallo @Alle, wahrscheinlich ist mein Beitrag schon irgendwo ähnlich verfasst...aber sorry, bin zu faul alle...

  1. Hallo @Alle,
    wahrscheinlich ist mein Beitrag schon irgendwo ähnlich verfasst...aber sorry, bin zu faul alle durchzusuchen:) Zudem ist ja jedes System mit dem Problem evtl. anders...
    Also zuerstmal mein Problem bzw. meine Frage:
    Ich habe Win Xp prof auf beiden Rechnern, ich will Suse LInux 9.0 prof. parallel zu Win XP nur auf dem 1.PC installieren, habe aber Angst davor den MTBR mit dem Grub (?) Bootmanager zu verändern, weil ich Win XP und vor allem die übrigen vielen Partitionen behalten will, wegen all der vielen Daten/Dateien;)
    Habe zwar momentan so ziemlich alles gesichert, auch ein Image von der Win-Part. gemacht, aber will nicht alles neu inst. usw...ggf. könnte ich auch einen Testrechner nehmen, aber ob der Win XP aushält???
    Hinzu kommt, dass ich bereits Linux auf dem 1.PC installiert habe, am Besten erstmal eine Übersicht meines Systems:
    1. PC= Asus A7n8X-Deluxe (Bios Rev. 1.04, NForce2 Chipsatz) mit AMD Athlon XP 2800+, 1024 GB Ram, 1.HDD=SATA Samsung SP1614C (SI 3112 Onboard SATA-Controller) 160 GB, 2.HDD=IDE IBM (älter...UDMA 100) 40 GB als Master/1.IDE-Controller, Ati All-in-Wonder 8500 DV, Sound, Lan (Nvidia,3Com), etc on Board..., an Peripherie: Logitech Maus/Tastatur MX (Maus:MX700 optisch/funk), Rest jetzt nicht so wichtig.
    2.PC=AMD...Rest glaube ich nicht wichtig, da dort nur Win XP prof. läuft, allerdings soll da auch mit LInux über 1.PC ein Netzwerk bzw. ICS entstehen:)
    Wichtig hier wäre zu erwähnen, dass er am Inet hängt (DSL) und über ICS/Netzwerk (standard) mit dem 1.PC verbunden ist.

    Mit Win Xp klappt alles, was klappen soll, aber nun soll eben Linux auf dem 1.PC als Zweitsystem installiert werden, bzw. ist es schon, und zwar NICHT AUF DER SATA-HDD, SONDERN AUF DER IDE-HDD. Dort habe ich auch bereits freie Partitionen eingerichtet (Fat32), die Linux wohl nicht haben will, es hat sich freien Platz durch Verkleinern der dort 3. und letzten Partition (keine Primär-Part.) gemacht (bzw. Ich:)) Diese Swap und Root Partitionen bestehen, eine Daten-Part. zusätzlich habe ich nicht. Hoffe, es geht auch so?
    Aber da Linux weder die SATA Platte als Sata erkannt hat (wohl nur als IDE und zudem nicht in voller Grösse, nur 149 GB), bzw. den Sata-Controller mag es wohl nicht, und nur mit der DVD manuell gebootet werden kann, traue ich mich eben nicht den MTBR zu verändern, so dass ich im Linux-Bootmanager auswählen kann, zudem der Sata Treiber nicht klappt (bei mir)?
    Mit den Ati Treibern von Ati habe ich mir wohl bereits den Desktop zerschossen, Linux hängt in der Detailansicht und will das neue Display nicht laden:( Netzwerk bzw. Internet über ICS klappt bisher gar nicht, da auch die Treiber fehlen...(Nforce2 Chipsatztreiber habe ich runtergeladen, wie installieren, keine rpm Dateien?)

    Hmm ist ein wenig lang geworden, also noch mal in Kürze:
    1) Bootloader, MTBR: überschreibe ich nicht die Win-Partitionstabelle und natürlich Win als OS?
    2)Sata (SI3112) Treiber, wie installieren? Die Treiber habe ich von Asus runtergeladen
    3) LAN und ICS, wie die Treiber installieren (NForce2) und dann einrichten (IP...) Treiber ebenfalls runtergeladen
    4) Wie installiere ich überhaupt neue Hardware-Treiber? (Yast, bislang klappt es bei mir nur mit den RPM Dateien, wenn überhaupt:)) Aber wie binde, glaube diese Pakete einbinden heisst es, ich überhaupt alle nicht rpm Dateien?

    Dann, ja erst dann kann ich überhaupt mal mit Linux arbeiten, wobei die Videos/Audios bereits (die unter Win fehlerfrei laufen) bei Linux ruckeln/krachen usw. (Treiberproblem, hoffe ich!?) Auf sämtliche Partitionen, auch eben der Sata HDD kann ich voll zugreifen, auch die NTFS Part. von Windows kann Linux lesen (schreiben geht glaube ich nicht, oder?), Die DVD/CD-Rom funktionieren ebenfalls, außer Brenner, den habe ich natürlich nicht gleich probiert...

    Also schoneinmal vielen herzlichen Dank an jedwede Hilfe, und falls Rückfragen wegen Hardware, Konfiguration etc bitte im Posting fragen.
    Hoffe ihr könnt mir helfen, leider kennen sich die persönlichen PC-Stammbekannten nicht recht mit Linux aus;)

    LG,
    Duffy
     
  2. Hallo,
    @aninemo: danke aber den thread habe ich schon gelesen, kann aber keine direkte Hilfe bzw. Antworten zu meinen Fragen erkennen, auch nicht in den Links, wie ich zB mehrere Win-Partitionen booten kann...habe ja nur Win XP drauf.
    Es geht mir hauptsächlich um die Frage, ob eine Gefahr besteht, den MTBR und die Partitionstabelle so zu verändern, dass weder Win noch weiter funktioniert und natürlich die Daten auf den übrigen Partitionen weg sind?
    Wobei ich ja bestimmt erstmal die richtigen SATA-Treiber einbinden sollte...Nur wie?
    Außerdem die generelle Frage, wie ich richtig die Treiber einbinde vor allem, wenn es keine rpm-Dateien sind, wie die wohl unverzichtbaren Chipsatztreiber etc?
    Wenn Jemand mir sagen kann, dass ich nicht das ganze Handbuch/Handbücher lesen ,sowie weitere Inet-Seiten und Foren durchstöbern muss, wäre ich schon sehr froh:)
    Ich meine diese Fragen, haben doch schon Unzählige, die Linux drauf haben, hinter sich gelassen, oder nicht?

    Also dann, bis in Kürze hoffentlich;)
    Danke schonmal im voraus!
     
  3. ich habe selbst winXP und suse laufen. im MBR ist der bootloader installiert und es gibt keine probleme, eins der beiden BS zu starten. meine präferenz liegt hier bei LILO, den finde ich einfacher zu konfigurieren. aber du kannst natürlich auch grub nehmen.
    wenn dir der MBR als platz für den bootloader nicht gefällt, installier ihn halt auf eine diskette und leg sie beim starten ein, damit du zwischen windoze und linux wählen kannst.

    nforce treiber sind übrigens bei suse und vielen anderen größeren distributionen schon dabei.

    was die sonstigen treiber angeht, die nicht in RPMs daherkommen, musst du dich wohl damit abfinden, dass du dir die infos beim hersteller suchen musst (ATI z.b. ist immer *besonders* lustig zum installieren...).
    gewöhn dich dran, dass du bei linux viel lesen musst. mittlerweile funktionieren zwar immer mehr installationen per weiter-klicken, aber viele benötigen handarbeit und einlesen.
    ohne hat es keinen sinn oder du wirst dein system nicht deinen wünschen anpassen können...
     
  4. Hallo Coldfusion,
    danke für deine Hinweise, ich denke auch, dass ich noch viel (ein)lesen muss, na ja vielleicht rentiert sich das mal irgendwann- nicht nur privat;)

    Das mit dem MBR ist ja wahrscheinlich auch kein Problem, will halt nur keine waghalsigen Experimente ausprobieren und mir die Part.tabelle zerschießen.
    Wenn aber muss ich ja erst die SATA Treiber inst., sonst läuft das bestimmt gar nicht, sonst hätte ja Linux bei der automatischen Inst. bestimmt schon selbst den MBR dort verändert.
    Das mit den Nicht-RPM Treibern habe ich mir schon gedacht...habe mir mal die lange Howto in Sachen Ati durchgelesen, aber nicht alles verstanden. Kommt wohl auch davon, da ich nicht mal Skripts unter Windows geschrieben habe:(

    Na ja, mit der Diskette ist ja genauso, wie von CD/DVD. Ist ja zum Probieren auch nicht schlecht, aber keine Endlösung (siehe halt oben/SATA).

    Das mit den Nforce(2) Treibern hat aber nicht ausreichend geklappt. Z.B. die Lan Nics, ... funktionieren ja nicht oder nur sehr schlecht (Sound). Hingegen USB und sogar Firewire hat das System angeblich erkannt, habe es aber noch nicht ausprobiert.
    Tja, soviel ich ja auf Logitech schwöre, in Sachen Maus, Tastatur, etc, musste ich arg staunen, dass die gar keine Linux Treiber im Angebot haben (!?) und Linux auch nicht*grrr* Deswegen klappt mein Mausrad zB. gar nicht.

    Zudem habe ich wohl bereits die Display Treiber (Original Ati Linuxtreiber!) zerschossen und kann nicht mehr ins System, wie rückgängig machen (kenne nicht die Befehle und Kommandos im Linux Boot System)?
    Oder muss ich das ganze System neu inst.

    Aber ich bin weiterhin zuversichtlich und ich weis eben, von Nichts kommt Nichts,hihi

    Also, danke schonmal:)
    LG
    duffy
     
  5. Hi Duffy

    also wenn ich richtig verstanden hab geht einiges nicht so recht bei Dir ? Du hast ne Suse Distri ? welche denn ? gib mal mehr infos zu deinen einzelen Problemen - nur dann kann man Dir ggf. helfen ;)

    Wenn Du nur noch in die Konsole kommst da die Grafik-Konfig zerschossen ist - dann log Dich als root ein und starte Yast oder Sax2 zum neu einrichten - danach sollte es wieder funktionieren. Bei kleinen Problemen muss man nich gleich alles neuinstallieren oder machst Du das unter Windws auch ? :)

    VG Bernd
     
  6. Hallo Codex1,

    danke für dein Posting.

    Richtig! Es geht so einiges nicht recht bei mir;))

    Also, dass mit der Konsole sieht in etwa so aus:
    bin als root eingeloggt, wenn ich yast aufrufe (yast eingegeben!??) kommt nur sowas wie unknown command oder invalid command...wenn ich sax2 eingebe (genauso) dann steht da: ebenfalls invalid oder unknown command aber dann noch: runlevel3 erforderlich, bitte wechseln zu runlevel 3...(runlevel 3 eingeben bringt natürlich nichts!). Wie gesagt kenne noch nicht die Befehlsstruktur in der Konsole. Gibt es da ne Übersicht, was man wie alles eingeben kann?

    Ich habe die Distri von Suse und zwar die 9.0 (nicht 9.1 etc) prof. auf DVD bzw. CD´s.
    Der Kernel ist der 2.4.xx (hmm), wie update also kompiliere ich denn einen neuen Kernel (zB. den 2.6.xx?)?
    Mein System steht ja ganz oben beschrieben, wie gesagt die SATA-HDD will nicht als solche funktionieren, ich weiß halt nicht, wie ich die Treiber von SiliconImage (3112 onboard Controller) bzw. ASUS installiere/einbinde, es sind keine RPM-Dateien?!

    Das Gleiche gilt für die ATI Treiber, wobei es da schon RPM Dateien gibt, die allerdings Linux nicht mehr booten lassen (siehe oben>Display Problem), geschweige denn 3D Beschleunigung oder TV Funktionen...

    Dann ist da noch das Netzwerk und Inet über ICS (siehe oben), das ist aber denke ich jetzt erstmal unwichtig;)

    Tja welche Detail-Infos soll ich denn noch liefern?
    Natürlich installiere ich Windows nicht wegen so nem Kleinkram neu, da habe ich schon weit grössere Probleme ohne Neuinst. behoben.
    Aber bei Linux bin ich eben ein Newbie...

    Also in diesem Sinne,

    LG
    duffy
     
  7. Hi Duffy,

    - zu dem Punkt - Befehlsübersicht - wenn Du in der Konsole arbeitest kann Du Dir die einzelnen Befehle über --help aufrufen, Einzelheiten zu einem Befehl entweder über: Befehl als Beispiel mal make diretory: md --help oder ein Manual über einen Befehl: man 8 runlevel man = manual 8=für Administrator-Info runlevel=hier einfach welches Manual

    - runlevel 3 bedeutet - dein System läuft aber im Moment noch ohne grafische Oberfläche - mit grafischer Oberfläche bist Du im runlevel 5

    - die SATA - Platte würd ich im Moment als zweitrangig ansehen - :) zum kompilieren oder installieren der einzelnen Treiber ohne rpm - benötigst du einige Programme wie, Kompiler, make, make install usw. die wahrscheinlich noch nicht alle installiert sind deshalb wäre ein einfaches graphisches System zur Fehlersuche mal nicht schlecht.

    - zum Starten - wenn ich richtig gelesen hab startest Du im Moment üver die DVD - das heisst DVD startet und Du sagst dann starte installiertes BS? Wenn Du dich unter root einlogst sollte an der Konsole der befehl: yast oder yast2 das Kontrollzentrum öffnen. Wenn wieder die Fehlermeldung kommt Befehl unbekannt geb mal: su - ein danach sollte er nach dem root-passwort fragen und du kommt in die root-Konsole, dann nochmal yast oder yast2 versuchen. Dann sehen wir mal weiter :)

    VG Bernd
    ( Linux ist immer ein Lernprozeß - aber ich fand den Umstieg von Amiga auf 386PC damals auch als sehr beschwerlich :D :eek: )
     
  8. Hallo Codex1,

    vorab danke, du hast mir damit (s.oben) jetzt praktisch weitergeholfen;) nach sowas habe ich gesucht...

    leider melde ich mich (noch) nicht aus linux heraus hier im forum, aber mein desktop ist wieder heile. der befehl su - hat geklappt. ohne den konnte ich yast allerdings nicht öffnen! bin dann in yast, das ja sehr übersichtlich gemacht ist, auch ohne grafikoberfläche, so ne art dosmodus für die Konfig.!?
    dort habe ich die display treiber re-inst. er zeigt auch treiber für tv an, aber noch nicht konfiguriert. habe gleich noch etliche pakete als software inst. und dann kam nach dem booten wieder der gute alte kde etc. mit yast kann ich auch eine sicherungskopie der config machen, nicht wahr? nur wie binde ich die dann im falle des falles wieder ein, auch aus der konsole heraus?
    tja aber bei yast konnt ich auch noch nicht die sata platte einrichten, obwohl er den controller gefunden hatte aber eben kein gültiges modul dafür, bzw. den treiber nimmt er nicht an, stürzt dann ab bzw. friert ein...!? wie komme ich da jetzt weiter, indem ich nun vorher diese zusatzmodule installiere (compiler...)? muss ich da erstmal den neuen kernel (2.6.xx) kompilieren, damit zB die Ati richtig installiert werden kann?

    Also, jedenfalls vielen Dank schonmal für die Hilfe, wenn´s Dir keine allzugrosse Mühe macht...bin für weitere Hilfe sehr offen*g*

    LG,
    duffy

    p.s. nette webseite hast du da, bist du ein echter astronomie-fan?
     
  9. Hi Duffy,
    erstma danke :) jepp Astronomie is ein kleines Steckenpferd von mir nur leider zu wenig Zeit :)

    So nun zu deinen Fragen - Du hast jetzt mal in der alten Oberfläche gearbeitet - das war glaub ich bis Suse 5 oder so is schon lange her :)

    Als erstes würd ich jetzt ein online update machen ( über Yast2 ) sofern Du eine Internet Verbindung hinbekommt - gehts Du über Modem oder DSL oder Lan ? Das wäre für mich jetzt mal vorrangig und danach können wir uns um die Platten usw. kümmern.

    Einen Kernel kompilieren usw brauchen wir für deine Platten Treiber nicht - das wär bischen zuviel des Guten ;) - aber hier ists wie bei allem in Linux - viel Lesen hilft viel - Gute HowTo`s und Anleitungen findest Du auch auf

    http://www.linuxforen.de/forums/index.php

    VG Bernd
     
Die Seite wird geladen...

Suse Linux Win XP und MTBR - Ähnliche Themen

Forum Datum
500 Internal Server Error | PHP | Linux SuSe 10 Webentwicklung, Hosting & Programmierung 17. Apr. 2012
Apache2 unter Suse Linux und ZIP-Dateien Linux & Andere 24. März 2009
VirtualBox 64Bit unter Vista mit einem Opensuse 11.1 32 Bit Linux Gast Virtualisierung & Emulatoren 24. Feb. 2009
Linux OpenSuse 11 auf VISTA installieren?!?! Linux & Andere 28. Juli 2008
Linux SUSE 9.2 Linux & Andere 12. Mai 2008