Sverweis und #NV (Excel 2000)

Dieses Thema Sverweis und #NV (Excel 2000) im Forum "Microsoft Office Suite" wurde erstellt von Don Sebastiano, 11. Mai 2013.

Thema: Sverweis und #NV (Excel 2000) Aloha! Ich bin gerade dabei, meine Fußballtabellen zu modernisieren und einige Abläufe im Hintergrund weiter zu...

  1. Aloha!

    Ich bin gerade dabei, meine Fußballtabellen zu modernisieren und einige Abläufe im Hintergrund weiter zu automatisieren.
    Dazu habe ich auf dem ersten Tabellenblatt die normale Liga-Tabelle stehen.
    Auf einem anderen Tabellenblatt stehen die Ergebnisse der Mannschaften, sowie die Anzahl der Siege, Unentschieden und Niederlagen.
    Ich versuche mittels SVERWEIS die Daten für Sieg, Unentschieden, Niederlage, Tore und Gegentore aus der Ergebnistabelle auszulesen. Die Formal sieht wie folgt aus:
    =SVERWEIS(C5;Kreuz!$BH$3:$CL$20;26;0)

    C5 ist die Zelle in der Ligatabelle mit dem Mannschaftsnamen
    Kreuz! ist das Tabellenblatt mit den einzelnen Ergebnissen
    BH3 bis CL20 der Bereich in dem die gesuchten Daten stehen
    26 die Spalte in der die Summe der (hier Siege) steht

    So, ich habe die Formel zunächst nur für Mannschaft A angelegt und alle Daten werden korrekt ausgelesen.
    Kopiere ich die Formel in die Zeilen für die anderen Mannschaften (Bezüge zu der Matrix sowie dem Suchkriterium bleiben korrekt!) werden entweder nur Nullen oder der Fehler #NV ausgegeben. Auch dann wenn ich die Formel manuell neu eingebe bleiben bei allen anderen Mannschaften die Fehler bestehen. Dabei spielt es keine Rolle, on der vierte Parameter eine 0, eine 1 oder leer bleibt.
    Es ist sichergestellt, dass sich keine Schreibfehler in den Suchkriterien befinden.
    Also, wo liegt der Fehler bitte?
    Anbeit mal zwei Fotos von der exemplarischen Tabelle.
     
  2. Hallo Don Sebastiano,

    BH ist die erste Spalte deiner Matrix. Wenn ich denn richtig zähle stehen die Siege in Spalte 25 (CF) und nicht in 26 (CG).

    Um solche Verrechner zu vermeiden könntest du die Spalte in sVerweis mit folgender Formel bestimmen:
    Code:
    SPALTE($CF1) - SPALTE($BH1) +1
    Gruß Matjes :)
     
  3. Hallo Matjes,

    ja, hmm, einfach dumm von mir.
    Da konnte ich wohl nicht zählen.
    Bleibt noch das zweite Problem:
    In der Tabelle sollen ja auch die Torverhältnisse dargestellt werden.
    Auch dies funktioniert nicht (diesmal wirklich kein Schreibfehler).
    Die Formel hierfür lautet:
    =SVERWEIS(C5;Kreuz!$BH$3:$BK$20;2)
    C5 bezieht sich auf den Mannschaftsnamen
    BH3 bis BK20 ist die Matrix (auf dem zweiten Bild oben zu sehen)
    2 die Spalte der geschossenen Tore (analog dazu 4 für die Gegentore).
    In der Tabelle unten müssten die Torverhältnisse mit 1:0 beginnend mit 18:0 zu enden.
    Wo ist da nun der Fehler?
     
  4. Schick mir mal die Datei (mail-Adresse in der PM).
    Dann schau ich mal warum es nicht klappt. So ist das nicht zu erkennen.

    Gruß Matjes :)
     
Die Seite wird geladen...

Sverweis und #NV (Excel 2000) - Ähnliche Themen

Forum Datum
Excel 2013 SVERWEIS ergibt bei Tabellenübergreifender Nutzung 0 Microsoft Office Suite 16. Sep. 2015
SVerweis weigert sich hartnäckig StarOffice, OpenOffice und LibreOffice 21. Mai 2010
Sverweis Funktion in Excel 2003 Windows XP Forum 2. Dez. 2009
Excel WENN DANN SVERWEIS gibt falsche Werte Zurück? Microsoft Office Suite 15. März 2008
WENN mit Sverweis verknüpfen gibt keine Zahl zurück StarOffice, OpenOffice und LibreOffice 14. März 2008