Textabhängige WENN-DANN Funktion

Dieses Thema Textabhängige WENN-DANN Funktion im Forum "StarOffice, OpenOffice und LibreOffice" wurde erstellt von Blindspot, 22. März 2005.

Thema: Textabhängige WENN-DANN Funktion Moin, Moin, es stellt sich folgendes Problem und ich hoffe hier Hilfe zu finden. Ich möchte eine Funktion...

  1. Moin, Moin,
    es stellt sich folgendes Problem und ich hoffe hier Hilfe zu finden.

    Ich möchte eine Funktion erstellen, welche die Zahlenwerte x, y, z in Zelle 1 ausgibt, abhängig von den Worten a, b, c in Zelle 2.

    Habe es schon mit der Funktion =WENN(Zelle 2='Wort a';x;0) probiert, spuckt aber immer wieder andere Sachen aus, von der Verschachtelung der Funktion mal ganz zu schweigen.

    Gibt es etwas besonderes zu beachten. wenn ich Funktionen von Texten abhängig machen möchte.

    Und noch eine kleine Frage: Gibt es die Möglichkeit Drop-Down Menüs in Tabellenzellen zu erstellen.

    Vielen Dank im Voraus
     
  2. sol
    sol
    Bei Zeichenfeldern musst Du Anführungszeichen verwenden, also:
    =WENN(Zelle 2=Wort a;x;0)
    Wenn ich mir die Aufgabenstellung so ansehe, würde ich allerdings eine andere Funktion empfehlen. Wenn ich dich richtig verstehe, heisst die Anforderung: hole mir den zum Wert in Zelle2 passenden Eintrag.

    Das ist ein typischer Fall für die Funktion SVERWEIS, die dafür flexibler und einfacher ist:
    Kennst Du die Funktion?

    Gruss
     
  3. Ne, die Funktion sagt mir jetzt nichts, werde aber gleich mal eion bißchen stöbern.
    Vielen Dank schonmal.

    Es stellt sich dann auch noch das Problem mit der Verschachtelung.
    Die sollte aber bei textabhängigen Funktionen ja normal ablaufen, oder?
     
  4. Alles klar, es lag nur an den .... Jetzt macht die Funktion genau was ich will und wann ich es will.

    Vielen herzlichen Dank ;D
     
  5. sol
    sol
    Ich versuch's mal zu erklären:
    angenommen, Du hast 5 Varianten, die Du mit WENN abfragst, dann hast Du ja so eine Formel:
    =WENN(A1=V;10;WENN(A1=W;20;WENN(A1=X;30;WENN(A1=Y;40;WENN(A1=Z;50;0)))))
    Wenn es noch mehr Fälle gibt, wird die Formel noch unübersichtlicher und wenn Du später was ergänzen oder änder willst, musst Du das für alle Zellen tun.

    Wenn Du das Ganze mit SVERWEIS machst, vereinfacht es sich so:
    Du legst irgendwo eine Tabelle an (z.B. in einem eigenen Tabellenblatt), die sieht so aus:
    A B
    1 V 10
    2 W 20
    3 X 30
    4 Y 40
    5 Z 50

    Um noch etwas mehr Komfort hereinzubringen, markierst Du diese Tabelle und gibst ihr einen Namen:
    Daten/Bereich festlegen, Name: Auswahl

    Dann genügt diese Formel: =SVERWEIS(A1;Auswahl;2;0), egal, wieviele unterschiedliche Fälle es gibt.

    In Worten: Schau nach, was in A1 steht, vergleiche das mit der ersten Spalte im Bereich->Auswahl' und hol Dir aus->Auswahl' den zugehörigen Wert aus Spalte 2.

    Wenn mehr Varianten hinzukommen, passt Du einfach den Bereich->Auswahl' an und an den Formeln musst Du nichts ändern.

    Um den Fall abzufangen, dass der gesuchte Wert nicht in der Vergleichstabelle vorkommt, kann man die Formel mit der Abfrage des Fehlerwertes #NV ergänzen:
    =WENN(ISTNV(SVERWEIS(A1;Auswahl;2;0));0;SVERWEIS(A1;Auswahl;2;0))

    Ein weiterer Vorteil ist der, dass Du eine übersichtliche Tabelle hast mit allen möblichen Varianten.

    Gruss
     
  6. Das klingt echt gut.
    Die Tabelle, welche ich gerade bearbeite hat zwar eine kleine geschlossene Menge an Varianten, aber ich werde mir diese formel merken für spätere Tabellen.

    Danke auf jeden Fall.

    Frohe Ostern
     
  7. sol
    sol
    Wünsche ich Dir auch.

    Und als Ergänzung zum bisherigen:
    In so eine Tabelle kann man auch die Namen von Zellvorlagen aufnehmen und diese mit
    +VORLAGE(SVERWEIS....)
    bzw.
    &T(VORLAGE(SVERWEIS....))
    in eine Formel einbinden.
    Dies für den Fall, dass man unterschiedliche Formatierungen benötigt und die 3 Varianten der Bedingten Formatierung nicht ausreichen. In eine Verweis-Tabelle kannst Du beliebig viele Einträge aufnehmen.
     
Die Seite wird geladen...

Textabhängige WENN-DANN Funktion - Ähnliche Themen

Forum Datum
Wenn-Dann Sonst weiter verschachtelt! Windows XP Forum 30. Mai 2005
Wenn-Dann-Sonst Funktion in Userform Microsoft Office Suite 26. Mai 2005