USB Scanner und USB Webcam

Dieses Thema USB Scanner und USB Webcam im Forum "Linux & Andere" wurde erstellt von Gandalf_the_Grey, 1. März 2005.

Thema: USB Scanner und USB Webcam Hallo Leute, ich habe mal wieder ein klitzekleines Problem mit zwei USB Geräten. Da ich es bis heute (trotz Sven's...

  1. Hallo Leute,

    ich habe mal wieder ein klitzekleines Problem mit zwei USB Geräten. Da ich es bis heute (trotz Sven's ausdauernder Hilfe) immer noch nicht geschafft habe meine beiden USB Mass Storage Devices in Debian zu aktivieren, habe ich versucht ZUMINDEST meine USB Webcam und meinen USB Scanner aktiv zu bekommen. Daraufhin habe ich ein wenig im Netz gesucht und heraus gefunden was ich alles dazu benötige. Für die Webcam den gc-usb Treiber sowie den v4l Treiber. Für den Scanner habe ich Sane installiert sowie als Grafisches Frontend Xsane. Ich habe das ganze sogar so konfiguriert das ein V4L Gerät (z.B. die Webcam) auch über Sane bzw. Xsane angesprochen werden kann. Wenn ich nun auf der Kommandozeile sane-find-scanner eingebe, erkennt er auch die zwei Geräte an libusb (das libusb Packet habe ich übrigens auch installiert). Wenn ich allerdings nun Xsane starte sagt es mit das keine Geräte gefunden wurden. Woran kann das liegen bzw. wieso kriege ich keinerlei Verbindung zu Scanner oder Webcam??

    Übrigens, ich verwende Debian Sarge mit dem 2.6.10er Kernel!!
    Habe auch schon erfolglos apm=off und noapic als Parameter in der Menu.lst mitgegeben.
     
  2. Keine Chance. Es wurden zwar beim Start das Canon Script was unter deinen Links zu finden war gestartet aber per XSane kann ich immer noch nicht scannen bzw. überhaupt ein Gerät ansprechen. Kriege immer gesagt: Kein Gerät ereichbar! Das kann aber nicht sein da ich über sane-find-scanner was finde!
     
  3. Es wäre recht hilfreich, wenn Du mal Deinen Scannertyp verraten würdest.
    In den Links geht es beispielhaft um Canon Scanner. Welchen Treiber Du für welchen Scanner nehmen mußt, erfährst Du auf der sane Webseite. Mein Canon N1240U wird z.B. mit dem Plustek Treiber genutzt.

    MfG
     
  4. Mal ehrlich frank60, ich bin nicht ganz blöd. Sane ist komplett konfiguriert und funktionierte VOR und NACH den Änderungen auf die du verlinkt hast nicht. Ich finde komischerweise über sane-find-scanner meinen Scanner an libusb. Was bedeutet das der Scanner von sane zumindest erkannt wird. Ich kriege eine entpsrechende Product und Hersteller ID. Diese habe ich auf entsprechend für die Scripte genommen. Auch für die Webcam sind alle nötigen Treiber installiert. Ich kann Tutorials lesen und Sie befolgen. Das Problem scheint aber leider (mal wieder) tiefer zu liegen. Danke für die Tipps, die haben aber leider nicht weiter geholfen. Wenn das so weiter geht fliegt Linux eh wieder von der Platte. Denn bei mir funktionieren 0 von 3 USB Geräten und das kann eigentlich nicht sein. Es haben sich auch schon andere Leute die Zähne dran ausgebissen und ich habe es mittlerweile satt mich mit so nem banalen sch*** auseinander zu setzen. Bitte nicht falsch verstehen, meine Wut ziehlt nicht auf dich sondern dieses verfluchte Debian. Mittlerweile ist mein System migriert und es läuft immer noch nix. Mal ganz davon abgesehen das mein System mittlerweile wohl so verhunzt ist das da viel zu viel nicht mehr läuft.
     
  5. Ich werde mich hüten, Dir noch einmal zu helfen zu versuchen.

    *PLONK*
     
  6. Och Kerle...

    Er hat's doch nicht so gemeint ;)

    Gruß
    Sven
     
  7. Letzteres hatte ich nicht gelesen. ;) Nach dem ersten Satz hatte ich eigentlich mit dem Thread abgeschlossen.
    Dann also doch noch einmal.
    Das Problem ist NICHT Debian. Dieses Problem gilt auch für andere Distributionen. Lediglich das angeblich so schlechte SuSE nimmt dem User diese Arbeit ab.
    Es ist wirklich so, daß in der Scannerliste des sane Projektes nachgelesen werden muß, welcher Treiber welchen Scanner unterstützt. Deshalb auch meine Frage, um welchen Scanner es sich handelt. Und in dessen Datei müssen die Angaben zum Scanner eingetragen werden. Also, wie in meinen Beispielen, werden die Angaben zu den genannten Canon scannern nicht in der Datei canon, sondern in der Datei plustek eingetragen. Dann klappts auch mit dem scannen.

    MfG
     
  8. Ich werde mich heute mittag eh nochmal dran setzen, dann schreib ich hier genau um welche beiden Geräte es sich handelt. Ich war mir aber relativ sicher das ich die einträge richtig gemacht habe. Zumindest die Webcam müsste über den v4l Treiber funktionieren. Aber das ist eine andere Sache. Ich habe/hatte halt das Gefühl das es ein Problem zwischen USB und Debian ist. Denn ich kriege ja z.B. auch seit WOCHEN nicht meine USB Mass Storage Geräte zum laufen. Nachdem ich jetzt erstmal ALLES radikal im System auf Auslieferngszustand zurück gebaut habe bleiben eigentlich derzeit nur noch die Probleme mit USB Scanner (Canon), USB Webcam (Dexxa Webcam, baugleich zu einem Modell von Logitech) und meinen zwei USB Mass Storage's (Digital Kamera Kodak DX4350 und MP3 Festplatten Player Gemini Archos 120).

    Wie gesagt, nochmal sorry für den Ton, aber das ging WIRKLICH nicht gegen dich. Ganz im Gegenteil. Bin ja froh das sich überhaupt noch einer die Mühe macht.

    Ich grase derzeit ungelogen TÄGLICH mindestens 6 Foren wegen meiner Probleme mit dem USB Müll ab und KEINER, wirklich KEINER konnte mir bisher helfen. Alle Probleme haben sich bisher irgendwie lösen lassen. Manche gleich, manche erst nach längerem suchen. Aber das USB Problem besteht weiter *seufz*
     
Die Seite wird geladen...

USB Scanner und USB Webcam - Ähnliche Themen

Forum Datum
Scanner-Unterstützung in PSE 12 Windows 10 Forum 5. Okt. 2016
Win10 erlaubt keine externen Scanner? Windows 10 Forum 11. Juli 2016
suche Treiber für Mustek Scanner 1200 usb plus Treiber & BIOS / UEFI 2. März 2015
Problem mit Scanner Treiber & BIOS / UEFI 22. Sep. 2014
Scanner Epson Perfection V330 Photo auf W98 Windows 95-2000 12. Sep. 2014