User-Benutzer-Ordner

Dieses Thema User-Benutzer-Ordner im Forum "Windows 8 Forum" wurde erstellt von BigWoelfi, 20. Dez. 2013.

Thema: User-Benutzer-Ordner Hallo, vor längerer Zeit schon hatte ich unter Windows 7 und, nach Installation von Windows 8 wieder, meinen...

  1. Hallo,

    vor längerer Zeit schon hatte ich unter Windows 7 und, nach Installation von Windows 8 wieder, meinen Ordner aus dem Systemordner Benutzer nach D: verlegt und dazu die Funktion Pfad aus den Eigenschaften der Ordner benutzt.

    Das hat auch so weit alles funktioniert, nur dass mir damals nicht aufgefallen war, dass ich Unter C:\ Benutzer angezeigt bekam und für den neuen Ort Users, so dass ich das so übernommen hatte. Es stand ja auch da, dass von C:\Users\Wolfgang nach D:\Users\Wolfgang verlegt wird.

    Jetzt habe ich die Aktion noch einmal gemacht und beim Verschieben den Ordner auf Benutzer geändert habe.
    Das hat auch so weit geklappt, mit der Ausnahme, dass einige installierte Programme das nicht selbst erkennen und in den Optionen der Programme Anpassungen vorzunehmen sind, wie zum Acronis-TI für die Synchronisation oder in iTunes der Ordner für die Mediathek.

    Jetzt bekomme ich aber trotzdem nach jedem Neustart immer wieder den Ordner D:\Users\Wolfgang\Music angezeigt, obwohl ich den jetzt komplett schon mehrfach gelöscht habe. Da sind auch keine unsichtbaren Dateien drin, alles leer. Trotzdem scheint noch ein Programm darauf zuzugreifen.

    Woran kann es liegen?
    Ist es ratsam, die ganze Registry danach abzusuchen oder ist es normal, dass der Ordner Benutzer nach dem Verlegen der Daten auf D: automatisch als Users angezeigt und durch Windows nicht selbst in Benutzer geändert wird?

    Ich habe auf jeden Fall mit TI Images vorher von dem kompletten Ordner D:\Users, mit allen Unterordnern sowie vom C: angelegt.

    Was das hier für ein schrottiger Editor?
    Warum kennt der keine Anführungszeichen, wie sie auf jeder Tastatur vorhanden sind.
    Das ist jetzt die 2. Änderung, weil ich beim ersten Mal dachte, dass ich sie vergessen hätte.
     
    Zuletzt bearbeitet: 20. Dez. 2013
  2. Niemand eine Antwort zu dem Problem?

    Ich habe jetzt herausgefunden, dass die Datei Desktop.ini mit kopiert werden muss und dass der Ordner Users schreibgeschützt sein muss. Schreibschutz war bereits vorhanden. Desktop.ini habe ich nachträglich hinein kopiert. Trotzdem funktioniert die Umwandlung in die Bezeichnung Benutzer nicht.

    Möglicherweise ist das anders, wenn man den kompletten User-Benutzer-Ordner verschiebt. oder gleich den gesamten Users-Ordner, mit allen Profilen, so dass dann neue Profile gleich auf der neuen Partition vom System angelegt werden.
    Aber ist es überhaupt ratsam, den kompletten Inhalt des User\Benutzer-Ordners zu verschieben?Da wäre dann ja auch AppData und ähnliche Dinge dabei, die gar keine Pfad-Funktion besitzen.
    Dafür gebe es auch ein Programm sogar - SafeMe2 zum Beispiel, leider alles auf englisch.

    Es gibt eine Anleitung in einem anderen Forum, wie man den kompletten User-Ordner, nicht nur den eigenen, auf eine andere Partition verschiebt.
    Was passiert dann bei einem Update wie von Win8 auf Win 8.1 zum Beispiel?
    Gibt das dann Schwierigkeiten?
    Muss man vorher alles rückgängig machen oder werden solche Änderungen beim Update erkannt und berücksichtigt?
    Das wäre eine Menge manuelle Arbeit sonst wieder, da SafeMe2 als Auswahl zunächst zwar alle User anzeigt, jedoch bei Remove nur noch meine eigenen Inhalte.
     
  3. Bei Windows 7 und 8 (und Vista) werden alle Systemordner in der englischen Sprache angelegt, also auch C:\Users und nicht C:\Benutzer. Der Explorer zeigt einen in die jeweilige Landessprache übersetzen Namen an, also C:\Benutzer. Wenn Du im Explorer-Fenster ganz oben in der Zeile mit den kleinen schwarzen Dreiecken im freien Bereich dahinter kurz anklickst, dann wird statt dieses Schwindelnamens C: > Benutzer > Wolfgang der korrekte Name angezeigt, auch mit linken Schrägstrichen statt der Dreiecke, also C:\Users\Wolfgang.

    Die sicherste Art, Daten zu speichern, ist die, ausserhalb der Windows-Ordner.
    Wenn Du Dir einen Ordner C:\Wolfgang mit den Unterordnern Fotos, Musik, Word-Dokumente, Excel-Tabellen usw. anlegst, dann zeigt auch der Explorer diese Namen immer korrekt an. Die Schwindelnamen werden nur in den Windows-Ordnern angezeigt.
     
    Zuletzt bearbeitet: 31. Dez. 2013
  4. Hallo hkdd,

    ich habe das jetzt noch einmal umgestellt.
    Zunächst die INI-Datei umbenannt und Explorer neu gestartet, damit der Benutzerordner auf D: zunächst als User angezeigt wurde.
    Dann eigene Ordnerstruktur mit Benutzer\Wolfgang\[Unterordner] erstellt.
    Anschließend alle Ordnerinhalte aus D:\Users\Wolfgang[Unterordner] nach D:\Benutzer\Wolfgang[Unterordner] verschoben mittels Pfad-Funktion.

    Viele Programme erkennen das so nicht, so dass ich in den Programmen bei den Pfaden wieder manuell nachbessern musste.
    Es wundert mich aber, dass es ausgerechnet die Microsoft-Programme, wie Office 365 und SkyDrive sind, die sich das nicht vollständig aus der Registry auslesen, obwohl es ja tatsächlich drin zu finden ist.

    Dann lass ich mich mal überraschen, was beim nächsten großen Update passiert bzw. ob das alles so richtig übernommen wird oder erhalten bleibt.

    Nachtrag:
    Ich meine, dass die Ordner "Gespeicherte Spiele" (Saved Games) und "Kontakte" (Contacts) eigentlich auch eine Registerkarte "Pfad" besaßen.
    Wo kann die abhanden gekommen sein bzw. wie bekommt man die zurück, wenn sie weg sind?
    Für diese beiden Ordner musste ich die Anpassung in der Registry übrigens manuell vornehmen, da ich die Ordner manuell verschoben haben, um den Hauptordner "Users" leer zu bekommen.
     
    Zuletzt bearbeitet: 2. Jan. 2014
  5. Ich hätte D:\Wolfgang\... mit Unterordnern angelegt. Wozu D:\Benutzer\... Damit kommst Du evtl. in Ärgernisse mit Windows. Das Wort Benutzer ist überflüssig, wie ein Kropf. Mit D:\Wolfgang kommt Windows nicht ins Gehege.
     
  6. Das habe ich jetzt noch mal so umgestellt, also ohne "Benutzer" und die fehlenden Registerkarten "Pfad" haben sich komplett nach der manuellen Bearbeitung der Registry, die ich erwähnt hatte, auch wieder angefunden, so dass ich sie diesmal auch nutzen konnte.

    Die manuelle Anpassung in den Microsoft-Programmen ist mir dennoch wieder nicht erspart geblieben.

    Dann warten wir mal ab, wie sich die Verlegung in der Zukunft verhalten wird.

    Danke für die Hinweise.