Verschachtelte Excel-Funktion

Dieses Thema Verschachtelte Excel-Funktion im Forum "Microsoft Office Suite" wurde erstellt von wir96clo, 28. Feb. 2005.

Thema: Verschachtelte Excel-Funktion Hallo Profis, ich sitze gerade vor einer kleinen Excel-Tabelle, ähnlich einer Taschengeld-Verteilung  :) Die...

  1. Hallo Profis,

    ich sitze gerade vor einer kleinen Excel-Tabelle, ähnlich einer Taschengeld-Verteilung  :)

    Die B-Spalte enthält Zahlenwerte im Bereich von 0 bis 20 und die C-Spalte vier zugehörige Vornamen, wie folgt:

    [table]
    [tr]
    [td]B[/td]
    [td]C[/td]
    [/tr]
    [tr]
    [td]15[/td]
    [td]Stefan[/td]
    [/tr]
    [tr]
    [td]12[/td]
    [td]Silvia[/td]
    [/tr]
    [tr]
    [td]3[/td]
    [td]Martin[/td]
    [/tr]
    [tr]
    [td]19[/td]
    [td]Stefan[/td]
    [/tr]
    [tr]
    [td]11[/td]
    [td]Stefan[/td]
    [/tr]
    [tr]
    [td]11[/td]
    [td]Martin[/td]
    [/tr]
    [tr]
    [td]19[/td]
    [td]Silvia[/td]
    [/tr]
    [tr]
    [td]4[/td]
    [td]Stefan[/td]
    [/tr]
    [tr]
    [td]13[/td]
    [td]Silvia[/td]
    [/tr]
    [tr]
    [td]18[/td]
    [td]Martin[/td]
    [/tr]
    [tr]
    [td]15[/td]
    [td]Alexandra[/td]
    [/tr]
    [tr]
    [td]9[/td]
    [td]Alexandra[/td]
    [/tr]
    [/table]

    ...usw. Das ganze kann sich theoretisch bis B/C65535 fortsetzen.

    Frage: Welche Funktion gibt mir den Durchschnitt von B für z.B. Martin an?
    (Beispiel Taschengeld: Wenn man davon ausgeht, das so chaotisch wie in der Tabelle das Taschengeld an die 4 Kids ausgezahlt wird - wie hoch ist der durchschnittliche Geld-Betrag für jedes Kind (hier z.B. Martin)?)

    Ciao und danke für jede Hilfe!
     
  2. Hi,
    zweite TAbelle erstellen,
    dort alle Namen auflisten die ben vorkommen können,
    dahinter zählen wie oft der Name in der ersten Tab anggeführt ist (zählenwenn)
    nächste Spalte mit Summe wenn den gesamten Betrag ermitteln.
    Gesamter Betrag / Anzal = durchschnitt. Damit sieht man dann auch, wie oft gezahlt wurde.
    Anosnten gibt es (soweit ich weiss) auch eine ø Funktion in xls, einfach mal die ganzen Formelhilfen durchgehen.
     
  3. Klasse, dank Dir habe ich das Problem mit dem Durchschnitt zweistufig gelöst.

    Jetzt zurück zur nächsten Hürde:

    Welche Funktion kann ich bemühen, um den maximalen und minimalen ausgezahlten Betrag jeweils für jedes Kind herauszubekommen? MAXWENN und MINWENN gibt es ja leider nicht wie SUMMEWENN...  :-[

    Hat jemand noch eine Idee?

    (Mein Problem dabei ist die Schachtelung: zuerst muß in C geschaut werden, wo jeweils Martin auftritt, dann muß dort B verglichen werden, bis der maximale bzw. minimale Wert gefunden ist...)
     
  4. Zu deinem ersten Problem gibt es eine einfachere Lösung:
    In D1 folgende Formel: =SUMMEWENN(C:C;E1;B:B)/ZÄHLENWENN(C:C;E1)
    In E1 kannst du dann den Namen reinschreiben, den du gerade auswerten willst.

    Zu deinem zweiten Problem brauchst du eine Hilfsspalte:
    in F1 folgende Formel: =WENN(C1=$E$1;B1;) (Die Dollar-Zeichen sind wichtig!) Formel runterziehen bis in Zeile 65535 (wenn du Lust hast)
    Jetzt in D2: =MAX(F:F)
    und in D3: =MIN(F:F)

    Fertig ist die Laube.
     
  5. Eine einfache Variante ist eine Pivot-Tabelle (Daten / Pivot-Table-Chart) erstellen oder sehe ich das falsch ?
     
  6. Perfekt, ihr habt mein Problem gelöst.

    Vielen vielen Dank!!
     
Die Seite wird geladen...

Verschachtelte Excel-Funktion - Ähnliche Themen

Forum Datum
Excel 2003 Verschachtelte Wenn-Funktion Microsoft Office Suite 30. Jan. 2009
Excel: Verschachtelte WENN-Abfragen anschaulich darstellen? Microsoft Office Suite 7. Dez. 2005
xml,xsl: Verschachtelte Elemente - was mache ich falsch? Webentwicklung, Hosting & Programmierung 20. Juli 2005
Verschachtelte SQL-Abfrage in MS Access Microsoft Office Suite 2. Juli 2005
Unsichtbare Textmarken in Word-Dokumentenvorlage + Felder mit Verschachtelten IF Microsoft Office Suite 19. Mai 2005